Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000408KdenliveUser Interfacepublic2008-11-24 22:332010-09-14 23:26
Reportermathias 
Assigned Toxzhayon 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSKubuntu Linux with backportsOS Version8.10
Product Version0.7.0 
Target VersionFixed in Version0.7.3 
Summary0000408: Cannot resolve system encoding
DescriptionError message at startup:

kdialog(8829) KLocalePrivate::initEncoding: Cannot resolve system encoding, defaulting to ISO 8859-1.

This results in that Clips with UTF-8 characters (i.e. ÅÄÖåäö) in them cannot be loaded in the Project Tree-view.

Another build (built 23 nov with builder wizard) managed to resolve system encoding and load the same files that does not work now.
Additional InformationLANG=sv_SE.UTF-8
LC_CTYPE="sv_SE.UTF-8"
LC_NUMERIC="sv_SE.UTF-8"
LC_TIME="sv_SE.UTF-8"
LC_COLLATE="sv_SE.UTF-8"
LC_MONETARY="sv_SE.UTF-8"
LC_MESSAGES="sv_SE.UTF-8"
LC_PAPER="sv_SE.UTF-8"
LC_NAME="sv_SE.UTF-8"
LC_ADDRESS="sv_SE.UTF-8"
LC_TELEPHONE="sv_SE.UTF-8"
LC_MEASUREMENT="sv_SE.UTF-8"
LC_IDENTIFICATION="sv_SE.UTF-8"
LC_ALL=
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon kbw.gdb.output.xEVJ9001 [^] (12,962 bytes) 2008-11-24 22:33
cpp file icon main.cpp [^] (1,163 bytes) 2009-01-27 23:30

- Relationships
related to 0000358closedmadsdyd Resize clip in timeline from clip end causes clip to disappear or shrink in imported 0.5 project 

-  Notes
(0001396)
madsdyd (administrator)
2008-11-24 22:42

Confirmed for Danish too, in svn rev. 2728.
This is under Kubuntu 8.04:
LANG=da_DK.UTF-8
LC_CTYPE="da_DK.UTF-8"
LC_NUMERIC="da_DK.UTF-8"
LC_TIME="da_DK.UTF-8"
LC_COLLATE="da_DK.UTF-8"
LC_MONETARY="da_DK.UTF-8"
LC_MESSAGES="da_DK.UTF-8"
LC_PAPER="da_DK.UTF-8"
LC_NAME="da_DK.UTF-8"
LC_ADDRESS="da_DK.UTF-8"
LC_TELEPHONE="da_DK.UTF-8"
LC_MEASUREMENT="da_DK.UTF-8"
LC_IDENTIFICATION="da_DK.UTF-8"
LC_ALL=


(0001397)
madsdyd (administrator)
2008-11-24 23:10

locale charmap seems to be broken on my system:

$ locale charmap
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
ANSI_X3.4-1968

Doing
export KDE_UTF8_FILENAMES=1
does not change anything.
(0001398)
madsdyd (administrator)
2008-11-24 23:12

submitter reports
export KDE_UTF8_FILENAMES=1
seems to solve his issue.

It does not solve mine though.
(0001399)
xzhayon (developer)
2008-11-24 23:40
edited on: 2008-11-25 00:10

for me it's the same with every program

$ kwrite
kwrite(10320) KLocalePrivate::initEncoding: Cannot resolve system encoding, defaulting to ISO 8859-1.
QThreadStorage: Thread 0x29f1b050 exited after QThreadStorage 2147483645 destroyed
$ export KDE_UTF8_FILENAMES=1
$ kwrite
kwrite(10329) KLocalePrivate::initEncoding: Cannot resolve system encoding, defaulting to ISO 8859-1.
QThreadStorage: Thread 0x29f1b050 exited after QThreadStorage 2147483645 destroyed

and exporting KDE_UTF8_FILENAMES doesn't change anything... kde 4.2 beta1 is going to be released tomorrow... maybe it's something they fixed
anyway i'll google for this

(0001400)
xzhayon (developer)
2008-11-25 00:14

...but it works if a set locale to it_it.UTF-8 or da_DK.UTF-8, without KDE_UTF8_FILENAMES
sorry, i misunderstood the problem
(0001526)
danielking (reporter)
2008-12-04 11:55

same problem here.
my locale is zh_CH.UTF-8.
ubuntu kde 4.1
(0002188)
Cimmo (reporter)
2009-01-24 17:32

same issue here with locale set to: en_US.UTF-8

export KDE_UTF8_FILENAMES=1 does NOT fix the issue
(0002262)
madsdyd (administrator)
2009-01-27 23:31

Just uploaded a test program (main.cpp).

Here is a pro file for it:
SOURCES += main.cpp
TEMPLATE =app
CONFIG += qt warn_on release
LANGUAGE = C++

It *works* on my system, which leads me to believe something is broken in KDE. Will have to look further into this.
(0002634)
xzhayon (developer)
2009-04-05 09:07

project files are now forced to be utf8
don't know if it is related to "Cannot resolve system encoding" (this could be fault of kde), but utf-8 characters should work now

please, have a try
(0002704)
Cimmo (reporter)
2009-04-11 17:07

kdenlive: Revision: 3285 Last Changed Date: 2009-04-11 09:03:34 +0200 (Sat, 11 Apr 2009)

I do not have the warning in the log anymore, but leave the reporter comment further.
(0005223)
Granjow (developer)
2010-05-28 17:55

Assuming resolved due to no response.

- Issue History
Date Modified Username Field Change
2008-11-24 22:33 mathias New Issue
2008-11-24 22:33 mathias File Added: kbw.gdb.output.xEVJ9001
2008-11-24 22:33 mathias Build/Install Method => Build Wizard
2008-11-24 22:42 madsdyd Note Added: 0001396
2008-11-24 22:42 madsdyd Severity minor => tweak
2008-11-24 22:42 madsdyd Status new => acknowledged
2008-11-24 22:42 madsdyd OS => Kubuntu Linux with backports
2008-11-24 22:42 madsdyd OS Version => 8.10
2008-11-24 22:42 madsdyd Summary Cannot detect => Cannot resolve system encoding
2008-11-24 23:10 madsdyd Note Added: 0001397
2008-11-24 23:12 madsdyd Note Added: 0001398
2008-11-24 23:12 madsdyd Relationship added related to 0000358
2008-11-24 23:40 xzhayon Note Added: 0001399
2008-11-24 23:42 xzhayon Note Edited: 0001399
2008-11-25 00:10 xzhayon Note Edited: 0001399
2008-11-25 00:14 xzhayon Note Added: 0001400
2008-12-04 11:55 danielking Note Added: 0001526
2009-01-24 17:32 Cimmo Note Added: 0002188
2009-01-27 23:30 madsdyd File Added: main.cpp
2009-01-27 23:31 madsdyd Note Added: 0002262
2009-04-05 09:07 xzhayon Note Added: 0002634
2009-04-05 09:07 xzhayon Status acknowledged => feedback
2009-04-11 17:07 Cimmo Note Added: 0002704
2010-05-28 17:55 Granjow Note Added: 0005223
2010-05-28 17:55 Granjow Status feedback => resolved
2010-05-28 17:55 Granjow Fixed in Version => 0.7.3
2010-05-28 17:55 Granjow Resolution open => fixed
2010-05-28 17:55 Granjow Assigned To => xzhayon
2010-09-14 23:26 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker