Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000417KdenliveUser Interfacepublic2008-11-28 22:452010-11-19 21:51
Reportercinephiliac 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.1 
Summary0000417: Ctrl selecting multiple clips+transitions moves them to the wrong track erratically
DescriptionWhen selecting multiple clips and transitions by holding Ctrl, occasionally the items already selected will temporarily be drawn 1/2 a track higher than they should be.
Additional InformationSTEPS TO REPRODUCE:
1. Place a couple of clips overlapping on a couple of tracks in the timeline.
2. Add transitions between them.
3. Select each clip and transition by holding Ctrl and clicking on each one in the timeline.
4. Sometimes all the selected clips and transitions will "jump" 1/2 a track higher.

VERSIONS:
ffmpeg: Revision: 15948 Last Changed Date: 2008-11-27 19:32:24 -0500 (Thu, 27 Nov 2008)
mlt: Revision: 1244 Last Changed Date: 2008-11-25 16:02:20 -0500 (Tue, 25 Nov 2008)
mlt++: Revision: 1244 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2740 Last Changed Date: 2008-11-27 08:09:10 -0500 (Thu, 27 Nov 2008)
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon capture0001.ogm [^] (1,075,227 bytes) 2008-11-28 22:45
txt file icon crash_after_ctrl+click.txt [^] (11,995 bytes) 2008-12-03 19:41 [Show Content]
? file icon capture0002.ogv [^] (1,681,588 bytes) 2008-12-03 19:42

- Relationships
related to 0000427closedLeHomard different behaviours caused by how to select segments and transitions 
related to 0000367closed Wrong behaviour when moving several clips at once 
related to 0000421closedLeHomard undo is broken after moving several clips at once like in issue 0000367 

-  Notes
(0001487)
madsdyd (administrator)
2008-12-02 17:23

Some changes have been commited in Kdenlive SVN rev. 2741, could you please test if they solve this issue?

Regards

Mads
(0001512)
cinephiliac (updater)
2008-12-03 19:40

I'm not getting it as much, and for some reason it doesn't seem to happen when the clips are on the first two tracks, but it is still happening on:
Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 15992 Last Changed Date: 2008-12-03 11:49:58 -0500 (Wed, 03 Dec 2008)
mlt: Revision: 1247 Last Changed Date: 2008-12-02 03:03:53 -0500 (Tue, 02 Dec 2008)
mlt++: Revision: 1247 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2755 Last Changed Date: 2008-12-03 07:44:18 -0500 (Wed, 03 Dec 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7

I managed to get a screencapture (capture0002.ogv) and a crash report just after.
(0001626)
madsdyd (administrator)
2008-12-13 12:03

New fix commited in 2774 - could you please test this? The commit text is:

Almost solved all group move issues, still one lost synchro bug under investigation.

Could you please test it? Thanks.
(0001628)
administrator (administrator)
2008-12-13 12:16

Group move seems to work fine now, but sometimes when undoing & trying to move one clip you get a "Cannot move clip" error message and the timeline is broken. I have not been able to find the exact sequence of actions to reproduce this bug, so if anyone finds a way to reproduce this, let me know it would help me to find a fix.

regards
(0004975)
LeHomard (developer)
2010-04-10 21:03

Can't reproduce with latest svn. If the issue isn't confirmed I'll go ahead and close the bug report.

- Issue History
Date Modified Username Field Change
2008-11-28 22:45 cinephiliac New Issue
2008-11-28 22:45 cinephiliac File Added: capture0001.ogm
2008-11-28 22:45 cinephiliac Build/Install Method => Build Wizard
2008-12-02 17:23 madsdyd Note Added: 0001487
2008-12-02 17:23 madsdyd Status new => acknowledged
2008-12-03 17:23 cinephiliac Relationship added related to 0000427
2008-12-03 17:25 cinephiliac Relationship added related to 0000367
2008-12-03 17:33 cinephiliac Relationship added related to 0000421
2008-12-03 19:40 cinephiliac Note Added: 0001512
2008-12-03 19:41 cinephiliac File Added: crash_after_ctrl+click.txt
2008-12-03 19:42 cinephiliac File Added: capture0002.ogv
2008-12-13 12:03 madsdyd Note Added: 0001626
2008-12-13 12:16 administrator Note Added: 0001628
2010-04-10 21:03 LeHomard Note Added: 0004975
2010-04-10 21:03 LeHomard Status acknowledged => feedback
2010-11-19 21:51 ttill Assigned To => j-b-m
2010-11-19 21:51 ttill Status feedback => resolved
2010-11-19 21:51 ttill Resolution open => fixed
2010-11-19 21:51 ttill Fixed in Version => 0.7.1
2010-11-19 21:51 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker