Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000422KdenliveFile Loadingpublic2008-11-30 22:222008-12-29 15:37
Reportermadsdyd 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSKubuntu LinuxOS Version8.04
Product VersionRecent git 
Target VersionFixed in Version0.7.1 
Summary0000422: Kdenlive will load bogus file as jpg
Description- type this in a terminal "echo foo > test.jpg"
 - add test.jpg to the list of clips: weird, huh? It does _not_ look healthy to me :-/
 
 There should be a mechanism to check the validity of clips before accepting them on the timeline. Perhaps there already is, but this information gets lost somewhere in the kdenlive <=> mlt++ <=> mlt <=> ffmpeg chain.
Additional Information*Sometimes* this will crash kdenlive, but mostly it will just load a "bogus" image, green/red/weird stuff.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filesjpeg file icon test_jpeg_corruption.jpeg [^] (81,486 bytes) 2008-12-01 06:15


? file icon kbw.gdb.output.XmJ21170 [^] (27,482 bytes) 2008-12-02 17:12

- Relationships
related to 0000322closedddennedy Formats unsupported by ffmpg seem to crash Kdenlive rather than being blocked from opening in the first place 

-  Notes
(0001476)
cinephiliac (updater)
2008-12-01 06:14

Screenshot added and acknowledged on:
Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 15966 Last Changed Date: 2008-11-30 19:08:42 -0500 (Sun, 30 Nov 2008)
mlt: Revision: 1244 Last Changed Date: 2008-11-25 16:02:20 -0500 (Tue, 25 Nov 2008)
mlt++: Revision: 1244 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2740 Last Changed Date: 2008-11-27 08:09:10 -0500 (Thu, 27 Nov 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7

I wasn't able to get a crash, but if anyone else can it would be great to post a backtrace.
(0001478)
madsdyd (administrator)
2008-12-01 08:08

OK, its just one of those days. Back to "assigned status", and thanks ddennedy for accepting it.
(0001482)
ddennedy (developer)
2008-12-02 09:13

fixed in MLT SVN r1247
(0001485)
madsdyd (administrator)
2008-12-02 17:11

OK, this now reliably crash kdenlive. I suspect that mlt now (as intended) returns a NULL producer whenever a clip can not be loaded, but that Kdenlive (unintentionally) does not check for this, rather just assumes the producer is != NULL.

Checked using these versions:
Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 15977 Last Changed Date: 2008-12-02 16:43:47 +0100 (Tue, 02 Dec 2008)
mlt: Revision: 1247 Last Changed Date: 2008-12-02 09:03:53 +0100 (Tue, 02 Dec 2008)
mlt++: Revision: 1247 Last Changed Date: 2008-11-06 06:32:23 +0100 (Thu, 06 Nov 2008)
kdenlive: Revision: 2744 Last Changed Date: 2008-12-02 11:49:07 +0100 (Tue, 02 Dec 2008)
Qt: 4.4.1
KDE: 4.1.2 (KDE 4.1.2)
Kdenlive: 0.7

Attaching stacktrace shortly, changing issue to Kdenlive also.
(0001494)
ddennedy (developer)
2008-12-03 00:27

I can confirm that the usage of a null producer is the problem:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb5523b70 (LWP 19061)]
mlt_properties_get_position (this=0x0, name=0xb7f09775 "length") at mlt_properties.c:285
285 property_list *list = this->local;
Current language: auto; currently c
(gdb) bt
(gdb) #0 mlt_properties_get_position (this=0x0, name=0xb7f09775 "length") at mlt_properties.c:285
#1 0xb7efd3f5 in mlt_producer_get_length (this=0x0) at mlt_producer.c:378
0000002 0xb7efd93a in mlt_producer_set_in_and_out (this=0x0, in=0, out=149) at mlt_producer.c:305
0000003 0xb7edc40a in Mlt::Producer::set_in_and_out () from /home/ddennedy/kdenlive/lib/libmlt++.so.1
0000004 0x080fc065 in Render::getFileProperties (this=0x8740380, xml=@0xbffb4ea8, clipId=@0xbffb4ea4) at /home/ddennedy/src/kdenlive/src/renderer.cpp:521
(0001496)
cinephiliac (updater)
2008-12-03 04:13

@Madsys - Sorry. Changing from Assigned to Acknowledged was an accident rather than a misunderstanding. Thanks for reverting that.
(0001500)
administrator (administrator)
2008-12-03 13:50

This bug should be fixed in revision 2752 (using latest MLT)
(0001544)
madsdyd (administrator)
2008-12-06 17:21

Tested against:

ffmpeg: Revision: 16009 Last Changed Date: 2008-12-05 15:59:41 +0100 (Fri, 05 Dec 2008)
mlt: Revision: 1255 Last Changed Date: 2008-12-04 19:25:48 +0100 (Thu, 04 Dec 2008)
mlt++: Revision: 1255 Last Changed Date: 2008-12-04 23:31:49 +0100 (Thu, 04 Dec 2008)
kdenlive: Revision: 2756 Last Changed Date: 2008-12-04 22:02:58 +0100 (Thu, 04 Dec 2008)

confirmed resolved. Thanks a bunch.

- Issue History
Date Modified Username Field Change
2008-11-30 22:22 madsdyd New Issue
2008-11-30 22:22 madsdyd Build/Install Method => Build Wizard
2008-11-30 22:22 madsdyd Relationship added related to 0000322
2008-12-01 06:13 ddennedy Status new => assigned
2008-12-01 06:13 ddennedy Assigned To => ddennedy
2008-12-01 06:14 cinephiliac Note Added: 0001476
2008-12-01 06:14 cinephiliac Assigned To ddennedy =>
2008-12-01 06:14 cinephiliac Status assigned => acknowledged
2008-12-01 06:15 cinephiliac File Added: test_jpeg_corruption.jpeg
2008-12-01 08:07 madsdyd Assigned To => ddennedy
2008-12-01 08:08 madsdyd Note Added: 0001478
2008-12-01 08:08 madsdyd Status acknowledged => assigned
2008-12-02 09:13 ddennedy Note Added: 0001482
2008-12-02 17:11 madsdyd Note Added: 0001485
2008-12-02 17:12 madsdyd File Added: kbw.gdb.output.XmJ21170
2008-12-02 17:13 madsdyd Assigned To ddennedy =>
2008-12-02 17:13 madsdyd Severity minor => crash
2008-12-02 17:13 madsdyd Status assigned => acknowledged
2008-12-02 17:13 madsdyd Category MLT => File Loading
2008-12-02 17:13 madsdyd Build 2740 => 2744
2008-12-03 00:27 ddennedy Note Added: 0001494
2008-12-03 04:13 cinephiliac Note Added: 0001496
2008-12-03 13:50 administrator Note Added: 0001500
2008-12-06 17:21 madsdyd Note Added: 0001544
2008-12-06 17:21 madsdyd Status acknowledged => resolved
2008-12-06 17:21 madsdyd Fixed in Version => Recent git
2008-12-06 17:21 madsdyd Resolution open => fixed
2008-12-06 17:21 madsdyd Assigned To => madsdyd
2008-12-06 21:46 madsdyd Assigned To madsdyd =>
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker