Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000423KdenliveUser Interfacepublic2008-12-01 14:212009-07-01 22:08
Reportermfranz 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.3 
Summary0000423: segfault in DocClipBase::markerComment()
DescriptionI was exploring the interface and clicked around everywhere, and can now not remember what exactly triggered the segfault. I'm sorry.

Revision: 2741

More info about the backtrace on request if you ask within the next days. (I'll delete the core file and update/rebuild kdenlive then.)
Additional InformationProgram terminated with signal 11, Segmentation fault.


#0 DocClipBase::markerComment (this=0x914d8a8, t={m_time = 25.000011426152554, static s_delta = 1.0000000000000001e-05}) at /usr/local/qt4/include/QtCore/qbasicatomic.h:65
65 return _q_value != value;



(gdb) list
60 return _q_value == value;
61 }
62
63 inline bool operator!=(int value) const
64 {
65 return _q_value != value;
66 }
67
68 inline bool operator!() const
69 {



(gdb) print _q_value
No symbol "_q_value" in current context.
(gdb) print value
No symbol "value" in current context.





(gdb) bt
#0 DocClipBase::markerComment (this=0x914d8a8, t={m_time = 25.000011426152554, static s_delta = 1.0000000000000001e-05}) at /usr/local/qt4/include/QtCore/qbasicatomic.h:65
#1 0x080d4a63 in Monitor::checkOverlay (this=0x8c7fec0) at /home/m/src/kdenlive/src/monitor.cpp:411
0000002 0x080d4cb3 in Monitor::seekCursor (this=0x8c7fec0, pos=1) at /home/m/src/kdenlive/src/monitor.cpp:501
0000003 0x080d5e34 in Monitor::qt_metacall (this=0x8c7fec0, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xa1c1728) at /home/m/src/kdenlive/build/src/cmake_bindir/monitor.moc:224
0000004 0xb739a5ed in QMetaCallEvent::placeMetaCall () from /usr/local/qt4/lib/libQtCore.so.4
0000005 0xb739bfbf in QObject::event () from /usr/local/qt4/lib/libQtCore.so.4
0000006 0xb6b088c6 in QWidget::event () from /usr/local/qt4/lib/libQtGui.so.4
0000007 0xb6ab7ad3 in QApplicationPrivate::notify_helper () from /usr/local/qt4/lib/libQtGui.so.4
0000008 0xb6abf2d2 in QApplication::notify () from /usr/local/qt4/lib/libQtGui.so.4
0000009 0xb7c12ed7 in KApplication::notify (this=0xbfb2fc38, receiver=0x8c7fec0, event=0xa54bcb8) at /home/m/kde4/kdelibs/kdeui/kernel/kapplication.cpp:307
0000010 0xb738d811 in QCoreApplication::notifyInternal () from /usr/local/qt4/lib/libQtCore.so.4
0000011 0xb738e39d in QCoreApplicationPrivate::sendPostedEvents () from /usr/local/qt4/lib/libQtCore.so.4
0000012 0xb738e575 in QCoreApplication::sendPostedEvents () from /usr/local/qt4/lib/libQtCore.so.4
0000013 0xb73b534c in ?? () from /usr/local/qt4/lib/libQtCore.so.4
0000014 0xb59e02d9 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000015 0xb59e385b in ?? () from /usr/lib/libglib-2.0.so.0
0000016 0xb59e39d8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000017 0xb73b4fd4 in QEventDispatcherGlib::processEvents () from /usr/local/qt4/lib/libQtCore.so.4
0000018 0xb6b4668b in ?? () from /usr/local/qt4/lib/libQtGui.so.4
0000019 0xb738c150 in QEventLoop::processEvents () from /usr/local/qt4/lib/libQtCore.so.4
0000020 0xb738c2f2 in QEventLoop::exec () from /usr/local/qt4/lib/libQtCore.so.4
0000021 0xb738e621 in QCoreApplication::exec () from /usr/local/qt4/lib/libQtCore.so.4
0000022 0xb6ab7981 in QApplication::exec () from /usr/local/qt4/lib/libQtGui.so.4
0000023 0x0809fde5 in main (argc=1, argv=0xbfb2fdb4) at /home/m/src/kdenlive/src/main.cpp:77



(gdb) up
#1 0x080d4a63 in Monitor::checkOverlay (this=0x8c7fec0) at /home/m/src/kdenlive/src/monitor.cpp:411
411 QString markerComment = m_currentClip->markerComment(GenTime(m_position, m_monitorManager->timecode().fps()));
(gdb) list
406 QPoint zone = m_ruler->zone();
407 if (m_position == zone.x()) m_overlay->setOverlayText(i18n("In Point"));
408 else if (m_position == zone.y()) m_overlay->setOverlayText(i18n("Out Point"));
409 else {
410 if (m_currentClip) {
411 QString markerComment = m_currentClip->markerComment(GenTime(m_position, m_monitorManager->timecode().fps()));
412 if (markerComment.isEmpty()) m_overlay->setHidden(true);
413 else m_overlay->setOverlayText(markerComment, false);
414 } else m_overlay->setHidden(true);
415 }




(gdb) print *m_currentClip
$2 = {
  <> = {<No data fields>},
  members of DocClipBase:
  static staticMetaObject = {
    d = {
      superdata = 0x82ffe40,
      stringdata = 0x82999c0 "DocClipBase",
      data = 0x829a2a0,
      extradata = 0x0
    }
  },
  audioFrameChache = {
    {
      d = 0x0,
      e = 0x0
    }
  },
  m_name = {
    static null = {<No data fields>},
    static shared_null = {
      ref = {
        _q_value = 33154
      },
      alloc = 0,
      size = 0,
      data = 0x82fffba,
      clean = 0,
      simpletext = 0,
      righttoleft = 0,
      asciiCache = 0,
      capacity = 0,
      reserved = 0,
      array = {0}
    },
    static shared_empty = {
      ref = {
        _q_value = 187
      },
      alloc = 0,
      size = 0,
      data = 0xb746c9ae,
      clean = 0,
      simpletext = 0,
      righttoleft = 0,
      asciiCache = 0,
      capacity = 0,
      reserved = 0,
      array = {0}
    },
    d = 0x0,
    static codecForCStrings = 0x0
  },
  m_description = {
    static null = {<No data fields>},
    static shared_null = {
      ref = {
        _q_value = 33154
      },
      alloc = 0,
      size = 0,
      data = 0x82fffba,
      clean = 0,
      simpletext = 0,
      righttoleft = 0,
      asciiCache = 0,
      capacity = 0,
      reserved = 0,
      array = {0}
    },
    static shared_empty = {
      ref = {
        _q_value = 187
      },
      alloc = 0,
      size = 0,
      data = 0xb746c9ae,
      clean = 0,
      simpletext = 0,
      righttoleft = 0,
      asciiCache = 0,
      capacity = 0,
      reserved = 0,
      array = {0}
    },
    d = 0x0,
    static codecForCStrings = 0x0
  },
  m_refcount = 0,
  m_baseTrackProducers = {
    {
      p = {
        static shared_null = {
          ref = {
            _q_value = 27887
          },
          alloc = 0,
          begin = 0,
          end = 0,
          sharable = 1,
          array = {0x0}
        },
        d = 0x0
      },
      d = 0x0
    }
  },
  m_clipType = UNKNOWN,
  m_snapMarkers = {
    {
      p = {
        static shared_null = {
          ref = {
            _q_value = 27887
          },
          alloc = 0,
          begin = 0,
          end = 0,
          sharable = 1,
          array = {0x0}
        },
        d = 0x0
      },
      d = 0x0
    }
  },
  m_thumbnail = <incomplete type>,
  m_duration = {
    m_time = 1.2095376008600865e-312,
    static s_delta = 1.0000000000000001e-05
  },
  m_audioTimer = 0x2,
  m_thumbProd = 0x0,
  m_audioThumbCreated = false,
  m_id = {
    static null = {<No data fields>},
    static shared_null = {
      ref = {
        _q_value = 33154
      },
      alloc = 0,
      size = 0,
      data = 0x82fffba,
      clean = 0,
      simpletext = 0,
      righttoleft = 0,
      asciiCache = 0,
      capacity = 0,
      reserved = 0,
      array = {0}
    },
    static shared_empty = {
      ref = {
        _q_value = 187
      },
      alloc = 0,
      size = 0,
      data = 0xb746c9ae,
      clean = 0,
      simpletext = 0,
      righttoleft = 0,
      asciiCache = 0,
      capacity = 0,
      reserved = 0,
      array = {0}
    },
    d = 0x0,
    static codecForCStrings = 0x0
  },
  m_properties = {
    {
      d = 0x0,
      e = 0x0
    }
  }
}




(gdb) print m_position
$3 = 1




(gdb) bt full
#0 DocClipBase::markerComment (this=0x914d8a8, t={m_time = 25.000011426152554, static s_delta = 1.0000000000000001e-05}) at /usr/local/qt4/include/QtCore/qbasicatomic.h:65
No locals.
#1 0x080d4a63 in Monitor::checkOverlay (this=0x8c7fec0) at /home/m/src/kdenlive/src/monitor.cpp:411
        markerComment = {
  static null = {<No data fields>},
  static shared_null = {
    ref = {
      _q_value = 33154
    },
    alloc = 0,
    size = 0,
    data = 0x82fffba,
    clean = 0,
    simpletext = 0,
    righttoleft = 0,
    asciiCache = 0,
    capacity = 0,
    reserved = 0,
    array = {0}
  },
  static shared_empty = {
    ref = {
      _q_value = 187
    },
    alloc = 0,
    size = 0,
    data = 0xb746c9ae,
    clean = 0,
    simpletext = 0,
    righttoleft = 0,
    asciiCache = 0,
    capacity = 0,
    reserved = 0,
    array = {0}
  },
  d = 0xb7d82ff4,
  static codecForCStrings = 0x0
}
0000002 0x080d4cb3 in Monitor::seekCursor (this=0x8c7fec0, pos=1) at /home/m/src/kdenlive/src/monitor.cpp:501
No locals.
0000003 0x080d5e34 in Monitor::qt_metacall (this=0x8c7fec0, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xa1c1728) at /home/m/src/kdenlive/build/src/cmake_bindir/monitor.moc:224
No locals.
0000004 0xb739a5ed in QMetaCallEvent::placeMetaCall () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000005 0xb739bfbf in QObject::event () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000006 0xb6b088c6 in QWidget::event () from /usr/local/qt4/lib/libQtGui.so.4
No symbol table info available.
0000007 0xb6ab7ad3 in QApplicationPrivate::notify_helper () from /usr/local/qt4/lib/libQtGui.so.4
No symbol table info available.
0000008 0xb6abf2d2 in QApplication::notify () from /usr/local/qt4/lib/libQtGui.so.4
No symbol table info available.
0000009 0xb7c12ed7 in KApplication::notify (this=0xbfb2fc38, receiver=0x8c7fec0, event=0xa54bcb8) at /home/m/kde4/kdelibs/kdeui/kernel/kapplication.cpp:307
        t = <value optimized out>
0000010 0xb738d811 in QCoreApplication::notifyInternal () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000011 0xb738e39d in QCoreApplicationPrivate::sendPostedEvents () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000012 0xb738e575 in QCoreApplication::sendPostedEvents () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000013 0xb73b534c in ?? () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000014 0xb59e02d9 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
0000015 0xb59e385b in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
0000016 0xb59e39d8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
0000017 0xb73b4fd4 in QEventDispatcherGlib::processEvents () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000018 0xb6b4668b in ?? () from /usr/local/qt4/lib/libQtGui.so.4
No symbol table info available.
0000019 0xb738c150 in QEventLoop::processEvents () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000020 0xb738c2f2 in QEventLoop::exec () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000021 0xb738e621 in QCoreApplication::exec () from /usr/local/qt4/lib/libQtCore.so.4
No symbol table info available.
0000022 0xb6ab7981 in QApplication::exec () from /usr/local/qt4/lib/libQtGui.so.4
No symbol table info available.
0000023 0x0809fde5 in main (argc=1, argv=0xbfb2fdb4) at /home/m/src/kdenlive/src/main.cpp:77
        aboutData = {
  d = 0x8a00528
}
        options = {
  d = 0x8a063e0
}
        app = {
  <> = {<No data fields>},
  members of KApplication:
  static staticMetaObject = {
    d = {
      superdata = 0xb71fedc8,
      stringdata = 0xb7d51720 "KApplication",
      data = 0xb7d518c0,
      extradata = 0x0
    }
  },
  static loadedByKdeinit = false,
  static KApp = 0xbfb2fc38,
  d = 0x8a3bac8
}
        __PRETTY_FUNCTION__ = "int main(int, char**)"


TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0001495)
cinephiliac (updater)
2008-12-03 04:10

Hi Mfranz,

Thanks for helping Kdenlive out by filing this report,

A couple of things that would really help would be attaching backtraces as attachments (there's a section above labled "Upload File") and adding the information requested at http://en.wikibooks.org/wiki/Kdenlive/Reporting_bugs [^] (especially the full version numbers including QT,MLT, FFMPEG).

It would also be great to see if you can try a couple of things that you were doing before and reproduce it. If so, steps to reproduce would help hugely.

Many thanks!

Cinephiliac
(0001498)
mfranz (reporter)
2008-12-03 10:35

I think I clicked on the left border of a clip after I had made some setting in some dialog. I'll send more info if I get the segfault again. Trying to reproduce will be rather time consuming without a clearer scenario.

I didn't install using the "Kdenlive Builder Wizard". I don't know what that is, and I don't have a kdenlive_start for more version info. But everything was from the respective SVN/HEAD at that time, so:

mlt was around r1240
ffmpeg around r15976
qt was 4.4.3 (-r891119 in qt-copy)

(So the bt that I sent inlined already was worthless? Or did you not look at it because it wasn't attached? :-)
(0001499)
administrator (administrator)
2008-12-03 13:46

I just committed a possible fix in svn revision 2755, I think we can leave the bug open and close it in a few days if it cannot be reproduced...
(0001841)
xzhayon (developer)
2008-12-21 03:38

it's been 18 days since jb committed the patch
did someone get this issue?

- Issue History
Date Modified Username Field Change
2008-12-01 14:21 mfranz New Issue
2008-12-01 14:21 mfranz Build/Install Method => Manual build from SVN
2008-12-03 04:10 cinephiliac Note Added: 0001495
2008-12-03 04:10 cinephiliac Status new => feedback
2008-12-03 10:35 mfranz Note Added: 0001498
2008-12-03 13:46 administrator Note Added: 0001499
2008-12-21 03:38 xzhayon Note Added: 0001841
2009-07-01 12:00 j-b-m Status feedback => resolved
2009-07-01 12:00 j-b-m Fixed in Version => 0.7.3
2009-07-01 12:00 j-b-m Resolution open => fixed
2009-07-01 12:00 j-b-m Assigned To => j-b-m
2009-07-01 22:08 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker