Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000429KdenliveEffectspublic2008-12-03 11:052009-02-03 02:01
Reportervolker_holthaus 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.2 
Summary0000429: Kdenlive crashes when i add the dust effect to an AVCHD Clip
DescriptionHello..

when i add the dust effect to an AVCHD Clip kdenlive crashes.

Thank you very much.

Volker
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filestxt file icon Volker_backtrace.txt [^] (27,266 bytes) 2008-12-03 17:09 [Show Content]

- Relationships

-  Notes
(0001502)
cinephiliac (updater)
2008-12-03 17:09

Hi Volker,

Thanks for helping us make Kdenlive better by submitting this report.

Could you navigate to where your Kdenlive_Start.sh and Kdenlive binary are and post the output of:

./kdenlive_start.sh --version

Thanks.

PS Attaching backtraces as a separate file also makes it much faster and easier for us to read bug reports and get back to fixing bugs. :)
(0001503)
volker_holthaus (reporter)
2008-12-03 17:12

Here is the output:

Kdenlive Builder Wizard version: 0.5.1
ffmpeg: Revision: 15915
mlt: Revision: 1240
mlt++: Revision: 1240
kdenlive: Revision: 2720
(0001517)
ddennedy (developer)
2008-12-04 02:33

This is a divide by zero on the width of the dust effect's resource file dust4.svg. Currently, this requires the SVG loader for gdk-pixbuf. I imagine some KDE users will not have GDK. Volker, please confirm this by opening a konsole, then:
cd kdenlive/bin
source kdenlive_env
inigo -query producers 2>&1 | grep pixbuf
(0001528)
volker_holthaus (reporter)
2008-12-04 16:15

Here are the output:

- pixbuf

Greatings

Volker
(0001532)
ddennedy (developer)
2008-12-04 19:53

Sorry, one more thing since gdk-pixbuf is also modular. 'gdk-pixbuf-query-loaders | grep svg'

Also, you can source kdenlive_env and just try to 'inigo some.svg' to confirm everything to support SVG is in order.
(0001536)
volker_holthaus (reporter)
2008-12-05 14:35

The output of

gdk-pixbuf-query-loaders | grep svg

is nothing and of

inigo some.svg (replaced with a correct filename)
is

Failed to load "/home/volker/entpack/wine-1.1.9/dlls/shell32/folder.svg"
(0001539)
ddennedy (developer)
2008-12-05 18:22

OK, we need to do one of two things. One is to have some better capabilities test to hide/show that filter. Another is to provide an alternative or replacement to the SVG file. Perhaps another alternative is to investigate the additional use of a Qt or KDE API to render SVG, and add that to the qimage or kdenlive MLT module. I think the easiest thing to do is to just replace those SVG with sufficiently high resolution PNG.
(0001821)
ddennedy (developer)
2008-12-20 00:14

Do you have libqsvg.so on your system? I have one in /usr/lib/qt4/plugins/imageformats/ and that it came from the libqt4-svg package with *many* packages dependent upon it. I imagine most users will have this. I just made a change in MLT SVN to let qimage open SVG files. If you have this plugin, please update and give it a test.
(0001948)
ddennedy (developer)
2008-12-28 21:40

Please upgrade, restest, and verify the qimage svg plugin exists on your system if it still fails.
(0001966)
volker_holthaus (reporter)
2008-12-29 16:33

It works with the actual version of kdenlive.

Thank you.

Volker

- Issue History
Date Modified Username Field Change
2008-12-03 11:05 volker_holthaus New Issue
2008-12-03 11:05 volker_holthaus Build/Install Method => Build Wizard
2008-12-03 17:09 cinephiliac Note Added: 0001502
2008-12-03 17:09 cinephiliac Status new => feedback
2008-12-03 17:09 cinephiliac Additional Information Updated
2008-12-03 17:09 cinephiliac File Added: Volker_backtrace.txt
2008-12-03 17:12 volker_holthaus Note Added: 0001503
2008-12-04 02:33 ddennedy Note Added: 0001517
2008-12-04 16:15 volker_holthaus Note Added: 0001528
2008-12-04 19:53 ddennedy Note Added: 0001532
2008-12-05 14:35 volker_holthaus Note Added: 0001536
2008-12-05 18:22 ddennedy Note Added: 0001539
2008-12-05 18:22 ddennedy Status feedback => assigned
2008-12-05 18:22 ddennedy Assigned To => ddennedy
2008-12-20 00:14 ddennedy Note Added: 0001821
2008-12-28 21:40 ddennedy Note Added: 0001948
2008-12-28 21:40 ddennedy Status assigned => feedback
2008-12-29 16:33 volker_holthaus Note Added: 0001966
2009-01-28 20:23 ddennedy Status feedback => resolved
2009-01-28 20:23 ddennedy Resolution open => fixed
2009-02-03 02:01 xzhayon Status resolved => closed
2009-02-03 02:01 xzhayon Fixed in Version => 0.7.2


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker