Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000430KdenliveMLTpublic2008-12-03 14:122011-06-09 22:47
Reporterdavid 
Assigned Tomadsdyd 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusassignedResolutionopen 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000430: Render to image sequence
DescriptionImage sequences are widely used for all kind of tasks in working with video and a de facto standard in post processing houses and other facilities.
Adding ability to render Kdenlive projects to image sequences would add so much value to the software and wouldn't be very hard to implement I imagine (correct me if I'm wrong, I'm not a programmer).
The top one formats for my request would be png (with alphas), tiff and jpg.
Tagsrender dialogue
Build/Install MethodBuild Wizard
Attached Files

- Relationships
related to 0000323acknowledged Redesign the render dialog, more intuitive way for users to understand the difference between project and rendering profiles 

-  Notes
(0001501)
madsdyd (administrator)
2008-12-03 16:31

This should be fairly easy to implement, as ffmpeg supports rendering to a set of files:

ffmpeg -i somefile.avi somefile%05d.png

will render to a number of pngs. (I am unsure about alpha support, really, I have no idea where one should get the alpha information, unless you just mean 4 channels should be present in the pngs).

Trying to get inigo to render is a bit more trouble, from kdenlive, I got to this:

//STARTING RENDERING: true , "/scratch/KdenliveInstall//20081202/bin/inigo" , "square_ntsc" , "avformat" , "-" , "/tmp/kde-madsdyd/kdenlivePj9090.westley" , "/tmp/untitled%05d.png" , () , ("") , -1 , -1

however, nothing happens (not even a message box).

Checking out inigo, I tried this:

$ inigo /home/madsdyd/Privat/Kdenlive/mads-180-gange-3.avi -consumer avformat:test%05d.png
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5= 0| |6= 1| |7= 2| |8= 5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
| H = back 1 minute, L = forward 1 minute |
| h = previous frame, l = next frame |
| g = start of clip, j = next clip, k = previous clip |
| 0 = restart, q = quit, space = play |
+---------------------------------------------------------------------+
Current Position: 0
madsdyd@ripley:/tmp$ ls -ltr

It seems inigo consumes no frames at all, when a string like %05d is present.

I am taking the liberty to change this to an MLT issue, untill we have some more knowledge about it.


(0001518)
ddennedy (developer)
2008-12-04 02:46

-consumer avformat:test%05.jpg works for me. Doing .png just gives me a JPEG anyways. You have to add "vcodec=png" to get the PNG format. The file extension is a hint to output using the still images muxer, but the vcodec specifies the encoding.
As for alpha support, it does not make a whole lot of sense in kdenlive yet. Right now, it has a constant black background track that something as minimal as a title clip will get composited over. In the long term, it might be interesting to consider a feature to suppress that default behaviour.

- Issue History
Date Modified Username Field Change
2008-12-03 14:12 david New Issue
2008-12-03 14:12 david Build/Install Method => Build Wizard
2008-12-03 16:31 madsdyd Note Added: 0001501
2008-12-03 16:31 madsdyd Status new => feedback
2008-12-03 16:31 madsdyd Category Rendering => MLT
2008-12-04 02:46 ddennedy Note Added: 0001518
2008-12-21 15:58 madsdyd Status feedback => assigned
2008-12-21 15:58 madsdyd Assigned To => madsdyd
2008-12-21 15:59 madsdyd Relationship added related to 0000323
2011-06-09 22:47 Granjow Tag Attached: render dialogue


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker