Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000432KdenliveMLTpublic2008-12-05 11:172008-12-29 15:37
Reporterdivan 
Assigned Tomadsdyd 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.0 
Target VersionFixed in Version0.7.1 
Summary0000432: Crash on AVCHD clip drag/seek
DescriptionIn default project I add one AVCHD clip(thumbnail shown correctly) and drag it onto the timeline(tail thumbnail not shown). Next, if I'm trying to move the clip in timeline or seek on it, I got a crash.
'mplayer -identify' output is attached for given videclip, if it does matter(video is recorded by Sony HDR-SR7E camcorder).
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Fileslog file icon kdenlive_crash.log [^] (27,557 bytes) 2008-12-05 11:17 [Show Content]
? file icon mplayer_mts.putput [^] (178,428 bytes) 2008-12-05 11:18

- Relationships

-  Notes
(0001540)
ddennedy (developer)
2008-12-06 04:44

hmmm, crashing somewhere in ffmpeg/libswscale for pixel format conversion. I do not reproduce this with any of my avchd samples. Does this happen on all your AVCHD clips or just some? Do you have a really short one or one you can make short using dd that reproduces the problem such that you can upload it or post it somewhere for download?
(0001541)
divan (reporter)
2008-12-06 10:05

I have only one clip on the laptop, the rest I'll be able to test on monday. But clip is 40Mb in size. I made a few shorter clips with dd and kdenlive doesn't crash, when clips size is below approx 17Mb. I can upload an 18 megs file, is it ok?
(0001546)
ddennedy (developer)
2008-12-06 19:16

Go ahead and try.
(0001548)
madsdyd (administrator)
2008-12-06 20:27

I think the upload limit is 5 MB - will look into if I can change it here
(0001549)
madsdyd (administrator)
2008-12-06 21:25

Unfortunately it seems to require some php settings change, which I can not make. And, also, I am not sure I can make the mantis change, using the management interface. So, 5 MB is the limit as it is.
(0001560)
divan (reporter)
2008-12-07 15:48

I've uploaded short video clip here:
http://divan0.org.ua/short.mts [^] - ~17Mb in size. This clip reproduces the described crash.
(0001635)
madsdyd (administrator)
2008-12-13 17:31

Hi divan

I can not reproduce with these versions:
ffmpeg: Revision: 16089 Last Changed Date: 2008-12-13 10:16:12 +0100 (Sat, 13 Dec 2008)
mlt: Revision: 1264 Last Changed Date: 2008-12-12 20:10:00 +0100 (Fri, 12 Dec 2008)
mlt++: Revision: 1264 Last Changed Date: 2008-12-04 23:31:49 +0100 (Thu, 04 Dec 2008)
kdenlive: Revision: 2782 Last Changed Date: 2008-12-13 04:22:29 +0100 (Sat, 13 Dec 2008)
Qt: 4.4.1
KDE: 4.1.2 (KDE 4.1.2)
Kdenlive: 0.7

The clip (short.mts) loads just fine. Playback stutters somewhat, but this may very well be my video card (my laptop is dying a slow but painful death).

Does it still crash for you?
(0001641)
ddennedy (developer)
2008-12-14 06:23

I was able to reproduce a segfault on this in inigo when playing the last frame. I found the bug and it is not specific to AVCHD although it might be rare on many formats. I think I reproduced this because the file was trimmed to containing an incomplete last frame (reported duration slightly longer than usable duration). In any case, a fix was committed to SVN r1265. Now, MLT will produce white video when the last frame(s) is invalid. This means the last frame is unusable and you need to trim it out.
(0001859)
divan (reporter)
2008-12-21 12:55

Seems to be fixed. Doesn't crash anymore.
(0001861)
madsdyd (administrator)
2008-12-21 13:01

Fixed in MLT svn rev. 1265. Thanks Dan.

- Issue History
Date Modified Username Field Change
2008-12-05 11:17 divan New Issue
2008-12-05 11:17 divan File Added: kdenlive_crash.log
2008-12-05 11:17 divan Build/Install Method => Build Wizard
2008-12-05 11:18 divan File Added: mplayer_mts.putput
2008-12-06 04:44 ddennedy Note Added: 0001540
2008-12-06 10:05 divan Note Added: 0001541
2008-12-06 19:16 ddennedy Note Added: 0001546
2008-12-06 20:27 madsdyd Note Added: 0001548
2008-12-06 20:27 madsdyd Status new => feedback
2008-12-06 21:25 madsdyd Note Added: 0001549
2008-12-07 15:48 divan Note Added: 0001560
2008-12-13 17:31 madsdyd Note Added: 0001635
2008-12-14 06:23 ddennedy Note Added: 0001641
2008-12-21 12:55 divan Note Added: 0001859
2008-12-21 13:01 madsdyd Note Added: 0001861
2008-12-21 13:01 madsdyd Status feedback => resolved
2008-12-21 13:01 madsdyd Fixed in Version => Recent git
2008-12-21 13:01 madsdyd Resolution open => fixed
2008-12-21 13:01 madsdyd Assigned To => madsdyd
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker