Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000441KdenliveUser Interfacepublic2008-12-07 23:042011-11-01 18:57
Reporterreinhard 
Assigned ToGranjow 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version8.10
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0000441: unexpected behaviour when using 'I' and 'O' shortcuts in timeline
Descriptionwhen I press 'I' or 'O' (rev 2759) I can change the length of the green bar in the clip monitor.
But!
When I do this in the timeline (when no clip is selected) this does not change the length of the green bar but will affect the next clip below (which is touched by the timeline cursor) by changing his length accordingly.
Steps To Reproduce- put a segment of a clip in track 1
- put another segment in track 2, behind clip 1
- put another segment in track 3, behind clip 2
- place the timeline ruler so that it touches segment 2, for example
- hit 'I' or 'O'
Additional InformationMy expectation was, that 'I' and 'O' shortcuts would also change the length of the green bar of the timeline, since it changes the green bar in the clip monitor as well. At least this was the behaviour in the kde3 releases, IIRC.
The actual behavior is indeed very useful, but might be executed by another shortcut.
BTW - in 'AVID' this functionality is called as 'trim head' and 'trim tail'.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon capture0016.ogv [^] (482,495 bytes) 2008-12-07 23:05

- Relationships

-  Notes
(0001599)
cinephiliac (updater)
2008-12-10 21:48

Personally I don't mind the overall behaviour here, however I agree that often it does seem to select the clip below the one you mean. Manually clicking on the clip you want to change in the timeline seems to correct this though.

Either way, marking as an acknowledged.
(0004068)
reinhard (reporter)
2009-10-05 17:09

Hi,

some news about this issue?

To be honest, It's still a bit confusing for me, although, I think it seems logical from a coders point of view ;)

My suggestion would be to use the shortcuts 'I' and 'O' to change the play zone (the green bar) in the timeline (at least the other video editors I know about do it this way) and e.g. 'shift+I' and 'shift+O' for changing the crop of a selected clip...
(0004069)
j-b-m (administrator)
2009-10-05 18:51

I agree that this is confusing. Unluckily, it's too late to change that for Kdenlive 0.7.6, we are in string freeze now.

I will put it on the roadmap for next Kdenlive release.
(0004077)
reinhard (reporter)
2009-10-05 22:45

There's no hurry!

But it's good to know you have it on your list ;)

thanks!
(0004121)
ddennedy (developer)
2009-10-12 02:30

I disagree and like the current behaviour and think it is consistent. In the Clip monitor you are setting in and out points when pressing 'i' and 'o'. Same goes for when in the timeline. The green bar in the timeline is not related to trimming. The i and o keys are not so much for affecting the UI as it is related to a function, and that function is setting edit points and trimming. Perhaps the shift can be used to adjust the timeline's zone.
(0004163)
ddennedy (developer)
2009-10-14 06:09

See this comment in the forums:
http://www.kdenlive.org/forum/professionals-video-editors-only-please#comment-5305 [^]

If the timeline zone bar is used to facilitate 3-point editing, then I agree it does make sense to tie it to the 'i' and 'o' keys.
(0004165)
reinhard (reporter)
2009-10-15 00:38

yes, this was the main reason for me to raise this issue.
so, maybe issue 0000516 and 0000477 are a bit related to this...
(0006322)
Granjow (developer)
2011-01-15 17:37

Is it possible that this issue has been fixed in the meantime?
I could not reproduce it.
(0006400)
ddennedy (developer)
2011-02-08 09:28

I think it went into 0.7.7, hard for me to tell without building the older versions and not always so easy to locate release notes with the info.

- Issue History
Date Modified Username Field Change
2008-12-07 23:04 reinhard New Issue
2008-12-07 23:04 reinhard Build/Install Method => Build Wizard
2008-12-07 23:05 reinhard File Added: capture0016.ogv
2008-12-10 21:48 cinephiliac Note Added: 0001599
2008-12-10 21:48 cinephiliac Status new => acknowledged
2009-10-05 17:09 reinhard Note Added: 0004068
2009-10-05 18:51 j-b-m Note Added: 0004069
2009-10-05 22:45 reinhard Note Added: 0004077
2009-10-12 02:30 ddennedy Note Added: 0004121
2009-10-14 06:09 ddennedy Note Added: 0004163
2009-10-15 00:38 reinhard Note Added: 0004165
2011-01-15 17:37 Granjow Note Added: 0006322
2011-01-15 17:37 Granjow Assigned To => Granjow
2011-01-15 17:37 Granjow Status acknowledged => feedback
2011-02-08 09:28 ddennedy Note Added: 0006400
2011-02-08 09:28 ddennedy Status feedback => resolved
2011-02-08 09:28 ddennedy Fixed in Version => 0.7.7.1
2011-02-08 09:28 ddennedy Resolution open => fixed
2011-07-05 12:15 j-b-m Fixed in Version 0.7.7.1 => 0.8.2
2011-11-01 18:57 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker