Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000450KdenliveUser Interfacepublic2008-12-09 13:222009-02-03 02:18
Reportervolker_holthaus 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.2 
Summary0000450: preview shows only the first one second of a rendered clip
DescriptionFirst i render my AVCHD Clip with the project settings 1080 50i and rendering settings 1080 50i. Then i load the generated clips in a new projekt with the settings 1080 50i.
When i want to see the clip in the preview, i only see the first second of the clip, then the preview was black or sometimes white.
When i play the clip with ffplay or inigo everything seems alright.

Thank you very much for your support. You done a great work.

Volker
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships
related to 0000436assignedddennedy Some TS clips are show to be 10 minutes long whatever their real length 
has duplicate 0000563closed HDV 1080 60i profile rendering of HDV 1080 60i ouptut produces un-playable output 

-  Notes
(0001585)
volker_holthaus (reporter)
2008-12-09 14:27

When i play the clip with inigo, there are the same problems, like with kdenlive. With ffplay everything is alright.
(0001607)
ddennedy (developer)
2008-12-11 06:42

I reproduced this. When playing in ffplay, it reports frequently "Invalid timestamps stream=0, pts=0..." and it fails to seek, also resulting in playback halting. MLT needs to be able to seek if it thinks the file is seekable. So, it fails in the same manner that ffplay fails after seeking.

Then, I transcoded the clip using ffmpeg using the same args as kdenlive render. ffplay reports these same errors, but both ffplay and inigo plays through the file and seeks around.
(0001608)
ddennedy (developer)
2008-12-11 06:42

I have to debug this further in MLT consumer_avformat.
(0001744)
ddennedy (developer)
2008-12-17 08:40

I wanted to work on this tonight, but now I can not reproduce it! I had reproduced it on a different system. I just updated ffmpeg to svn trunk as I was using Nov 20 checkout on the system where I could not reproduce, and it still works as well. Oh wait, I was testing playback in ffplay or inigo only. Now that I have loaded it into kdenlive, with HDV 1080 50i project, I see the problem, but now it is late -sigh.
(0002130)
ddennedy (developer)
2009-01-14 09:46

This is fixed in MLT SVN r1316.

Note that ffmpeg/ffplay will still report Invalid timestamps at the beginning. Even when transcoding with the ffmpeg utility to TS, these timestamps are reported. This seems to be a problem with the mpegts muxer in libavformat out of my control. However, the output is now playable with inigo and usable in kdenlive.

(0002138)
volker_holthaus (reporter)
2009-01-14 15:58

It works..

Greetings

Volker
(0002150)
jmpoure (developer)
2009-01-15 08:37

fixed after Dan's changes to MLT SVN r131 and FFmpeg TS commits on 2009-01-15. Cool! Closing bug.

- Issue History
Date Modified Username Field Change
2008-12-09 13:22 volker_holthaus New Issue
2008-12-09 13:22 volker_holthaus Build/Install Method => Build Wizard
2008-12-09 14:27 volker_holthaus Note Added: 0001585
2008-12-11 06:17 ddennedy Status new => assigned
2008-12-11 06:17 ddennedy Assigned To => ddennedy
2008-12-11 06:42 ddennedy Note Added: 0001607
2008-12-11 06:42 ddennedy Note Added: 0001608
2008-12-17 08:40 ddennedy Note Added: 0001744
2008-12-29 01:39 ddennedy Relationship added related to 0000436
2009-01-04 20:59 ddennedy Relationship added has duplicate 0000564
2009-01-04 20:59 ddennedy Relationship added has duplicate 0000563
2009-01-14 09:46 ddennedy Note Added: 0002130
2009-01-14 09:46 ddennedy Status assigned => feedback
2009-01-14 15:58 volker_holthaus Note Added: 0002138
2009-01-15 08:37 jmpoure Note Added: 0002150
2009-01-15 08:37 jmpoure Status feedback => resolved
2009-01-15 08:37 jmpoure Resolution open => fixed
2009-02-03 02:18 xzhayon Status resolved => closed
2009-02-03 02:18 xzhayon Fixed in Version => 0.7.2


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker