Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000455KdenliveUser Interfacepublic2008-12-11 18:152009-02-03 01:58
Reportervolker_holthaus 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.2 
Summary0000455: Add a avi Clip (rendered by synfigstudio)
DescriptionWhen i add a clip rendered from synfigstudio kdenlive crashes.

Greatings

Volker
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filestxt file icon error.txt [^] (75,060 bytes) 2008-12-11 18:15 [Show Content]

- Relationships
related to 0000322closedddennedy Formats unsupported by ffmpg seem to crash Kdenlive rather than being blocked from opening in the first place 

-  Notes
(0001612)
cinephiliac (updater)
2008-12-12 05:01

Hi Volker,

To fix this it would be useful for the devs to get some basic information. Could you take a look at en.wikibooks.org/wiki/Kdenlive/Reporting_bugs and let us know your versions (see "Version:") and the results of following the "Rendering/Playback" section at the bottom of that page?

Thanks

Cinephiliac
(0001613)
ddennedy (developer)
2008-12-12 08:59

could you please '$ source /path/to/kdenlive/bin/kdenlive_env'
and then test playback in inigo (inigo your.avi) and ffplay?
Finally, send the output of 'ffmpeg -i your.avi'
Thanks!
(0001614)
volker_holthaus (reporter)
2008-12-12 09:18

Here's the output of kdenlive -version:

Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 16052 Last Changed Date: 2008-12-11 08:49:05 +0100 (Thu, 11 Dec 2008)
mlt: Revision: 1255 Last Changed Date: 2008-12-04 19:25:48 +0100 (Thu, 04 Dec 2008)
mlt++: Revision: 1255 Last Changed Date: 2008-12-04 23:31:49 +0100 (Thu, 04 Dec 2008)
kdenlive: Revision: 2773 Last Changed Date: 2008-12-09 23:15:24 +0100 (Tue, 09 Dec 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7


It works with both. Here's the output of ffmpeg -i Intro.avi:

FFmpeg version SVN-r16052, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --prefix=/home/volker/programme/kdenlive --disable-network --disable-ffserver --enable-gpl --enable-shared --enable-swscale --enable-debug --enable-pthreads --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-libfaac --enable-libfaad
  libavutil 49.12. 0 / 49.12. 0
  libavcodec 52. 6. 1 / 52. 6. 1
  libavformat 52.23. 1 / 52.23. 1
  libavdevice 52. 1. 0 / 52. 1. 0
  libswscale 0. 6. 1 / 0. 6. 1
  built on Dec 11 2008 09:58:25, gcc: 4.3.2
Input #0, avi, from '/home/volker/Bilder/Tauchen/Trimix Kurs/2008-12-07 Abschluss Tauchgang Old Joe/Intro.avi':
  Duration: 00:00:16.95, start: 0.000000, bitrate: 728 kb/s
    Stream #0.0: Video: mpeg1video, yuv420p, 1904x1080 [PAR 1:1 DAR 238:135], 104857 kb/s, 29.97 tb(r)
At least one output file must be specified


Thank you very much.

Volker
(0001727)
ddennedy (developer)
2008-12-16 23:45

Unable to reproduce using a MPEG-1 video only file I created myself using ffmpeg.
(0001728)
ddennedy (developer)
2008-12-16 23:49

In the backtrace, why is the DocClipBase null?

0000002 0x0815011b in DocClipBase::setProducer (this=0x0, producer=0xed59448) at /home/volker/programme/kdenlive/source/kdenlive/src/docclipbase.cpp:384
(0001947)
ddennedy (developer)
2008-12-28 21:39

Please retest after upgrading.
(0001967)
volker_holthaus (reporter)
2008-12-29 16:34

It works with the actual version of kdenlive.

Thank you very much.

Volker

- Issue History
Date Modified Username Field Change
2008-12-11 18:15 volker_holthaus New Issue
2008-12-11 18:15 volker_holthaus File Added: error.txt
2008-12-11 18:15 volker_holthaus Build/Install Method => Build Wizard
2008-12-12 05:01 cinephiliac Note Added: 0001612
2008-12-12 05:01 cinephiliac Status new => feedback
2008-12-12 05:02 cinephiliac Relationship added related to 0000322
2008-12-12 08:59 ddennedy Note Added: 0001613
2008-12-12 09:18 volker_holthaus Note Added: 0001614
2008-12-16 23:45 ddennedy Note Added: 0001727
2008-12-16 23:49 ddennedy Note Added: 0001728
2008-12-17 06:59 ddennedy Status feedback => assigned
2008-12-17 06:59 ddennedy Assigned To => ddennedy
2008-12-28 21:39 ddennedy Note Added: 0001947
2008-12-28 21:39 ddennedy Status assigned => feedback
2008-12-29 16:34 volker_holthaus Note Added: 0001967
2009-01-28 20:26 ddennedy Status feedback => resolved
2009-01-28 20:26 ddennedy Resolution open => fixed
2009-02-03 01:58 xzhayon Status resolved => closed
2009-02-03 01:58 xzhayon Fixed in Version => 0.7.2


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker