Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000465KdenliveRenderingpublic2008-12-13 17:372009-07-01 21:55
Reporterjappel 
Assigned Toddennedy 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000465: exporting to ogg theora 720x576 blocks system
DescriptionThe export of a rather small (~1 min duration) project results after 0000010:0000015% of successful rendering in great system-slowdown. The rendering process itself appears to be halting, the system freezes. It may be that the process runs out of memory, and starts heavily swapping. at least hd accesses are companioning the system freeze.

this does not occur with other output codes tested (h.264, xvid, pal, mpg4, dvd). the amount of ram on the rendering system is 1gb.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships
has duplicate 0000657closedddennedy When exportin with one of the theora presets the export process crashes 
has duplicate 0000701closedddennedy No progress bar for rendering and too much cpu useage 

-  Notes
(0001660)
cinephiliac (updater)
2008-12-15 08:57

OK I tried to reproduce this and while I didn't get the slowdown mentioned, I did get some strange results. In my case I hit render and KUI server comes up, but no render seems to happen (or even a progress in the KUI server progress bar).

As requested in a previous bug report, your version numbers would help along with any details of the project settings (Project -> Project Settings) and what kind of filetypes you were using as clips.

Thanks for bringing this to our attention!
(0001708)
jappel (reporter)
2008-12-16 15:01

Con gusto!
I edited a ~1 min timeline. The timeline contained text and color clips and video clips of two different kinds (info through smplayer):
 
 1. Video res. 640 x 480
 Format: MJPG
 Bitrate: 9217 kbps
 fps: 30.000
 Codec: ffmjpeg
 
 Audio Stream:
 Bitrate: 128 kbps
 Samplingrate : 16000 Hz
 Channels: 1
 Codec: Linear PCM 128
 
 
 2. Video Res: 320 x 240
 Format: MJPG
 Bitrate: 2438 kbps
 fps: 30.000
 Codec ffmjpeg
 
 Audio Stream
 Bitrate: 352 kbps
 Samplingrate: 22050 Hz
 Channles: 1
 Codec: Linear PCM 352 kbps

The project is set to dv pal.
(0001722)
ddennedy (developer)
2008-12-16 21:36

I noticed something like this too recently. I believe there is a memory leak in the ffmpeg/libavformat ogg muxer.
(0003097)
ddennedy (developer)
2009-06-03 19:20

This issue should be blocking severity because it really cripples the system and scares and pisses off the user that either has to hard reset in the midst of disk activity, some of it potentially write operation, or they have to stop using the computer for a good long while to wait for the process to complete/fail/be killed by oom.
(0003189)
ddennedy (developer)
2009-06-13 10:27

Fixed in MLT git commit 21603d5.

- Issue History
Date Modified Username Field Change
2008-12-13 17:37 jappel New Issue
2008-12-13 17:37 jappel Build/Install Method => Build Wizard
2008-12-15 08:57 cinephiliac Note Added: 0001660
2008-12-15 08:57 cinephiliac Status new => feedback
2008-12-16 15:01 jappel Note Added: 0001708
2008-12-16 21:36 ddennedy Note Added: 0001722
2008-12-16 21:40 ddennedy Status feedback => assigned
2008-12-16 21:40 ddennedy Assigned To => ddennedy
2009-06-03 06:46 ddennedy Severity block => major
2009-06-03 06:53 ddennedy Relationship added has duplicate 0000657
2009-06-03 07:42 ddennedy Relationship added has duplicate 0000701
2009-06-03 19:20 ddennedy Note Added: 0003097
2009-06-03 19:20 ddennedy Severity major => block
2009-06-13 10:27 ddennedy Note Added: 0003189
2009-06-13 10:27 ddennedy Status assigned => resolved
2009-06-13 10:27 ddennedy Fixed in Version => Recent git
2009-06-13 10:27 ddennedy Resolution open => fixed
2009-06-19 09:33 xzhayon Target Version => future version
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:55 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker