Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000472KdenliveEffectspublic2008-12-15 11:582009-07-01 21:55
Reporterdoitux 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000472: rotate effect doesnt work
DescriptionWhen i try to reproduce another issue i get following crash:

1. add a clip
2. add "rotate" video effect
3. edit "y" value for video effect to "40" e.g.
Trying to play the effect in project monitor doesnt work (black screen)

4. delete the clip
5. undo "delete selected items" (the clip here)
6. undo "edit effect rotate"
--> kdenlive crashes here! log attached

I think this is related to http://www.kdenlive.org/mantis/view.php?id=468 [^]
because the effect isnt there when undo, the "edit effect" cannot be done and crash.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Fileslog file icon undoDeleteClipWithRotateEffectCrash.log [^] (48,674 bytes) 2008-12-15 11:58 [Show Content]
? file icon kbw.gdb.output.VZq28721 [^] (48,779 bytes) 2008-12-15 12:06
patch file icon effect_addition_undoing.svn2789.patch [^] (599 bytes) 2008-12-15 14:06 [Show Content]
? file icon test-472.mpg [^] (3,782,656 bytes) 2008-12-17 12:05

- Relationships
parent of 0000468closeddoitux undo don't restore applied effects 

-  Notes
(0001667)
madsdyd (administrator)
2008-12-15 12:05

I can not confirm the "rotate-not-working" part, we may need some more info on the clip (type) perhaps even an attached clip.

I *can* confirm the crash though - attaching another crash log (its probably 2788, even though it says 2782).
(0001668)
doitux (updater)
2008-12-15 12:07

additional clip info:
duration: 00:00:54:16
video codec: DV (Digital Video)
frame size: 720x576
frame rate: 25.000000
pixel aspect ratio: 066667
(0001671)
cinephiliac (updater)
2008-12-15 13:01

Acknowledging based on Mads' feedback and that doitux has given further clip info.
(0001679)
xzhayon (developer)
2008-12-15 14:07

it's funny but the crash is caused by a kDebug():
kDebug() << "CHange EFFECT AT: " << ix << ", CURR: " << m_effectList.at(ix).attribute("tag") << ", NEW: " << effect.attribute("tag");
'ix' is not a valid 'm_effectList' index. please mads, see my patch (well, it's a // :P)

maybe this isn't good, but the program works as expected, except for this (not related i think):
1. repeat the above steps
2. undo everything
3. in the undo stack, click on "add effect"
the effect will be there, but with values already set (in my case, y = 40)
is this correct?
(0001685)
xzhayon (developer)
2008-12-15 16:30

mads: i believe the problem is strictly related to 468
ix (== 0) is not an index of m_effectsList because this is empty, and in fact there's no effect on the clip. but the undoing should have reapplied the effect (issue 468), so the list shouldn't be empty
i think that the crash in this issue is simply a symptom/duplicate of 468 (and it's fixed with my short short patch, which is only a temporary hack). probably it's better to focus on the .dv problem here (which is definitely not my field)...

doitux: anyway i'll give it a try. i know i've already asked, but i'll be more precise
please start kdenlive in a shell and apply the rotate effect to your .dv file to reproduce the black screen issue, then play: does the shell print messages similar to this?
X Error: BadAlloc (insufficient resources for operation) 11
  Extension: 140 (Uknown extension)
  Minor opcode: 19 (Unknown request)
  Resource id: 0x4400197
(0001687)
madsdyd (administrator)
2008-12-15 16:41

xzhayon: I agree. We should save your patch, because clearly this function expects at least one effect to be present.

I'll ask about adding Q_ASSERT_X to the code on the mailing list.
(0001697)
doitux (updater)
2008-12-15 23:28

i dont get this:
X Error: BadAlloc (insufficient resources for operation) 11
  Extension: 140 (Uknown extension)
  Minor opcode: 19 (Unknown request)
  Resource id: 0x4400197

Here a demo video of the black screen: http://pokerth.net/rotateEffect.mp4 [^]
(0001698)
doitux (updater)
2008-12-15 23:42

i also tested
MPEG-4 part 2
640x352
Frame rate: 30000.000000
Pixel aspect ratio: 1.000000
Same problem with non working rotate effect (black screen like in demo video)


Sorry for posting two seperate bugs in one report :/
(0001699)
xzhayon (developer)
2008-12-16 00:47

the user has the same problem with every file, also with files working on my box. removing mlt's distro packages and rebuilding the mlt's and kdenlive didn't help. the issue only happens with the 'rotate' effect
could be this only a problem of doitux's system? i think that dan would be helpful!
(0001734)
doitux (updater)
2008-12-17 00:40

The crash issue resolved in rev 2800. child issue 468 closed.

What do you think. Should we close it and i will open a new one about "rotate effect doesnt work"?
(0001743)
madsdyd (administrator)
2008-12-17 08:31

Changed summary. I think we can keep this bug about rotate not working, but putting it back into feedback, as we still can not reproduce by anyone but the original reporter.

doitux: I think we need a clip that does not work for you. The file upload limit has been raised to approx 50 MB. Do you perhaps have a 10 sec DV clip, that you can upload to this issue?
(0001745)
doitux (updater)
2008-12-17 08:56

Ok i upload a clip that doesnt work.
(0001747)
doitux (updater)
2008-12-17 09:32

Mmmh, when i try to upload a 34MB clip i always get this error:
Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 72000001 bytes) in /home/www/8864acea003f2354834d936830f18e43/web/mantis/core/database_api.php on line 395

This is the file:
-rwxr--r-- 1 doitux users 36000000 9. Nov 2006 Capture098.dv

Any ideas?
(0001748)
madsdyd (administrator)
2008-12-17 09:42

Sorry about that - I have asked jb to take a look at it.
(0001750)
xzhayon (developer)
2008-12-17 09:55

i can upload a clip of 3mb that doitux tested with the same results
(0001759)
xzhayon (developer)
2008-12-17 12:06

here's the clip, works perfectly here
(0003418)
doitux (updater)
2009-06-24 00:39

everything works fine now. i think this can be closed
(0003421)
xzhayon (developer)
2009-06-24 00:47

fixed somewhere

- Issue History
Date Modified Username Field Change
2008-12-15 11:58 doitux New Issue
2008-12-15 11:58 doitux File Added: undoDeleteClipWithRotateEffectCrash.log
2008-12-15 11:58 doitux Build/Install Method => Build Wizard
2008-12-15 12:05 madsdyd Note Added: 0001667
2008-12-15 12:05 madsdyd Status new => feedback
2008-12-15 12:06 madsdyd File Added: kbw.gdb.output.VZq28721
2008-12-15 12:07 madsdyd Relationship added related to 0000468
2008-12-15 12:07 doitux Note Added: 0001668
2008-12-15 13:01 cinephiliac Note Added: 0001671
2008-12-15 13:01 cinephiliac Status feedback => acknowledged
2008-12-15 14:06 xzhayon File Added: effect_addition_undoing.svn2789.patch
2008-12-15 14:07 xzhayon Note Added: 0001679
2008-12-15 16:30 xzhayon Note Added: 0001685
2008-12-15 16:41 madsdyd Note Added: 0001687
2008-12-15 16:42 madsdyd Relationship deleted related to 0000468
2008-12-15 16:42 madsdyd Relationship added parent of 0000468
2008-12-15 23:28 doitux Note Added: 0001697
2008-12-15 23:42 doitux Note Added: 0001698
2008-12-16 00:47 xzhayon Note Added: 0001699
2008-12-17 00:40 doitux Note Added: 0001733
2008-12-17 00:40 doitux Note Added: 0001734
2008-12-17 00:40 doitux Note Deleted: 0001733
2008-12-17 08:31 madsdyd Note Added: 0001743
2008-12-17 08:31 madsdyd Status acknowledged => feedback
2008-12-17 08:31 madsdyd Summary rotate effect doesnt work and undo deleting this clip crashes => rotate effect doesnt work
2008-12-17 08:56 doitux Note Added: 0001745
2008-12-17 09:32 doitux Note Added: 0001747
2008-12-17 09:42 madsdyd Note Added: 0001748
2008-12-17 09:55 xzhayon Note Added: 0001750
2008-12-17 12:05 xzhayon File Added: test-472.mpg
2008-12-17 12:06 xzhayon Note Added: 0001759
2009-06-24 00:39 doitux Note Added: 0003418
2009-06-24 00:47 xzhayon Note Added: 0003421
2009-06-24 00:47 xzhayon Status feedback => resolved
2009-06-24 00:47 xzhayon Fixed in Version => Recent git
2009-06-24 00:47 xzhayon Resolution open => fixed
2009-06-24 00:47 xzhayon Assigned To => xzhayon
2009-06-24 00:47 xzhayon Assigned To xzhayon =>
2009-06-24 00:48 xzhayon Target Version => future version
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:55 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker