Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000491KdenliveUser Interfacepublic2008-12-19 02:502009-05-30 12:01
Reporterxzhayon 
Assigned Toxzhayon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.4 
Summary0000491: backward seeking not working
Descriptionif you create/load a project and try to go backward with [none/ctrl/shift]+left arrow (alt works) nothing happens
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships
related to 0000546closed 'forward 1 frame' is broken... 

-  Notes
(0001807)
cinephiliac (updater)
2008-12-19 06:50

Really? For me Ctrl+left goes back one edit and left key alone moves cursor backwards. What are your versions? Mine are:

Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 16223 Last Changed Date: 2008-12-18 13:25:11 -0500 (Thu, 18 Dec 2008)
mlt: Revision: 1271 Last Changed Date: 2008-12-18 02:37:29 -0500 (Thu, 18 Dec 2008)
mlt++: Revision: 1271 Last Changed Date: 2008-12-04 17:31:49 -0500 (Thu, 04 Dec 2008)
kdenlive: Revision: 2808 Last Changed Date: 2008-12-18 08:31:46 -0500 (Thu, 18 Dec 2008)
Qt: 4.4.3
KDE: 4.1.85 (KDE 4.1.85 (KDE 4.2 Beta2))
Kdenlive: 0.7
(0001812)
xzhayon (developer)
2008-12-19 10:37

ffmpeg 14424
mlt/mlt++ 1265
kdenlive 2808
qt 4.4.3
kde 4.1.3

anyway i can't reproduce this on 2803, so it's must be something newly introduced (at least for me)
i'll try to rebuild everything and then i'll be back
(0001830)
xzhayon (developer)
2008-12-21 02:12

i still can't go backward, only alt+left works

ffmpeg 14424
mlt/mlt++ 1280
kdenlive 2809
qt 4.4.3
kde 4.4.3

can it be my old ffmpeg? i don't think so...
i'll check the new commits to see what changed
(0002675)
xzhayon (developer)
2009-04-09 02:57

nothing changed here. ffmpeg it's the same (14424), mlt and kdenlive are built from HEAD, qt it's 4.4.3 and kde it's 4.2.2
(0002842)
xzhayon (developer)
2009-05-11 11:30

i've finally fixed this in rev. 3371. since i was the only one to get the issue, i'm marking it as resolved

unfortunately it required a little hack: m_position value wasn't upgraded. this happened probably because of some issues in cmake, or similar (the same code is working in forward seeking, and also adding some kDebug() here and there fixed my problem, so it's something really strange)
i promise i'll check cmake/qt/automoc updates to hopefully remove this hack in the future

- Issue History
Date Modified Username Field Change
2008-12-19 02:50 xzhayon New Issue
2008-12-19 02:50 xzhayon Build/Install Method => Manual build from SVN
2008-12-19 06:50 cinephiliac Note Added: 0001807
2008-12-19 06:50 cinephiliac Status new => feedback
2008-12-19 10:37 xzhayon Note Added: 0001812
2008-12-21 02:12 xzhayon Note Added: 0001830
2009-04-09 02:57 xzhayon Note Added: 0002675
2009-05-11 11:30 xzhayon Note Added: 0002842
2009-05-11 11:30 xzhayon Status feedback => resolved
2009-05-11 11:30 xzhayon Fixed in Version => Recent git
2009-05-11 11:30 xzhayon Resolution open => fixed
2009-05-11 11:30 xzhayon Assigned To => xzhayon
2009-05-30 11:58 administrator Fixed in Version Recent git => 0.7.4
2009-05-30 12:01 administrator Status resolved => closed
2009-08-03 00:15 xzhayon Relationship added related to 0000546


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker