Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000524KdenliveTransitionspublic2008-12-26 00:422009-01-04 13:23
Reporterreinhard 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusacknowledgedResolutionopen 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version8.10
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000524: 2 transitions at the same time don't work
Description- place one segment on track 1: 00:00:00:00 - 00:00:04:00
- place another segment in track 2: 00:00:02:00 - 00:00:06:00
- add a transition (luma) that dissolve from track 1 to track 2
- add a segment in track 0: 00:00:01:00 - 00:00:03:00
- add a transition (composition) to the whole segment in track 0
check 'composite-luma-problem.png' for details

... now the transitions are broken from 00:00:02:00 - 00:00:03:00
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filespng file icon composite-luma-problem.png [^] (193,473 bytes) 2008-12-26 00:42


png file icon transition_track.png [^] (15,950 bytes) 2008-12-29 05:01

- Relationships

-  Notes
(0001957)
administrator (administrator)
2008-12-29 05:02

Please try editing the transition between track 0 and 1 and set it's transition track to track 2 (see attached picture transition_track.png) and tell me if it works for you.
(0001970)
reinhard (reporter)
2008-12-29 23:47

yes, works fine this way - hopefully you can make this happen automagically.
(0001974)
madsdyd (administrator)
2008-12-30 15:45

Should this be acknowledged? I am not sure what the reporters intention actually were?
(0001983)
reinhard (reporter)
2008-12-30 23:41

I vote for 'yes' ;)
Also my last comment seems wrong (sorry, but I was sick the last days)

The intended behaviour of the 'auto' transition should be, in case of this PIP composition, to work from track 0 to 1, respectively the segment below. And this association should be retain, but is broken when the luma transition from track 1 to track 2 begins.
(0001986)
madsdyd (administrator)
2008-12-31 13:49

OK, acknowledging as a feature request. I am still not totally sure what the intended behavoiur should be, but I hope jb is :-). Otherwise I hope he will put it back into feedback.
(0001997)
reinhard (reporter)
2009-01-01 20:04

there is some weirdness here, because I've found out that the issue depends on the order how to create the timeline composition.

It works as expected when you do it in this order...

(It seems also important to restart kdenlive; otherwise things happen different!)

- restart kdenlive
- create a new project
- place one segment in track 1: 00:00:00:00 - 00:00:04:00
- place another segment in track 2: 00:00:02:00 - 00:00:06:00
- add a segment in track 0: 00:00:01:00 - 00:00:03:00
- add a transition (composition) to the whole segment in track 0

NEW (forgot to mention this, which might caused some confusion, SORRY!!):

- make the picture (segment in track 0) smaller, by changing the size of the red rectangle.

AND now finally:

- add a transition (luma) that dissolve from track 1 to track 2

So when you create the luma transition first it will NOT work as expected.
(0002028)
ddennedy (developer)
2009-01-03 08:32

I agree with madsdyd that this report is unclear about exactly what is "broken" about the behaviour. What I see in the 2:00 - 3:00 perioud is that the PiP is dissolving along with the other 2 tracks, and that is what I would expect. If I did not want that I have to shorten the PiP or make the dissolve to track 2 start later.

If changing the Composite to track 2 is the expected behavior, then I do not understand how one can establish the rules under which kdenlive would automatically know when to do this. It does not know what you are trying to achieve - how you are using the composite.

Or is the problem that from 2:00 - 3:00 that track 0 seems to dissolve with track 1 where that was not explicitly requested? (I do expect the composition of track 0 and track 1 to dissolve into track 2, but it also appears as though there might be some opacity <100 in the Composite even though it is set to 100.)
(0002029)
ddennedy (developer)
2009-01-03 08:37

Oh, I think you want the track 0 (PiP) to always be on top fully opaque and not be dissolving into anything. The 2 tracks below should be an independent dissolve with the PiP overlayed. Am I right?
(0002030)
ddennedy (developer)
2009-01-03 08:46

OK, now I just tried again, doing steps in a different order, and I see a different result, and I can not recreate the effect I was seeing in my first test no matter how I change "with track." It seems there is some non-obvious sensitivity to the order.
(0002031)
ddennedy (developer)
2009-01-03 08:54

Confirmed:

Add Composite transition between 0 & 1 before the Luma between 1 & 2 => the PiP dissolves.

Add the Luma transition first => the PiP does not dissolve.

Maybe this is a feature. ;-) In any case, the problem is that I can not seem to switch between the 2 outcomes any other way, but it seems that there should be some more explicit control.
(0002036)
reinhard (reporter)
2009-01-03 15:59

@ ddennedy:
yeah, finally you've found the right words to describe the problem ;)
The PiP in track 0 should dissolving along with the other 2 tracks (in the 2:00 - 3:00 period).
This is what I've expected...

The other issue with fully opaque PIP on top of all, seems another issue, since I can't find out how to realize such a composition?!? Did I missed something?

Maybe this could be solved when some resize, scale, crop effects will be introduced at some time?
http://www.kdenlive.org/forum/scaleresize-effect [^]
(0002042)
ddennedy (developer)
2009-01-04 01:52

The need for scale and crop is totally separate from this. At the rate of the bugs coming in, I would not expect new features for a while.
(0002047)
reinhard (reporter)
2009-01-04 13:23

yep, so I've just filed a feature request...
http://www.kdenlive.org/mantis/view.php?id=565 [^]

- Issue History
Date Modified Username Field Change
2008-12-26 00:42 reinhard New Issue
2008-12-26 00:42 reinhard File Added: composite-luma-problem.png
2008-12-26 00:42 reinhard Build/Install Method => Build Wizard
2008-12-29 05:01 administrator File Added: transition_track.png
2008-12-29 05:02 administrator Note Added: 0001957
2008-12-29 23:47 reinhard Note Added: 0001970
2008-12-30 15:45 madsdyd Note Added: 0001974
2008-12-30 15:45 madsdyd Status new => feedback
2008-12-30 23:41 reinhard Note Added: 0001983
2008-12-31 13:49 madsdyd Note Added: 0001986
2008-12-31 13:49 madsdyd Severity major => feature
2008-12-31 13:49 madsdyd Status feedback => acknowledged
2009-01-01 20:04 reinhard Note Added: 0001997
2009-01-03 08:32 ddennedy Note Added: 0002028
2009-01-03 08:37 ddennedy Note Added: 0002029
2009-01-03 08:46 ddennedy Note Added: 0002030
2009-01-03 08:54 ddennedy Note Added: 0002031
2009-01-03 15:59 reinhard Note Added: 0002036
2009-01-04 01:52 ddennedy Note Added: 0002042
2009-01-04 13:23 reinhard Note Added: 0002047


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker