Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000535KdenliveUser Interfacepublic2008-12-29 18:572010-11-15 14:01
Reporterjappel 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.7 
Summary0000535: some clips in the timeline no longer show anything in the clipmonitor
Descriptionthis is related to issue 0000534 and 0000533:

Although preview images of clips are shown accurately, some clips from the timeline do not show any video anymore. I encountered this earlier also with files that have been saved normally (i.e. no recovery involved).
Additional Informationclips info:
 
 Mime:video/mpeg
 Audio:MPEG audio layer 2 (lib: MAD) 64kb/s
 Video:MPEG (libmpeg2) 640x480(640x480)
 
 
 program versions:
 
 Kdenlive Builder Wizard version: 0.7.1
 ffmpeg: Revision: 16384 Last Changed Date: 2008-12-29 13:11:01 +0100 (Mon, 29 Dec 2008)
 mlt: Revision: 1297 Last Changed Date: 2008-12-28 21:43:00 +0100 (Sun, 28 Dec 2008)
 mlt++: Revision: 1297 Last Changed Date: 2008-12-29 00:35:06 +0100 (Mon, 29 Dec 2008)
 kdenlive: Revision: 2853 Last Changed Date: 2008-12-29 04:50:56 +0100 (Mon, 29 Dec 2008)
 Qt: 4.4.3
 KDE: 4.1.85 (KDE 4.1.85 (KDE 4.2 Beta2))
 Kdenlive: 0.7
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon backtrace_conv [^] (14,688 bytes) 2009-01-14 17:41 [Show Content]

- Relationships
has duplicate 0001110closedj-b-m Kdenlive some times is reading/export my clips, some times it don't. 

-  Notes
(0001993)
jappel (reporter)
2008-12-31 20:44

After some further testing, which involved a different computer, different fileformats and a fresh build of kdenlive & friends...

Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 16397 Last Changed Date: 2008-12-30 13:02:35 +0100 (Tue, 30 Dec 2008)
mlt: Revision: 1301 Last Changed Date: 2008-12-30 01:21:18 +0100 (Tue, 30 Dec 2008)
mlt++: Revision: 1301 Last Changed Date: 2008-12-29 00:35:06 +0100 (Mon, 29 Dec 2008)
kdenlive: Revision: 2859 Last Changed Date: 2008-12-29 14:18:51 +0100 (Mon, 29 Dec 2008)
Qt: 4.4.3
KDE: 4.1.85 (KDE 4.1.85 (KDE 4.2 Beta2))
Kdenlive: 0.7.1

.. I came to the conclusion that this is fileformat related. When a timeline is editing which contains only raw-dv video, and i save the timeline, quit kdenlive, restart and load the saved project, everything is fine.

When I save a timeline which contains the attached fileformat, restart kdenlive and open the project, some of the clips in the timeline no longer show any video in the timeline view (rendering also omits some clips.

I could not upload a testfile for your hacking pleasure here, so you can find it here:

http://rapidshare.com/files/178536787/mov02367.mpg.html [^]

Muchas gracias for looking into it.
(0002023)
ddennedy (developer)
2009-01-03 07:30

I reproduced this in kdenlive, and then I reproduced it on the inigo command line:

inigo mov02367.mpg in=26

If I change the profile to dv_ntsc, then it starts to fail to show video when in=31.

This must be something related to MPEG-1 and the first one second of video. I will investigate it.
(0002133)
ddennedy (developer)
2009-01-14 10:18

BTW, ffplay is reporting "invalid dts/pts combination" when playing this file. Also, a transcode using the ffmpeg utility that does not start at the beginning fails to transcode the video:

$ ffmpeg -ss 1 -i mov02367.mpg test.mpg
$ ffmpeg -i test.mpg
...
Input #0, mpeg, from 'test.mpg':
  Duration: 00:00:34.70, start: 0.500000, bitrate: 65 kb/s
    Stream #0.0[0x1c0]: Audio: mp2, 32000 Hz, mono, s16, 64 kb/s
$ ffplay test.mpg shows audio waveforms for the video

Basically, this file is not seekable, but this fact is not readily apparant to MLT. Therefore, it is not safe for editing. Sorry. You should transcode this file before using it.
(0002134)
ddennedy (developer)
2009-01-14 10:23

Well despite the above, it is quite seekable in the clip monitor, so I am going to look into this deeper because it is a curiosity, but I make no guarantee.

If you decide to transcode, I recommend the lossless HuffYuv AVI format. You can use kdenlive for this, just put the whole clip on a track by itself and render.
(0002140)
jappel (reporter)
2009-01-14 17:40

I converted the original file to huffyuv with kdenlive. The resulting file contains weird, colored lines moving randomly in the lower quarter of the video when played with kaffeine/xine. Adding this file to the project tree in kdenlive crashes kdenlive right away.

I also converted the original file to H264 I-frame only from the lossless / hq section in the render dialog. The resulting file can be added to kdenlive again without crashing the application, i will convert the original video into other lossless/hq formats, and then test if i they do the trick.

I ll attach a backtrace for the crash that occurs always when trying to add the huffyuv video to the project tree.
thanks for the hint and the investigation,
J.

(i am not using the freshed svn versions atm, I cannot update due to network restrictions)

Kdenlive Builder Wizard version: 0.7.1
ffmpeg: Revision: 16397 Last Changed Date: 2008-12-30 13:02:35 +0100 (Tue, 30 Dec 2008)
mlt: Revision: 1301 Last Changed Date: 2008-12-30 01:21:18 +0100 (Tue, 30 Dec 2008)
mlt++: Revision: 1301 Last Changed Date: 2008-12-29 00:35:06 +0100 (Mon, 29 Dec 2008)
kdenlive: Revision: 2859 Last Changed Date: 2008-12-29 14:18:51 +0100 (Mon, 29 Dec2008)
Qt: 4.4.3
KDE: 4.1.96 (KDE 4.1.96 (KDE 4.2 RC1))
Kdenlive: 0.7.1
(0002141)
ddennedy (developer)
2009-01-14 18:22

OK, thanks for reporting the new trouble with the huffyuv conversion. I used the DV NTSC profile when I tried it. I see you were using HDV 1080 50i, with which I will try to reproduce because the backtrace is not very helpful due to stack corruption.
(0002991)
ddennedy (developer)
2009-05-30 06:14

I have a workaround for this in my working copy, but it severely reduces performance on seeking because it must decode from the beginning up to the sought frame. Unfortunately, at this time, it does it for all MPEG-1 Video. Therefore, I have to think more about whether to commit it. I tried to add detection of a buggy stream and then appy this, but it failed. I have to try harder, but I do not want workarounds for bugs to be intrusive to the code.

(0004146)
ddennedy (developer)
2009-10-13 07:02

As a workaround for now, the 0.7.6 release of Kdenlive adds a Transcode preset to "Fix MPEG-1".
(0004151)
jappel (reporter)
2009-10-13 09:10

when I manually transcode the files to

"fix mpeg-1"
the resulting file has no audio

"fix ogg theora"
the transcoding fails

"lossless matroska"
there is no video shown (at least in kdenlive)

"remux mpgeg2"
there is no video shown (at least in kdenlive)

"DNxHD 1920..."
The transcoded files has video & audio, but doesnt keep it's screen ratio (original files are 640x480), so all transcoded files have to be set to "force PAR" 0.75 in the clip properties.

thanks for keeping an eye on it.
(0004156)
ddennedy (developer)
2009-10-13 18:22

Fix Ogg Theora and Remux MPEG-2 are not intended to work with MPEG-1. DNxHD is only intended for widescreen HD footage. Also, it is not surprising that Lossless Matroska did not work since that uses HuffYUV for which you already reported a problem. I am very surprised that Fix MPEG-1 did not work. You might want to consider a newer FFmpeg version if you do not have something as recent as v0.5 released Mar 10, 2009.
(0004157)
jappel (reporter)
2009-10-13 19:29

so far i used ffmpeg rev19361 of Jul 6, I just updated to todays SVN-r20225 & recompiled mlt & kdenlive. Still, the MPEG-1 file plays no audio in kdenlive.
(0004162)
ddennedy (developer)
2009-10-14 05:29

I located your original mov02367.mpg on my hard drive and tested 'Fix MPEG-1' with that, and it worked beautifully! Even when trimming the beginning beyond 1 second. Lossless Matroska worked as well. Sorry it does not work for you.

Re "Still, the MPEG-1 file plays no audio in kdenlive." That is expected; there are no fixes or improvements to MPEG-1 seeking in MLT/FFmpeg. I am just commenting on the workarounds for now.
(0004696)
j-b-m (administrator)
2010-02-09 14:18

Issue seems to be fixed in recent FFMpeg: https://roundup.ffmpeg.org/roundup/ffmpeg/issue1226 [^]

Please confirm

- Issue History
Date Modified Username Field Change
2008-12-29 18:57 jappel New Issue
2008-12-29 18:57 jappel Build/Install Method => Build Wizard
2008-12-31 20:44 jappel Note Added: 0001993
2009-01-03 07:28 ddennedy Status new => assigned
2009-01-03 07:28 ddennedy Assigned To => ddennedy
2009-01-03 07:30 ddennedy Note Added: 0002023
2009-01-14 10:18 ddennedy Note Added: 0002133
2009-01-14 10:18 ddennedy Status assigned => resolved
2009-01-14 10:18 ddennedy Resolution open => not fixable
2009-01-14 10:23 ddennedy Note Added: 0002134
2009-01-14 10:25 ddennedy Status resolved => feedback
2009-01-14 10:25 ddennedy Resolution not fixable => reopened
2009-01-14 17:40 jappel Note Added: 0002140
2009-01-14 17:41 jappel File Added: backtrace_conv
2009-01-14 18:22 ddennedy Note Added: 0002141
2009-05-30 06:14 ddennedy Note Added: 0002991
2009-05-30 06:14 ddennedy Status feedback => acknowledged
2009-09-16 23:24 ddennedy Relationship added has duplicate 0001110
2009-10-13 07:02 ddennedy Note Added: 0004146
2009-10-13 09:10 jappel Note Added: 0004151
2009-10-13 18:22 ddennedy Note Added: 0004156
2009-10-13 19:29 jappel Note Added: 0004157
2009-10-14 05:29 ddennedy Note Added: 0004162
2010-02-09 14:18 j-b-m Note Added: 0004696
2010-02-09 14:18 j-b-m Status acknowledged => feedback
2010-11-15 14:01 ttill Status feedback => resolved
2010-11-15 14:01 ttill Resolution reopened => fixed
2010-11-15 14:01 ttill Fixed in Version => 0.7.7
2010-11-15 14:01 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker