Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000540KdenliveUser Interfacepublic2008-12-30 15:282009-02-02 23:49
Reportermadsdyd 
Assigned Tomadsdyd 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSKubuntu LinuxOS Version8.04
Product VersionRecent git 
Target VersionFixed in Version0.7.2 
Summary0000540: Crash related to folder handling and project/clip ids
DescriptionThere is an issue related to the way that groupid's and clipid's are used in the project tree, that makes Kdenlive crash, if a folder has a higher id (groupid?) than the clip with the highest id.

The steps to reproduce are somewhat involved...
Steps To Reproduce- start kdenlive
- add a clip
- add a folder
- make the clip a child of the folder
- save the file as test.kdenlive
- close kdenlive
- start kdenlive
- open the test.kdenlive file, confirm folder and clip present in the project tree
- add a clip to the project tree: crash.
Additional InformationNote, that if you do not make the clip a child of the folder, the folder will not be save in the project file. I think this is a bug in itself, actually, but it is probably due to a limitation in the project file format.

I found out about this problem when loading old kdenlive 0.5 projects that had folders. Folders are created after clips, when converting.

This patch removes the crash, but I am not sure it is the right approach or "enough":

--- clipmanager.cpp 2008-12-28 20:30:00.000000000 +0100
+++ clipmanager.cpp.mads 2008-12-28 20:29:56.000000000 +0100
@@ -100,6 +100,12 @@
     m_clipList.append(clip);
     const QString id = clip->getId();
     if (id.toInt() >= m_clipIdCounter) m_clipIdCounter = id.toInt() + 1;
+ // mbd: This is to handle Folders - which are hard to distinguesh from clips - when loading
+ // from old (0.5) kdenlive files, we currently create the folders *after* all the clips.
+ // So, adding a new clip to a 0.5 project with folders breaks down, because groupids and
+ // clipids are *not* seperated. They should, really.
+ const QString groupId = clip->getProperty( "groupid" );
+ if (groupId.toInt() >= m_clipIdCounter) m_clipIdCounter = groupId.toInt() + 1;
 }
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0002241)
madsdyd (administrator)
2009-01-27 13:54

Svn 2937 has a fix, tested, confirmed: resolving. Thanks jb.

- Issue History
Date Modified Username Field Change
2008-12-30 15:28 madsdyd New Issue
2008-12-30 15:28 madsdyd Build/Install Method => Build Wizard
2009-01-27 13:54 madsdyd Note Added: 0002241
2009-01-27 13:54 madsdyd Status new => resolved
2009-01-27 13:54 madsdyd Fixed in Version => Recent git
2009-01-27 13:54 madsdyd Resolution open => fixed
2009-01-27 13:54 madsdyd Assigned To => madsdyd
2009-02-02 23:42 xzhayon Fixed in Version Recent git => 0.7.2
2009-02-02 23:49 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker