Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000552KdenliveUser Interfacepublic2009-01-02 02:312009-06-18 01:51
Reportergriphiam 
Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.3 
Summary0000552: Clip in timeline cannot be removed
DescriptionThis happens every so often, and I'm unable to detect a pattern. The clip is there in a timeline and can be moved between tracks but it doesn't appear when you render it. I'm unable to delete it, and the console prints --

kdenlive(5047) Render::mltRemoveClip: // WARMNING, TRYING TO REMOVE A BLANK: 0 , AT: 2695

where the AT: XXX changes depending on the location of the clip. Trying to move it in time produces --

kdenlive(5047) EffectStackEdit::transferParamDesc: in
kdenlive(5047) Render::mltMoveClip: ////// LOOKING FOR CLIP TO MOVE, INDEX: 0
kdenlive(5047) Render::mltMoveClip: // ERROR MOVING CLIP TO : 2546
kdenlive(5047) MoveClipCommand::redo: ---- redoing action
kdenlive(5047) Render::mltMoveClip: ////// LOOKING FOR CLIP TO MOVE, INDEX: 0
kdenlive(5047) Render::mltMoveClip: // ERROR MOVING CLIP TO : 2569
kdenlive(5047) CustomTrackView::moveClip: // MOVED CLIP TO: 2569 , ITEM START: 2546

And it does move in the UI. Trying to resize it produces --

kdenlive(5047) Render::mltResizeClipEnd: //////// ERROR RSIZING BLANK CLIP!!!!!!!!!!!

And the UI springs back to the original clip size.

Ocasionally, the same behavior is experienced with Transitions, but usually if I shrink them down to a small size, they can be removed.
Additional InformationThe ability to name a clip or transition might help, as you can then look at the raw xml file to figure out where it is.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filestxt file icon build_info.txt [^] (1,801 bytes) 2009-01-02 12:33 [Show Content]
? file icon Walk-in-Tallinn.kdenlive [^] (62,895 bytes) 2009-01-02 19:02
? file icon new_video.kdenlive [^] (26,444 bytes) 2009-01-02 20:16
? file icon phantom_clips.kdenlive [^] (37,840 bytes) 2009-01-02 23:14
txt file icon kdenlive_crash.txt [^] (60,166 bytes) 2009-01-21 17:34 [Show Content]
txt file icon kdenlive_resize.txt [^] (49,688 bytes) 2009-01-22 09:33 [Show Content]

- Relationships

-  Notes
(0002000)
Cimmo (reporter)
2009-01-02 12:31

Happening for me as well, I compiled Kdenlive 0.7.1 and loaded a project done with 0.7 and now I cannot delete/resize any of the video pieces.

kdenlive(11596) Render::mltRemoveClip: // WARMNING, TRYING TO REMOVE A BLANK: 9 , AT: 2442

kdenlive(11596) EffectStackEdit::transferParamDesc: in
kdenlive(11596) Render::mltResizeClipEnd: //////// ERROR RSIZING BLANK CLIP!!!!!!!!!!!

My package is here:
http://www.marcocimmino.net/2009/01/01/kdenlive-071-for-ubuntu-804/ [^]
(0002005)
madsdyd (administrator)
2009-01-02 18:35

Could you perhaps try to create steps to reproduce, or make available (through attach) the 0.7 project that does not load in 0.7.1?

Would help a lot.
(0002012)
Cimmo (reporter)
2009-01-02 19:02

Attached, hope it's enough (no video)
(0002015)
griphiam (reporter)
2009-01-02 20:16

When I opened the project this morning, those clips I couldn't remove yesterday, were removed. If I see the problem again, I will try reopening the file to see if that clears the error.

I am also attaching my kdenlive project, in case that helps.
(0002022)
griphiam (reporter)
2009-01-02 23:15

I've uploaded a new kdenlive xml file. The two phantom clips appear around the 7:30 and 8:45 marks. The main project content ends at the 3:30 mark, so everything after that shouldn't be there (and I can't remove those clips).
(0002164)
Cimmo (reporter)
2009-01-21 00:42

madsdyd is there something else you need to deal with the bug? Just asking as the BR is still under "Feedback" mode, thanks
(0002169)
administrator (administrator)
2009-01-21 13:53

Several important fixes were done in the last 2 weeks to prevent that kind of corruption. Can anybody try to reproduce the issue with the current svn version ?
(0002173)
Cimmo (reporter)
2009-01-21 17:34

I can't verify as kdenlive crashes as soon as I close the dialog that tell me that one file doesn't exist and will be dismissed from the project, attached crash log
(0002174)
administrator (administrator)
2009-01-21 18:55

Thanks Cimmo. The crash you reported should now be fixed in svn, please update & try again.
(0002178)
Cimmo (reporter)
2009-01-22 09:35

Ok crash is now ok, about resize:
1. some cannot be resized at all
2. some if you resize them they just become one single vertical line
3. some are resizible

attaching log, I don't know how to help anymore, need a video?
(0002179)
administrator (administrator)
2009-01-22 12:57

Would be great to solve that issue. But I need the project file with the video files to reproduce the bug.

Could you try to open the project, remove all clips from your project, only leaving one of the problematic clip ? Then save as test.kdenlive and reopen to see if the problem is still here.

After that could you mail me the project file and the problematic video clip ? That's the only way I can think of...

You can mail it to me privately (jb at kdenlive org), I will ony use the video clip for debugging purposes...
(0002200)
madsdyd (administrator)
2009-01-25 21:31

Changing to acknowledged.

Cimmo: Sorry about the delay, January has been a b.... with real-life just keeping taking time away from kdenlive. Unfortunately February looks bad too... :-(

Thanks for keeping us on our toes.
(0002703)
Cimmo (reporter)
2009-04-11 17:00
edited on: 2009-04-11 17:01

kdenlive: Revision: 3285 Last Changed Date: 2009-04-11 09:03:34 +0200 (Sat, 11 Apr 2009)

Cannot reproduce the problem anymore, seems fixed :)


- Issue History
Date Modified Username Field Change
2009-01-02 02:31 griphiam New Issue
2009-01-02 02:31 griphiam Build/Install Method => Manual build from SVN
2009-01-02 12:31 Cimmo Note Added: 0002000
2009-01-02 12:33 Cimmo File Added: build_info.txt
2009-01-02 18:35 madsdyd Note Added: 0002005
2009-01-02 18:35 madsdyd Status new => feedback
2009-01-02 19:02 Cimmo File Added: Walk-in-Tallinn.kdenlive
2009-01-02 19:02 Cimmo Note Added: 0002012
2009-01-02 20:16 griphiam Note Added: 0002015
2009-01-02 20:16 griphiam File Added: new_video.kdenlive
2009-01-02 23:14 griphiam File Added: phantom_clips.kdenlive
2009-01-02 23:15 griphiam Note Added: 0002022
2009-01-21 00:42 Cimmo Note Added: 0002164
2009-01-21 13:53 administrator Note Added: 0002169
2009-01-21 17:34 Cimmo File Added: kdenlive_crash.txt
2009-01-21 17:34 Cimmo Note Added: 0002173
2009-01-21 18:55 administrator Note Added: 0002174
2009-01-22 09:33 Cimmo File Added: kdenlive_resize.txt
2009-01-22 09:35 Cimmo Note Added: 0002178
2009-01-22 12:57 administrator Note Added: 0002179
2009-01-25 21:31 madsdyd Note Added: 0002200
2009-01-25 21:31 madsdyd Status feedback => acknowledged
2009-04-11 17:00 Cimmo Note Added: 0002703
2009-04-11 17:01 Cimmo Note Edited: 0002703
2009-04-13 18:49 administrator Status acknowledged => resolved
2009-04-13 18:49 administrator Resolution open => fixed
2009-04-13 18:49 administrator Fixed in Version => Recent git
2009-04-15 13:07 madsdyd Fixed in Version Recent git => 0.7.3
2009-06-18 01:51 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker