Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000558KdenliveRenderingpublic2009-01-03 05:482009-02-02 23:49
Reportergriphiam 
Assigned Tomadsdyd 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.2 
Summary0000558: White text in a title clip is rendered with a green tinge
DescriptionBoth in the preview and in final rendering. When editing the title clip and selecting "show background" it shows the correct color.

Attached is a screenshot. This should be white text on black background.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filespng file icon title_text.png [^] (94,665 bytes) 2009-01-03 05:48


png file icon title000.png [^] (5,363 bytes) 2009-01-03 07:33


diff file icon qimage_patch.diff [^] (3,469 bytes) 2009-01-05 07:38 [Show Content]

- Relationships

-  Notes
(0002024)
ddennedy (developer)
2009-01-03 07:34

I noticed this too. I attached the title image file kdenlive saved to $HOME/kdenlive/titles. It looks to be something in the Qt-based titler as opposed to in MLT.
(0002034)
griphiam (reporter)
2009-01-03 10:03

Agreed. Just checked the white text in $HOME/kdenlive/titles -- All the png files have the same green tinge (black text seems fine). Probably not a rendering issue then, but the title png generation.
(0002062)
griphiam (reporter)
2009-01-05 03:53

Modified the source code to see if the problem had something to do with Antialiasing... turning render hints on and off had no effect.

I think it has something to do with the transparent background. If you actually fill a black background in the Title Widget, then it renders the white text correctly.
(0002063)
griphiam (reporter)
2009-01-05 07:16

So it turns out to be a problem with antialiasing.

If I add the following line to TitleWidget::slotNewText around line 371

font.setStyleStrategy(QFont::NoAntialias);

Then the white text on transparent does not render with green artifacts. Apparently Antialiasing is on by default in the QFont class. I've tried doing some google searching to see if anyone else was having the same issue, and haven't come up with any hits.

The best thing to do might be to add a button for antialiasing (similar to Bold, Italic & Underline) that the user can toggle. I can try generating the appropriate patch files if the rest of the developers agree this is an OK solution -- I think it's appropriate that the user have control over this. However, Qt4 should be able to render white antialiased fonts on a transparent background. I'll try to do a bit more research to see if anyone else has a solution.
(0002064)
griphiam (reporter)
2009-01-05 07:38

Update!!

According to the Qt4 Doc --http://doc.trolltech.com/4.0/qt4-arthur.html [^]

Antialiasing is only supported when writing to QImage, not QPixmap. If you change TitleWidget::renderedPixmap() to return QImage (and update QPixmap to QImage in all the right places) it works with no green artifacts. QImage and QPixmap have similar functions so the changes in the code else where are trivial.

I've attached the svn diff patch.
(0002100)
madsdyd (administrator)
2009-01-10 23:52

I acknowledge the problem, and have assigned to self - will test and probably apply patch at some point "soonish"
(0002116)
administrator (administrator)
2009-01-13 18:05

Patch applied, please test if it works correctly for you
(0002148)
griphiam (reporter)
2009-01-15 06:48

Verified using SVN revision 2920
(0002184)
madsdyd (administrator)
2009-01-23 14:26

Resolving as fixed as admin and reporter seems to agree :-)

- Issue History
Date Modified Username Field Change
2009-01-03 05:48 griphiam New Issue
2009-01-03 05:48 griphiam File Added: title_text.png
2009-01-03 05:48 griphiam Build/Install Method => Build Wizard
2009-01-03 07:33 ddennedy File Added: title000.png
2009-01-03 07:34 ddennedy Note Added: 0002024
2009-01-03 10:03 griphiam Note Added: 0002034
2009-01-05 03:53 griphiam Note Added: 0002062
2009-01-05 07:16 griphiam Note Added: 0002063
2009-01-05 07:38 griphiam Note Added: 0002064
2009-01-05 07:38 griphiam File Added: qimage_patch.diff
2009-01-10 23:52 madsdyd Note Added: 0002100
2009-01-10 23:52 madsdyd Assigned To => madsdyd
2009-01-10 23:52 madsdyd Status new => acknowledged
2009-01-13 18:05 administrator Note Added: 0002116
2009-01-15 06:48 griphiam Note Added: 0002148
2009-01-23 14:26 madsdyd Note Added: 0002184
2009-01-23 14:26 madsdyd Status acknowledged => resolved
2009-01-23 14:26 madsdyd Fixed in Version => Recent git
2009-01-23 14:26 madsdyd Resolution open => fixed
2009-02-02 23:42 xzhayon Fixed in Version Recent git => 0.7.2
2009-02-02 23:49 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker