Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000565KdenliveEffectspublic2009-01-04 13:212009-06-18 01:51
Reporterreinhard 
Assigned Toddennedy 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.3 
Summary0000565: scale and crop effects
DescriptionSeems still important to have IMHO
http://www.kdenlive.org/forum/scaleresize-effect [^]

Also might be useful when realizing a PIP without the need to fiddling with composite transition, which is sometimes problematic...
http://www.kdenlive.org/mantis/view.php?id=524 [^]
TagsNo tags attached.
Build/Install MethodNot Applicable
Attached Files? file icon crop behaviour.ogv [^] (4,733,526 bytes) 2009-02-15 23:22

- Relationships
has duplicate 0000509closedddennedy A possibility to 'crop' clips is really needed IMHO 
has duplicate 0000632acknowledgedLeHomard Pan/Crop/3D view 

-  Notes
(0002428)
ddennedy (developer)
2009-02-15 04:54

in MLT SVN r1357 and Kdenlive SVN r3048
(0002431)
reinhard (reporter)
2009-02-15 22:55
edited on: 2009-02-15 23:21

Thanks for adding the crop effect, but it works not as I've expected...but maybe I'm wrong...
Actually it works a little bit dynamically ;)

Because when I move one of the sliders the opposite side will be affected too.
For example - I move the 'Top' slider to remove some lines of pixels from the top, but the buttom of the movie moves up in addition?!?
Is this the correct behaviour?

Also sometimes it works more like a 'crop & zoom'...
For example - move the 'Top' slider and afterwards move the 'Left' slider which zooms into the movie...

I'll upload a video to illustrate the issue...

(0002433)
ddennedy (developer)
2009-02-16 09:45

I understand, this reaction was somewhat exepected, but this is intended behavior to preserve the aspect ratio. It is not correct to distort the aspect ratio. So, yes, you have to remove some from neighboring edges to compensate. Alternatively, you could just use the new Pan and Zoom I have added to scale up the image slightly. I suppose one could justify slightly distorting the aspect ratio to trim tiny amounts from the edges; however, you can also easily do the more proper thing to keep aspect ratio by adjusting the neighboring edges.
(0002434)
ddennedy (developer)
2009-02-16 10:29

A helpful clarification - it is preserves the pixel aspect ratio, not the display aspect ratio of the active image area. Then, it must pad the image to meet the project settings resolution and apsect ratio. Think about it like this: if you remove 50 pixels from the left edge of a 4:3 image and you want to keep the same output 4:3 image and size, then you either need to stretch the video and thereby distort it, or you can center it and pad each side, or you can scale it to fill the width, which effectively is removing equal amounts from the top and bottom. Right now, I am just not giving you the option to distort it, but if you really want to distort, then you can use the Composite transition with a color clip, which features the very obvious and scary "Distort" checkbox.
(0002436)
reinhard (reporter)
2009-02-17 23:20

Ok, I think I understand your point and I also want to keep the pixel aspect ratio! At least most of time ;)
But originally I thought the removed pixels would be just transparent, since I mostly need it when doing PIP compositions to remove unused pixels.
So what about adding this as a option?
BTW - Would also be nice to have this for 'pan and zoom', or is this a ugly/bad solution?
But on the other hand - maybe I just don't understand the benefit of the actual behaviour...
(0002437)
ddennedy (developer)
2009-02-17 23:27

Yes, I will look into adding an alpha mask for these.
(0002438)
reinhard (reporter)
2009-02-17 23:34

GREAT, THANKS!!!
(0002542)
ddennedy (developer)
2009-03-13 07:37

Fixed in kdenlive SVN r3146.

This works now via the Composite transition when Align is enabled (default). Align causes the automatic padding to set the alpha channel to make padded areas be transparent. This works with anything that does padding including compositing slideshows, image clips, cropped video clips, etc. When Distort is disabled the composite rectangle acts as a bounding box, and with Align enabled it ignores the padding for positioning the overlay within the bounding box.

- Issue History
Date Modified Username Field Change
2009-01-04 13:21 reinhard New Issue
2009-01-04 13:21 reinhard Build/Install Method => Not Applicable
2009-02-09 09:43 ddennedy Status new => assigned
2009-02-09 09:43 ddennedy Assigned To => ddennedy
2009-02-09 09:45 ddennedy Relationship added has duplicate 0000509
2009-02-09 09:45 ddennedy Relationship added has duplicate 0000632
2009-02-15 04:54 ddennedy Note Added: 0002428
2009-02-15 04:54 ddennedy Status assigned => resolved
2009-02-15 04:54 ddennedy Resolution open => fixed
2009-02-15 22:55 reinhard Note Added: 0002431
2009-02-15 22:55 reinhard Status resolved => feedback
2009-02-15 22:55 reinhard Resolution fixed => reopened
2009-02-15 23:21 reinhard Note Edited: 0002431
2009-02-15 23:22 reinhard File Added: crop behaviour.ogv
2009-02-16 09:45 ddennedy Note Added: 0002433
2009-02-16 10:29 ddennedy Note Added: 0002434
2009-02-17 23:20 reinhard Note Added: 0002436
2009-02-17 23:27 ddennedy Note Added: 0002437
2009-02-17 23:34 reinhard Note Added: 0002438
2009-03-13 07:37 ddennedy Note Added: 0002542
2009-03-13 07:37 ddennedy Status feedback => resolved
2009-03-13 07:37 ddennedy Fixed in Version => Recent git
2009-03-13 07:37 ddennedy Resolution reopened => fixed
2009-04-15 13:07 madsdyd Fixed in Version Recent git => 0.7.3
2009-06-18 01:51 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker