Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000566KdenliveUser Interfacepublic2009-01-04 21:572009-02-02 23:49
Reportermadsdyd 
Assigned Tomadsdyd 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSKubuntu LinuxOS Version8.04
Product VersionRecent git 
Target VersionFixed in Version0.7.2 
Summary0000566: Changing the parameters of a composite transition looses the force_track property
DescriptionIf you force the track of a composite transition to something else than auto, then change its parameters by e.g. dragging the red box, the force_track property is lost, and "a_track" goes back to default value.
Steps To Reproduce- start kdenlive
- add clip to the timeline
- add a composite transition to the clip
- set the track to something else than auto
- save to a file
- inspect the file, note the "force_track 1" on the composite transition
- change the red box
- save
- inspect the file, note the "force_track 0" on the composite transition
Additional InformationI will try to fix this, has assigned to self.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0002103)
madsdyd (administrator)
2009-01-11 21:38

I am going crazy trying to figure out what is going wrong here.

I have found out that if you save a file with a locked composite transition and reloads it, it will work as expected - perhaps it is somehow confusing the first created transition with some sort of template.

I am going nuts with this bug.
(0002104)
madsdyd (administrator)
2009-01-11 21:43

Oh, and the situation is the same for luma transitions - this is something general.
(0002215)
madsdyd (administrator)
2009-01-25 23:05

Status: Jb has applied a patch in svn rev 2901, that appears to fix the problem.

I have yet to truly test it: My compiled kdenlive crashes, but I suspect it is because I have some local changes that conflicts the 2901, so I will review this bug, when I have a clean build. Soonish.
(0002238)
madsdyd (administrator)
2009-01-27 13:30

Fix in 2901 tested - works very nice.

Thanks a lot.

- Issue History
Date Modified Username Field Change
2009-01-04 21:57 madsdyd New Issue
2009-01-04 21:57 madsdyd Status new => assigned
2009-01-04 21:57 madsdyd Assigned To => madsdyd
2009-01-04 21:57 madsdyd Build/Install Method => Build Wizard
2009-01-11 21:38 madsdyd Note Added: 0002103
2009-01-11 21:43 madsdyd Note Added: 0002104
2009-01-25 23:05 madsdyd Note Added: 0002215
2009-01-27 13:30 madsdyd Note Added: 0002238
2009-01-27 13:30 madsdyd Status assigned => resolved
2009-01-27 13:30 madsdyd Fixed in Version => Recent git
2009-01-27 13:30 madsdyd Resolution open => fixed
2009-02-02 23:42 xzhayon Fixed in Version Recent git => 0.7.2
2009-02-02 23:49 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker