Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000577KdenliveUser Interfacepublic2009-01-10 02:132010-02-20 08:17
Reporteranaximander 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformdarwin version 9.6.0 (powerpc)OSMac OsXOS Version10.5.6
Product VersionRecent git 
Target Version0.7.2Fixed in Version0.7.7 
Summary0000577: kdenlive crashes at startup after the initial assistant window (Mac OsX)
DescriptionI compiled kdenlive on Mac OsX(ppc G4) together with mandatory dependencies
qt4.4.3 (Mac version: no X11) + kde base libraries 4.1.85 (from macports) + the svn versions of ffmpeg (rev 16400) , mlt (rev 1301) and mlt++ (rev 1302), kdenlive KDE4 branch svn version rev 2865

kdenlive crashes on startup after the startup assistant window with throughing an exception 'NSInternalInconsistencyException'. command line output is appended.

I am not sure if mlt framework works correct, because inigo the command line player does not play a lot of video files, so maybe this is also a reason for the crash
Steps To Reproducestart kdenlive
TagsSOLVED
Build/Install MethodManual build from SVN
Attached Filestxt file icon kdenlive-cli-output.txt [^] (6,258 bytes) 2009-01-10 02:13 [Show Content]

- Relationships

-  Notes
(0002102)
jmpoure (developer)
2009-01-11 10:36

Tagging this bug to 0.7.2 and acknowledged.
(0002120)
ddennedy (developer)
2009-01-14 06:38

I do test MLT on OS X against the MacPorts version of ffmpeg, and it works quite well. However, all apps must #include <SDL.h> due to some SDL-Quartz integration quarks. I am not sure if a complex app like kdenlive will still have further issues with the SDL integration.
(0004454)
anaximander (reporter)
2010-01-02 18:12

I think this bug could be closed because at least starting with 0.7.6 from macports this is no longer an issue. kdenlive does start without problems on mac osx ppc

- Issue History
Date Modified Username Field Change
2009-01-10 02:13 anaximander New Issue
2009-01-10 02:13 anaximander File Added: kdenlive-cli-output.txt
2009-01-10 02:13 anaximander Build/Install Method => Manual build from SVN
2009-01-11 10:36 jmpoure Note Added: 0002102
2009-01-11 10:36 jmpoure Status new => acknowledged
2009-01-11 10:36 jmpoure Target Version => 0.7.2
2009-01-14 06:38 ddennedy Note Added: 0002120
2010-01-02 18:12 anaximander Note Added: 0004454
2010-01-02 18:19 anaximander Tag Attached: SOLVED
2010-01-04 01:27 ddennedy Status acknowledged => resolved
2010-01-04 01:27 ddennedy Fixed in Version => 0.7.6
2010-01-04 01:27 ddennedy Resolution open => fixed
2010-01-04 01:27 ddennedy Assigned To => ddennedy
2010-02-02 10:34 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker