Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000594KdenliveUser Interfacepublic2009-01-22 14:532009-07-01 21:55
Reportermhenley 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.1 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000594: Segfault upon finishing the Startup Wizard
DescriptionWhen I start kdenlive I am able to select Video Standard, Additional Settings. Once I click Finish, I immediately get a SIGSEGV. The Crash details are below. Qt: 4.4.2 , KDE: 4.1.4, MLT/MLT+: 0.3.4 . Is this a configuration issue or a real crash?
Additional InformationApplication: Kdenlive (kdenlive), signal SIGSEGV
0x00007faf38bc34cf in waitpid () from /lib64/libpthread.so.0
[Current thread is 0 (LWP 8273)]

Thread 2 (Thread 0x7faf24b75950 (LWP 8274)):
#0 0x00007faf331cc3b2 in select () from /lib64/libc.so.6
#1 0x00007faf38edc19e in ?? () from /usr/lib64/qt4/libQtCore.so.4
0000002 0x00007faf38e2aac9 in ?? () from /usr/lib64/qt4/libQtCore.so.4
0000003 0x00007faf38bbc017 in start_thread () from /lib64/libpthread.so.0
0000004 0x00007faf331d2bfd in clone () from /lib64/libc.so.6
0000005 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7faf39caa750 (LWP 8273)):
[KCrash Handler]
0000004 0x00007faf398c47b3 in mlt_properties_get_data () from /usr/lib/libmlt.so.1
0000005 0x00007faf398c78c6 in mlt_service_profile () from /usr/lib/libmlt.so.1
0000006 0x00007faf398c8cec in mlt_producer_get_fps () from /usr/lib/libmlt.so.1
0000007 0x00007faf396a9e2e in Mlt::Producer::get_fps () from /usr/lib/libmlt++.so.1
0000008 0x0000000000499e53 in Render::setSceneList ()
0000009 0x00000000004c80b0 in KdenliveDoc::KdenliveDoc ()
0000010 0x0000000000476ac5 in MainWindow::newFile ()
0000011 0x000000000047a2cc in MainWindow::MainWindow ()
0000012 0x0000000000466be1 in main ()

TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0002180)
mhenley (reporter)
2009-01-22 14:55

The system is x86_64-pc-linux-gnu and the compile options are "-O1 -pipe -mtune=core2"
(0002196)
administrator (administrator)
2009-01-25 16:05

My guess is that it might be a problem with your MLT install. Can you play a video clip through MLT's command line player:

inigo myvideo.mpg
(0002198)
mhenley (reporter)
2009-01-25 17:34

It seemed to play just fine here. Is this the correct version? I am using pulseaudio so that could the alsa error.
Here is the output of inigo:
matt@speedy ~ $ inigo --version
MLT inigo 0.3.4
Copyright (C) 2002-2008 Ushodaya Enterprises Limited
<http://www.mltframework.org/> [^]
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
matt@speedy ~ $ inigo big_buck_bunny_480p_h264.mov
ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5= 0| |6= 1| |7= 2| |8= 5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
| H = back 1 minute, L = forward 1 minute |
| h = previous frame, l = next frame |
| g = start of clip, j = next clip, k = previous clip |
| 0 = restart, q = quit, space = play |
+---------------------------------------------------------------------+
Current Position: 854
matt@speedy ~ $
(0002482)
Qrex (reporter)
2009-03-01 20:30

I'm getting crash at the same moment. Archlinux, KDE 4.2.1, kernel 2.6.28.7, MLT 0.3.6, MLT++ 0.3.6, Kdenlive 0.7.2.1 built from source. Here's backtrace from gdb:

Starting program: /usr/bin/kdenlive
[Thread debugging using libthread_db enabled]
[New Thread 0xb6039700 (LWP 27676)]
Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".
kdenlive(27676) MainWindow::parseProfiles: RESULTINGÂ MLT PATH: "/usr/share/mlt/profiles/"
Xlib: extension "Generic Event Extension" missing on display ":0.0".
kdenlive(27676) initEffects::parseEffectFiles: // INIT EFFECT SEARCH
[New Thread 0xb2d53b90 (LWP 27725)]
kdenlive(27676) Wizard::checkMltComponents: // FOUND MLT's pkgconfig version: 36
kdenlive(27676) Wizard::installExtraMimes: EXTS: ("*.mpeg", "*.vob", "*.m2t", "*.mp2", "*.mpe", "*.mpg", "*.mts", "*.mod", "*.ts")
kdenlive(27676) Wizard::installExtraMimes: INSTALLING NEW MIME TO: "/home/pablo/.local/share/mime/packages/video-mpeg.xml"
kdenlive(27676) Wizard::installExtraMimes: EXTS: ("*.dv")
kdenlive(27676) Wizard::installExtraMimes: INSTALLING NEW MIME TO: "/home/pablo/.local/share/mime/packages/video-dv.xml"
kdenlive(27676) Render::Render: ////////// USINGÂ PROFILE: hdv_1080_50i
kdenlive(27676) Monitor::Monitor: /////// BUILDING MONITOR, ID: 65012340
kdenlive(27676) Render::Render: ////////// USINGÂ PROFILE: hdv_1080_50i
kdenlive(27676) Monitor::Monitor: /////// BUILDING MONITOR, ID: 65012421
kdenlive(27676) RecMonitor::RecMonitor: /////// BUILDING MONITOR, ID: 65012447
QStatusBar::insertPermanentWidget: Index out of range (5), appending widget
QStatusBar::insertPermanentWidget: Index out of range (7), appending widget
kdenlive(27676): Shortcut for KAction "monitor_play_zone" "Play Zone" set with QShortcut::setShortcut()! See KAction documentation.
kdenlive(27676): Shortcut for KAction "monitor_loop_zone" "Loop Zone" set with QShortcut::setShortcut()! See KAction documentation.
kdenlive(27676) MainWindow::loadPlugins: // PARSING FIOLER: "/usr/lib/kde4/"
kdenlive(27676) MainWindow::loadPlugins: // FOUND PLUGIN: "libkdenlive_sampleplugin.so" = "/usr/lib/kde4/libkdenlive_sampleplugin.so"
kdenlive(27676) MainWindow::addToMenu: // ADD to MENU ("Countdown", "Noise")
kdenlive(27676) KdenliveDoc::setProfilePath: KDEnnlive document, init timecode from path: "hdv_1080_50i" , 25
kdenlive(27676) KdenliveDoc::KdenliveDoc: KDEnlive document, init timecode: 25
kdenlive(27676) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 4 , DURATION: 0
kdenlive(27676) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 3 , DURATION: 0
kdenlive(27676) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 2 , DURATION: 0
kdenlive(27676) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 1 , DURATION: 0
kdenlive(27676) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 0 , DURATION: 0
kdenlive(27676) TrackView::parseDocument: /////////// TOTAL PROJECT DURATION: 300
kdenlive(27676) Render::setSceneList: // NEW SCENE LIST DURATION SET TO: 0
[New Thread 0xb1bb4b90 (LWP 27798)]
[New Thread 0xb13b3b90 (LWP 27799)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb6039700 (LWP 27676)]
0xb805335d in mlt_properties_get_data () from /usr/lib/libmlt.so.1

(gdb) thread apply all bt

Thread 4 (Thread 0xb13b3b90 (LWP 27799)):
#0 0xb6b05a48 in clone () from /lib/libc.so.6
#1 0x003d0f00 in ?? ()
0000002 0x00000000 in ?? ()

Thread 3 (Thread 0xb1bb4b90 (LWP 27798)):
#0 0xb8069424 in __kernel_vsyscall ()
#1 0xb73f9f82 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0xb805dfd6 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000003 0x00000001 in ?? ()
0000004 0x00000000 in ?? ()

Thread 2 (Thread 0xb2d53b90 (LWP 27725)):
#0 0xb8069424 in __kernel_vsyscall ()
#1 0xb6afeab1 in select () from /lib/libc.so.6
0000002 0xb7541bf7 in ?? () from /usr/lib/libQtCore.so.4
0000003 0x00000009 in ?? ()
0000004 0xb7483910 in ?? () from /usr/lib/libQtCore.so.4
0000005 0x09d73360 in ?? ()
0000006 0x00000000 in ?? ()

Thread 1 (Thread 0xb6039700 (LWP 27676)):
#0 0xb805335d in mlt_properties_get_data () from /usr/lib/libmlt.so.1
#1 0x00000005 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)'
(gdb) continue
Continuing.
KCrash: Application 'kdenlive' crashing...
sock_file=/home/pablo/.kde4/socket-Nivakonnen/kdeinit4__0
kdenlive: Fatal IO error: client killed
[Thread 0xb2d53b90 (LWP 27725) exited]

Program exited with code 01.

Hope this helps. Should I paste or send someone valgrind output also?
(0002484)
administrator (administrator)
2009-03-02 10:03
edited on: 2009-03-03 09:11

Your backtrace doesn't say anything... and I don't think the 2 crashes are the same issue.

To mhenley: I really recommend using KDE 4.2.x. The 4.1.x release was really unstable.

Try removing the kdenlive config file:
$HOME/.kde/share/config/kdenliverc

Also, please try playing a video file with inigo (MLT's command line player):

inigo myclip.mpg

Does it play fine?

(0002499)
Qrex (reporter)
2009-03-04 20:49

Inigo plays movies fine, but I don't have kdenliverc file in any of my directories...
(0003414)
Granjow (developer)
2009-06-23 23:35

Any changes since 0.7.4? Still crashing?
(0003424)
mhenley (reporter)
2009-06-24 00:51

Am offshore Brasil at the moment so I can't check the current version, but it was working for simple files when I last tried. It has gotten past this problem for me.
(0003427)
xzhayon (developer)
2009-06-24 00:59

then this has been fixed

- Issue History
Date Modified Username Field Change
2009-01-22 14:53 mhenley New Issue
2009-01-22 14:53 mhenley Build/Install Method => Build Wizard
2009-01-22 14:55 mhenley Note Added: 0002180
2009-01-25 16:05 administrator Note Added: 0002196
2009-01-25 17:34 mhenley Note Added: 0002198
2009-03-01 20:30 Qrex Note Added: 0002482
2009-03-02 10:03 administrator Note Added: 0002484
2009-03-03 09:11 administrator Note Edited: 0002484
2009-03-03 09:11 administrator Status new => feedback
2009-03-04 20:49 Qrex Note Added: 0002499
2009-06-23 23:35 Granjow Note Added: 0003414
2009-06-24 00:51 mhenley Note Added: 0003424
2009-06-24 00:59 xzhayon Note Added: 0003427
2009-06-24 00:59 xzhayon Status feedback => resolved
2009-06-24 00:59 xzhayon Fixed in Version => Recent git
2009-06-24 00:59 xzhayon Resolution open => fixed
2009-06-24 00:59 xzhayon Assigned To => xzhayon
2009-06-24 00:59 xzhayon Assigned To xzhayon =>
2009-06-24 00:59 xzhayon Target Version => future version
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:55 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker