Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000596KdenliveUser Interfacepublic2009-01-23 09:132009-07-01 21:55
ReporterGranjow 
Assigned ToGranjow 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000596: Allow to enter unicode characters
DescriptionEspecially for the Text Clip text tool a feature to enter Unicode would be very useful.

GTK (afaik -> Firefox and Co.) handles it that way: Shift-Ctrl-U enters the Unicode mode, then pressing [0-9a-f] builds the Unicode number. Example: Shift-Ctrl-U 2026 will display _u2026_ (underlined). Any other key closes the Unicode mode and _u2026_ will be replaced by the character (here the ellipsis, …).
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003238)
Granjow (developer)
2009-06-16 21:25

I've added Unicode insert support in r3552.

Please test if you feel like and tell me if there is something I can improve.
(0003286)
xzhayon (developer)
2009-06-18 10:46

as far as i can tell, works fine for me!
(0003288)
Granjow (developer)
2009-06-18 11:22

Great :)
Did you see the additional information about characters? I bet there is a better solution for that. Adding everything in a .cpp file sucks. What could I use to keep it translatable?
(0003289)
xzhayon (developer)
2009-06-18 11:47

no i didn't, i thought it was automatically read by decodeunicode.org (better not, even if possible, because kdenlive is not meant to work on the net)
well, the only other way i know to add translatable strings is to add them in the ui, and then show/hide them as needed. i don't know which is the better option

other improvements:
- the dialog is too big, i would reduce it both in width and height
- would be nice to hide or fill with a replacement text, the two lines containing the char, when no char is selected
- when no description is available, a replacement text (something like "No description available") would be nice, just to fill that empty space
- do qt libs have some way to return the character name (something like the titles of the chars pages on decodeunicode.org)? it would be useful to know what i'm inserting
- in the future, what about a list of characters? ok, ok, there are thousands of them. then why not a list of, say, 11 characters: the one i selected and the five before/after it?

they're all suggestions ;)
(0003292)
Granjow (developer)
2009-06-18 17:46

Show/hide would be uncool. How should I know which labels exist and which ones don't, and if I forget to hide one … So I'll stay this way for the moment.

* Height reduced. Width not :P And I won't.
* Hide vertical bars is not possible. Instead I'm displaying an info text below.
* Replacement text: Also there now.
* Qt libs don't provide much information. But I just found something.
<http://unicode.org/Public/UNIDATA/NamesList.txt>. [^] Terms of use are here: <http://www.unicode.org/copyright.html>. [^] Will go through it later.
* List of characters? No. Not in the future :)

Thanks for your suggestions!

* I've additionally added buttons for the prev/next character; Arrow keys (up/down) can control them too.

r3575
(0003301)
xzhayon (developer)
2009-06-19 02:22

nice work!

about the list:
- it's displaying 4 chars on the left and 8 on the right of the selected char. is this a wanted behaviour (this is not a critique, i just want you to be aware of that)?
- when clearing the text field by selecting the text and pressing <DEL>, the list isn't reset
(0003307)
Granjow (developer)
2009-06-19 08:50

Thanks :)

* 4|1|8: Yes, this is wanted. I thought of changing it on the fly when scrolling downwards so that you have 5|1|7 until 8|1|4. At the moment it is especially for scrolling upwards through the characters.
* argh.
(0003309)
Granjow (developer)
2009-06-19 09:21

r3588: List is being reset
(0003343)
Granjow (developer)
2009-06-20 13:50

r3603: Remembering last unicode (only if you clicked OK in the title widget!)
(0003345)
xzhayon (developer)
2009-06-20 15:16

then you can save and read it in the unicode dialog, just do as title widget does (save when ok is clicked)
(0003348)
Granjow (developer)
2009-06-20 16:34

r3605
(0003349)
Granjow (developer)
2009-06-20 17:11

r3606: Arrows changed. Arrow down now selects the next unicode. Seems to be more intuitive for me.
(0003350)
xzhayon (developer)
2009-06-20 17:12
edited on: 2009-06-20 17:13

yes, it's ok now!

fixed in rev. 3606


- Issue History
Date Modified Username Field Change
2009-01-23 09:13 Granjow New Issue
2009-01-23 09:13 Granjow Build/Install Method => Manual build from SVN
2009-06-16 15:42 Granjow Status new => assigned
2009-06-16 15:42 Granjow Assigned To => Granjow
2009-06-16 21:25 Granjow Note Added: 0003238
2009-06-16 21:25 Granjow Status assigned => feedback
2009-06-18 10:46 xzhayon Note Added: 0003286
2009-06-18 11:22 Granjow Note Added: 0003288
2009-06-18 11:47 xzhayon Note Added: 0003289
2009-06-18 17:46 Granjow Note Added: 0003292
2009-06-19 02:13 xzhayon Target Version => future version
2009-06-19 02:22 xzhayon Note Added: 0003301
2009-06-19 08:50 Granjow Note Added: 0003307
2009-06-19 09:21 Granjow Note Added: 0003309
2009-06-20 13:50 Granjow Note Added: 0003343
2009-06-20 15:16 xzhayon Note Added: 0003345
2009-06-20 16:34 Granjow Note Added: 0003348
2009-06-20 17:11 Granjow Note Added: 0003349
2009-06-20 17:12 xzhayon Note Added: 0003350
2009-06-20 17:12 xzhayon Status feedback => resolved
2009-06-20 17:12 xzhayon Fixed in Version => Recent git
2009-06-20 17:12 xzhayon Resolution open => fixed
2009-06-20 17:13 xzhayon Note Edited: 0003350
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:55 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker