Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000615KdenliveMLTpublic2009-01-25 22:492009-02-02 23:49
Reportermadsdyd 
Assigned Tomadsdyd 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.7.2 
Summary0000615: Add plugin framework to produce clips using westley files
DescriptionThis is a post-fact bug about the fact that jb has added (the first version of?) a plugin framework that allows to write plugins for kdenlive, that can produce clips (generators?)

AFAICT it works by generating .westley files, which are then loaded into the project. The plugin framework seems to be based on Qt's plugin framework (so, it is much lighter than e.g. kparts, make no mistake). Plugins are written in C++, and it is my guess that everything that can be created in a .westley file can be added through the plugin/generators.

TagsNo tags attached.
Build/Install MethodNot Applicable
Attached Files

- Relationships

-  Notes
(0002214)
madsdyd (administrator)
2009-01-25 22:52

In case it is not clear, this bug was made to keep track of the plugin addition to kdenlive.

As of svn rev 2880, two generators are now present: a (non-working?) countdown generator and a (working) noise generator.
(0002278)
ddennedy (developer)
2009-01-28 22:17

The countdown worked for me.

- Issue History
Date Modified Username Field Change
2009-01-25 22:49 madsdyd New Issue
2009-01-25 22:49 madsdyd Build/Install Method => Not Applicable
2009-01-25 22:52 madsdyd Note Added: 0002214
2009-01-25 22:52 madsdyd Status new => resolved
2009-01-25 22:52 madsdyd Fixed in Version => Recent git
2009-01-25 22:52 madsdyd Resolution open => fixed
2009-01-25 22:52 madsdyd Assigned To => madsdyd
2009-01-28 22:17 ddennedy Note Added: 0002278
2009-02-02 23:42 xzhayon Fixed in Version Recent git => 0.7.2
2009-02-02 23:49 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker