Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000618KdenliveRenderingpublic2009-01-26 14:462011-11-01 18:56
Reportersolv 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Versionfuture versionFixed in Version0.8.2 
Summary0000618: When rendering one clip does not become visible until 5 seonds after clip starts
DescriptionIn a project I have an imported ogv clip cut up into different segments. The first clip starts in the timeline about 15 seconds after a few other stills. The preview works fine most of the time, however sometimes it does not show up until late as well.
Note that the transition from this clip to the next causes a black screen as well - but subsequent clips render/transition perfectly.
I have tried the following:
1) Moved it to a different track (this caused a crash until I removed the end transition
2) Changed between straight cut and transition
3) Changed transition from between color clip and video clip, to no clip on the timeline and cut to movie clip
4) Rendered in almost every different codec and format/ratio

Each time it renders the same way - audio begins but have black screen then a few seconds later the video appears.
Additional InformationThis has happened on the stable version as well and in a different project with a different clip in the same format (.ogv)

TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships
has duplicate 0001083closedddennedy total crash fedora11 on trying to render .ogv file made by py-recordmydesktop 
related to 0001551acknowledged Audio desynchronizes when "Crop From Start" is used 
related to 0001831closedddennedy speeding up video with the speed effect damages the picture quality 

-  Notes
(0002219)
ddennedy (developer)
2009-01-27 08:01
edited on: 2010-05-04 17:23

Ogg Theora has seeking issues in FFmpeg libs. This is a known issue with a bug in their roundup tracker. Your best bet is to transcode it to something else by placing the entire clip on a track by itself and rendering it to something like lossless huffyuv AVI.

(0002226)
solv (reporter)
2009-01-27 10:23

Okay will do thankyou for the tip =)
(0002275)
ddennedy (developer)
2009-01-28 20:30

I need to consider adding an Ogg Theora producer to be used instead of ffmpeg because this is a fairly common format now for Free Software users. Not to mention, the screen capture capability outputs to Ogg Theora :-/
(0003027)
makdaknife (reporter)
2009-06-02 12:49

I would definitely add my vote to this... as screencasting is becoming so popular and recordmydesktop only outputs to theora. :-(
(0003164)
nowardev (reporter)
2009-06-11 14:24

guys...
i have made a little script

it's arecordmydesktop. to convert automatically to avi

it's here

http://www.cli-apps.org/content/show.php/arecordmydesktop?content=102911 [^]
(0003169)
ddennedy (developer)
2009-06-11 19:35

Kdenlive 0.7.4 has a new, configurable transcode feature accessible from the Project Tree, but we still need a producer with better support for Ogg Theora to avoid this step.
(0004148)
ddennedy (developer)
2009-10-13 07:07

As a workaround for now, we have added to the 0.7.6 release of Kdenlive 2 new Transcode presets that can help: Fix Ogg Theora and Lossless Matroska. I have had some problems wtih ffmpeg keeping a/v sync sometimes when using "Fix Ogg Theora" but give it a try first because Lossless Matroska creates big files.
(0006146)
ddennedy (developer)
2010-12-07 08:44

Fixed in FFmpeg r25846 on Nov 29.

- Issue History
Date Modified Username Field Change
2009-01-26 14:46 solv New Issue
2009-01-26 14:46 solv Build/Install Method => Manual build from SVN
2009-01-27 08:01 ddennedy Note Added: 0002219
2009-01-27 10:23 solv Note Added: 0002226
2009-01-28 20:28 ddennedy Status new => assigned
2009-01-28 20:28 ddennedy Assigned To => ddennedy
2009-01-28 20:30 ddennedy Note Added: 0002275
2009-06-02 12:49 makdaknife Note Added: 0003027
2009-06-11 14:24 nowardev Note Added: 0003164
2009-06-11 19:35 ddennedy Note Added: 0003169
2009-06-19 09:39 xzhayon Target Version => future version
2009-10-13 07:06 ddennedy Relationship added has duplicate 0001083
2009-10-13 07:07 ddennedy Note Added: 0004148
2010-05-04 17:23 ddennedy Note Edited: 0002219 View Revisions
2010-05-04 17:24 ddennedy Relationship added related to 0001551
2010-11-12 06:07 ddennedy Relationship added related to 0001831
2010-12-07 08:44 ddennedy Note Added: 0006146
2010-12-07 08:44 ddennedy Status assigned => resolved
2010-12-07 08:44 ddennedy Resolution open => fixed
2011-07-05 12:15 j-b-m Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker