Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000655KdenliveUser Interfacepublic2009-02-03 09:282009-06-18 01:51
Reportereurodrew555 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.3 
Summary0000655: deleting video track causes kdenlive to crash
DescriptionI have an existing project which I am using to experiment with kdenlive.

I have added a number of video tracks to the project giving me tracks 0 to 11 visible in the timeline.

Tracks 0 to 7 are empty.
Tracks 8 and 9 are video tracks and have a number of clips/
Tracks 10 and 11 are audio tracks but are empty.

When I load the project and try to delete tracks 0 to 7 kdenlive crashes.
I can however delete tracks 8-11.
Additional InformationI am running Fedora 10 x86_64 with an ATI 4870 X2 video card.

Kdenlive was installed by Kdenlive Builder Wizard 0.7.1
Information about revisions of modules at the time of compilation:
ffmpeg: Revision: 16967 Last Changed Date: 2009-02-03 03:01:17 +0000 (Tue, 03 Feb 2009)
mlt: Revision: 1338 Last Changed Date: 2009-02-02 23:41:24 +0000 (Mon, 02 Feb 2009)
mlt++: Revision: 1338 Last Changed Date: 2009-01-26 18:32:03 +0000 (Mon, 26 Jan 2009)
kdenlive: Revision: 3030 Last Changed Date: 2009-02-03 02:33:47 +0000 (Tue, 03 Feb 2009)
uname -a at time of compilation:
Linux quadcore 2.6.27.9-159.fc10.x86_64 #1 SMP Tue Dec 16 14:47:52 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon kbw.gdb.output.yEyY2huK [^] (236,095 bytes) 2009-02-03 09:28
? file icon Testing kdenlive 3.kdenlive [^] (35,474 bytes) 2009-02-03 09:28

- Relationships

-  Notes
(0002340)
eurodrew555 (reporter)
2009-02-03 09:33

Just to add - If I create a new project I can't actually reproduce this crash.
I am able to add/delete any number of video tracks without kdenlive crashing.

There appears to be something specific to this project which is causing the crash.
(0002350)
administrator (administrator)
2009-02-04 11:00

Looks like you have some invalid clips in your project:

<producer in="0" out="200" id="3_8" >
<property name="resource" >/media/media/Images Video Rally Driving/Rally - 205 Challenge Best Videos/twyford2008-quick-section001.avi</property>
<property name="markup" >INVALID</property>
(...)

I am wondering what is the problem with that clip? Does it still exist? Maybe it's just the project file that is corrupted.

I just committed a fix to svn (revision 3033) so that it won't crash on track deletion anymore, but that clip will probably trigger other bugs, let me know.

regards
(0002534)
eurodrew555 (reporter)
2009-03-11 22:40

Just to let you know I've tried to reproduce this error with the latest version of kdenlive (Revision 3139).

As I cannot reproduce the error I would suggest that this issue is closed as fixed.

Many thanks,
Andrew

- Issue History
Date Modified Username Field Change
2009-02-03 09:28 eurodrew555 New Issue
2009-02-03 09:28 eurodrew555 File Added: kbw.gdb.output.yEyY2huK
2009-02-03 09:28 eurodrew555 Build/Install Method => Build Wizard
2009-02-03 09:28 eurodrew555 File Added: Testing kdenlive 3.kdenlive
2009-02-03 09:33 eurodrew555 Note Added: 0002340
2009-02-04 11:00 administrator Note Added: 0002350
2009-03-11 22:40 eurodrew555 Note Added: 0002534
2009-03-13 16:43 administrator Status new => resolved
2009-03-13 16:43 administrator Resolution open => fixed
2009-03-13 16:43 administrator Fixed in Version => Recent git
2009-03-13 16:43 administrator Additional Information Updated
2009-04-15 13:07 madsdyd Fixed in Version Recent git => 0.7.3
2009-06-18 01:51 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker