Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000688KdenliveUser Interfacepublic2009-02-22 19:552010-09-14 23:26
Reportereurodrew555 
Assigned ToGranjow 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.7.1 
Summary0000688: Kdenlive crashes every time when selecting clip
DescriptionI can replicate this crash every time by:

start kdenlive (it prompts for auto-recovery)
select "Don't recover" to start a fresh project

add a clip (.mov) to the project.
go to the clip monitor and select play.
pause, then select an in point.
play
pause, and then select an out point.

drag clip to timeline and release mouse button
now when I click on the clip in the timeline kdenlive crashes.

Basically kdenlive is extremely unstable and unusable on my Fedora 10 x86_64 configuration.

I updated kdenlive to the latest version using the Kdenlive Builder Wizard - the last time I updated was about 10 days ago.
Additional InformationKdenlive was installed by Kdenlive Builder Wizard 0.7.1
Information about revisions of modules at the time of compilation:

ffmpeg: Revision: 17530 Last Changed Date: 2009-02-22 14:39:06 +0000 (Sun, 22 Feb 2009)
mlt: Revision: 1367 Last Changed Date: 2009-02-20 23:45:54 +0000 (Fri, 20 Feb 2009)
mlt++: Revision: 1367 Last Changed Date: 2009-02-04 15:49:35 +0000 (Wed, 04 Feb 2009)
kdenlive: Revision: 3068 Last Changed Date: 2009-02-21 02:11:42 +0000 (Sat, 21 Feb 2009)
uname -a at time of compilation:
Linux quadcore 2.6.27.15-170.2.24.fc10.x86_64 #1 SMP Wed Feb 11 23:14:31 EST 2009 x86_64 x86_64 x86_64 GNU/Linux
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon kbw.gdb.output.28PdeXBV [^] (23,881 bytes) 2009-02-22 19:55

- Relationships

-  Notes
(0002446)
eurodrew555 (reporter)
2009-02-22 20:08

After further testing I have found kdenlive crashes after clicking anywhere within the timeline - I do not have to actually select the clip for the program to crash.
(0002447)
eurodrew555 (reporter)
2009-02-22 20:15

To try to isolate this further I have tried rolling back to my last known stable revision, but I can't roll back ffmpeg, the kdenlive builder wizard fails on building ffmpeg with:

make: *** No rule to make target `libavutil/pixfmt.h', needed by `libswscale/swscale.o'. Stop.

I have tried to roll back to the revisions I was using in the bug report I logged recently (0000655)
(0002448)
eurodrew555 (reporter)
2009-02-22 23:09
edited on: 2009-02-22 23:10

I've installed kdenlive 0.7-1.fc10 using the tigro repository and the exact same problem is occurring.

Perhaps the underlying issue is due to updated packages on Fedora?
Before I upgrading kdenlive I did a full system upgrade using yum (kernel and all packages).

Hope that helps. I'm very interested to see what anyone thinks of the gdb output as I'd really like to get kdenlive stable under Fedora 10.

(0002449)
December (reporter)
2009-02-23 03:28

Is it possibly the same bug as this: http://www.kdenlive.org/mantis/view.php?id=684 [^]

When you click on the timeline, your preview monitor switches to Projecto view, so it could well just be that.
(0004960)
Granjow (developer)
2010-04-10 13:20

Please re-test with the current version of kdenlive. Still reproducible?
(0005060)
eurodrew555 (reporter)
2010-04-23 09:53

I have upgraded kdenlive on Fedora 12 x86_64 to the following:

Kdenlive Builder Wizard version: 0.9.90
frei0r: commit 1c3c63b424d6cfdfa1d681559efbd5e54e1b91a3 Date: Wed Mar 31 01:41:34 2010 +0200
ffmpeg: Revision: 22950 Last Changed Date: 2010-04-23 05:43:36 +0800 (Fri, 23 Apr 2010)
mlt: commit 327be4e680a7e3edfaee17fbaaa257f7485d29de Date: Mon Apr 19 21:32:40 2010 -0700
kdenlive: Revision: 4394 Last Changed Date: 2010-04-22 03:41:45 +0800 (Thu, 22 Apr 2010)
Qt: 4.6.2
KDE Development Platform: 4.4.2 (KDE 4.4.2)
Kdenlive: 0.7.8 (rev. 4394)

I had to make the following change to 85826-kdenlive_builder_wizard.kmdr for it to correctly see my KDE4 version:

1610c1610
< KDE_VER=`kde4-config -v | grep -i "KDE Development Platform:" | awk '{print $4}'`
---
> KDE_VER=`kde4-config -v | grep -i KDE: | awk '{print $2}'`

I have tested against a DVD that I have that I believe has a damaged VOB file and I can get kdenlive to crash every time whenever I scrub the clip.

If I use a video file that I believe is OK though I cannot reproduce this issue.

The issue with the damaged VOB file is really separate to this issue as this previously happened with any video.

This issue therefore now looks to be resolved.

- Issue History
Date Modified Username Field Change
2009-02-22 19:55 eurodrew555 New Issue
2009-02-22 19:55 eurodrew555 File Added: kbw.gdb.output.28PdeXBV
2009-02-22 19:55 eurodrew555 Build/Install Method => Build Wizard
2009-02-22 20:08 eurodrew555 Note Added: 0002446
2009-02-22 20:15 eurodrew555 Note Added: 0002447
2009-02-22 23:09 eurodrew555 Note Added: 0002448
2009-02-22 23:10 eurodrew555 Note Edited: 0002448
2009-02-23 03:28 December Note Added: 0002449
2010-04-10 13:20 Granjow Note Added: 0004960
2010-04-10 13:20 Granjow Assigned To => Granjow
2010-04-10 13:20 Granjow Status new => feedback
2010-04-10 13:33 Granjow Tag Attached: old
2010-04-23 09:53 eurodrew555 Note Added: 0005060
2010-04-23 09:53 eurodrew555 Status feedback => assigned
2010-04-23 11:27 j-b-m Status assigned => resolved
2010-04-23 11:27 j-b-m Fixed in Version => 0.7.7.1
2010-04-23 11:27 j-b-m Resolution open => fixed
2010-05-28 18:16 Granjow Tag Detached: old
2010-09-14 23:26 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker