Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000693KdenliveUser Interfacepublic2009-02-25 12:562011-06-10 10:48
Reportereurodrew555 
Assigned Tottill 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0000693: kdenlive startup should have some sort of notification to user that it is loading project
DescriptionI have a project with about 50 images and 50 video files.
These are simply sequentially laid across the timeline.

When I start kdenlive it appears to be hanging, but if I look at system monitor the disk is extremely busy.

After a few minutes the project does start up, so my feature request would be to:

- first load the user interface, so the user knows the program has started
- show a dialog box "Loading project", again to inform the user

It then doesn't really matter how long it takes to load, the end user knows the app is working on it.
Additional InformationUsing latest version from Build Wizard.
Compiled on Fedora x86_64.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships
parent of 0001529closedttill Projekt load time 
related to 0000997closedttill kdenlive really slow to open a big project 

-  Notes
(0002540)
eurodrew555 (reporter)
2009-03-13 00:01

I noticed if kdenlive is already started it does show the progress as it's loading up the new project.

I believe the GUI should therefore load up and display first, and then the project should start loading with the the % progress displaying on the status bar.

This would at least show the user that kdenlive is making progress on loading.

At the moment the only way I can tell a huge project (1 hour long) is loading is that I can see the CPU usage and disk activity in the system monitor, so I know it's working on it. This gives no indication as to how long it will take....
(0005606)
LeHomard (developer)
2010-08-12 22:38

I don't think Kdenlive actually show the progress of the loading, only of the thumbnail creation if needed. Also even with dozens of video and audio clip, lots of transitions and effects, it only takes a few seconds to load (when thumbnails are generated).

Opening last project is an option, chich I think is disabled by default, so it won't happen without the user knowing...

I'd say this report should be closed. Any advice against ?
(0005650)
mcfrisk (reporter)
2010-08-19 23:13

I agree: kdenlive should show some status to user that it is loading the project.

My project takes 16 minutes from kdenlive start to a responsive UI. After that the thumbnail loading shows the status bar. The project has 909 files:

$ egrep -o 'resource=".*"' project.kdenlive | awk '{print $1}'| sort| uniq | wc -l
909
(0005945)
ttill (developer)
2010-10-02 20:38

Now (svn r4963) a progress bar will show up while loading the clips because this part takes longest. Additionally in r4964 I sped up the clip loading.
Please test and tell me if the progress dialog is sufficient and how big the speed gain is.
(0005950)
eurodrew555 (reporter)
2010-10-05 04:12

I have built svn r4964 and tested - the progress bar goes from 0% to 100% very quickly in a few seconds, however the clips haven't actually loaded yet. The UI hangs while the clips load in about 60 seconds.

The clips seem to load faster than before (I would estimate maybe 2x or 3x faster).

So it appears the progress bar isn't actually in sync with the loading of the clips? it seems to finish before they even start loading.
(0005959)
ttill (developer)
2010-10-10 12:25

The progress dialog should now be visible all the time in svn r4977.
(0005961)
eurodrew555 (reporter)
2010-10-11 02:23

I have built svn r4979 and the progress notification works well - many thanks ttill.

On my biggest project:

283 clips 3.8 GiB.
Unused clips 6 24.8 MiB
Thumbnails cache 451 6.6MiB
Project files 289

Loading of the project hangs on 50% for quite some time before rapidly going up to 100%.

The dialog that was previously in the middle of the screen has disappeared and clips are visible however the UI cannot be used - in the bottom left info shows "Loading clips" which hangs at 99% for quite some time.

As an idea perhaps it would be useful to show additional info of what file is being loaded underneath the % indicator - this would show exactly what file the project load is hanging on.
(0006047)
ttill (developer)
2010-11-13 00:47
edited on: 2010-11-13 00:48

At 50% (in the dialog) the timline elements are loaded and the project is loaded by MLT. By default all clips in a MLT composition (the timeline) are checked for validity (by MLT + ffmpeg) which takes some time. I just (svn r5091) introduced a option to disable this checks. It is disabled by default (enable through configure kdenlive dialog) for now because I have to do some further tests.
Please give the latest svn revision a try (with this option enabled).
I will now (soon) have a look at the last part of the project loading and see what I can do ;)

(0006671)
ttill (developer)
2011-04-27 23:22

I guess we can close this one.
Of course speed can always be pushed a little more but the speed increase between 0.7.8 and 0.8 was quit nice and now some other things are more important ;)

- Issue History
Date Modified Username Field Change
2009-02-25 12:56 eurodrew555 New Issue
2009-02-25 12:56 eurodrew555 Build/Install Method => Build Wizard
2009-03-13 00:01 eurodrew555 Note Added: 0002540
2010-08-12 22:38 LeHomard Note Added: 0005606
2010-08-12 22:38 LeHomard Assigned To => LeHomard
2010-08-12 22:38 LeHomard Status new => feedback
2010-08-19 23:13 mcfrisk Note Added: 0005650
2010-09-12 15:39 ttill Assigned To LeHomard => ttill
2010-09-12 15:39 ttill Status feedback => assigned
2010-09-12 15:39 ttill Target Version => future version
2010-09-12 15:39 ttill Additional Information Updated View Revisions
2010-10-02 20:38 ttill Note Added: 0005945
2010-10-02 20:39 ttill Status assigned => feedback
2010-10-05 04:12 eurodrew555 Note Added: 0005950
2010-10-05 04:12 eurodrew555 Status feedback => assigned
2010-10-10 12:25 ttill Note Added: 0005959
2010-10-11 02:23 eurodrew555 Note Added: 0005961
2010-11-13 00:47 ttill Note Added: 0006047
2010-11-13 00:48 ttill Note Edited: 0006047 View Revisions
2010-11-13 00:48 ttill Status assigned => feedback
2010-11-13 00:51 ttill Relationship added parent of 0001529
2010-11-14 22:14 ttill Relationship added related to 0000997
2011-04-27 23:22 ttill Note Added: 0006671
2011-04-27 23:22 ttill Status feedback => resolved
2011-04-27 23:22 ttill Resolution open => fixed
2011-04-27 23:22 ttill Fixed in Version => 0.8
2011-06-10 10:48 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker