Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000729KdenliveMLTpublic2009-03-21 15:412009-06-18 01:51
Reportersubik 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.3 
Summary0000729: composite of image over video triggers crash
DescriptionI'd like to highlight some stuff in my video so I tried to create a "title" clip with bordered rect only (all backgrounds are transparent).

Then I add thos title-clip into video track. The "composite" fx is loaded automatically.

The crash appears just when I move the position mark into title clip area.

kdenlive from SVN
mlt stuff from opensuse 11.0 packman repository 0.3.6
Qt: 4.4.3
KDE: 4.2.1 (KDE 4.2.1) "release 104"

BTW is there any workaround how to do a highlight like this (see attached file), please?
Additional Information...

kdenlive(12218) CustomTrackView::resetSelectionGroup: DESTROY SEL GRP, ITEMS: 1
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: aligned : 1
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: deinterlace : 0
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: distort : 0
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: fill : 0
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: geometry : 0%,0%:100%x100%:100
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: luma :
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: luma_invert : 0
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: operator : over
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: progressive : 0
kdenlive(12218) Render::mltAddTransition: ------ ADDING TRANS PARAM: softness : 0
kdenlive(12218) Render::stop: ///////////// RENDER STOPPED: "clip"
[Thread 0xb0fd4b90 (LWP 12242) exited]
[Thread 0xb07d3b90 (LWP 12243) exited]
kdenlive(12218) Render::stop: ///////////// RENDER STOP2-------
kdenlive(12218) Render::stop: ///////////// RENDER STOP3-------
kdenlive(12218) Render::start: ----- STARTING MONITOR: "project"
kdenlive(12218) Render::start: ----- MONITOR: "project" WAS STOPPED
[New Thread 0xb07d3b90 (LWP 12244)]
[New Thread 0xb0fd4b90 (LWP 12245)]
kdenlive(12218) Render::start: ----- MONITOR: "project" REFRESH

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb07d3b90 (LWP 12244)]
0xb25f06c5 in transition_get_image (a_frame=0x9e99818, image=0xb07d3384, format=0xb07d3390, width=0xb07d3388, height=0xb07d338c, writable=0)
    at transition_composite.c:601
601 transition_composite.c: No such file or directory.
        in transition_composite.c
Current language: auto; currently c
(gdb) bt
#0 0xb25f06c5 in transition_get_image (a_frame=0x9e99818, image=0xb07d3384, format=0xb07d3390, width=0xb07d3388, height=0xb07d338c, writable=0)
    at transition_composite.c:601
#1 0xb805e884 in mlt_frame_get_image (this=0x9e99818, buffer=0xb07d3384, format=0xb07d3390, width=0xb07d3388, height=0xb07d338c, writable=0)
    at mlt_frame.c:261
0000002 0xb80704ae in producer_get_image (this=0xafe22fc8, buffer=0xb07d3384, format=0xb07d3390, width=0xb07d3388, height=0xb07d338c, writable=0)
    at mlt_tractor.c:274
0000003 0xb805e884 in mlt_frame_get_image (this=0xafe22fc8, buffer=0xb07d3384, format=0xb07d3390, width=0xb07d3388, height=0xb07d338c, writable=0)
    at mlt_frame.c:261
0000004 0xb4590795 in filter_get_image (this=0xafe22fc8, image=0xb07d3384, format=0xb07d3390, width=0xb07d3388, height=0xb07d338c, writable=0)
    at filter_avcolour_space.c:99
0000005 0xb805e884 in mlt_frame_get_image (this=0xafe22fc8, buffer=0xb07d3384, format=0xb07d3390, width=0xb07d3388, height=0xb07d338c, writable=0)
    at mlt_frame.c:261
0000006 0xb476f6e4 in consumer_thread (arg=0x8cde408) at consumer_sdl_still.c:455
0000007 0xb7380175 in start_thread () from /lib/libpthread.so.0
0000008 0xb6901dae in clone () from /lib/libc.so.6
(gdb)
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filespng file icon highlight_mask.png [^] (1,913 bytes) 2009-03-21 15:41

- Relationships

-  Notes
(0002616)
subik (reporter)
2009-03-30 19:33

It looks like the crash is gone using the latest mlt from svn. Sorry for false alert.

- Issue History
Date Modified Username Field Change
2009-03-21 15:41 subik New Issue
2009-03-21 15:41 subik File Added: highlight_mask.png
2009-03-21 15:41 subik Build/Install Method => Manual build from SVN
2009-03-30 19:33 subik Note Added: 0002616
2009-04-06 08:45 administrator Status new => resolved
2009-04-06 08:45 administrator Resolution open => fixed
2009-04-06 08:45 administrator Fixed in Version => Recent git
2009-04-15 13:07 madsdyd Fixed in Version Recent git => 0.7.3
2009-06-18 01:51 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker