Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000749KdenliveFile Loadingpublic2009-04-05 11:062009-07-01 21:55
ReporterGranjow 
Assigned Toxzhayon 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000749: Automatically make title clips to use font-pixel-size in saved projects
Description… so that we don't have to double-click every single text clip and pres OK to change font-size to font-pixel-size (afaik that is necessary atm, isn't it?).

I suggest to do that during startup, a menu point would only make kdenlive more complicated. Certainly the user has to be asked whether he really wants to change it because he might just be on a PC with wrong («non-original») DPI settings which would mess up everything.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filespng file icon clips-dpi-monitor.png [^] (31,950 bytes) 2009-06-19 13:50


png file icon clips-dpi-window2.png [^] (54,119 bytes) 2009-06-19 13:50


png file icon clips-dpi-overview.png [^] (186,042 bytes) 2009-06-19 13:51


png file icon clips-dpi-window.png [^] (53,142 bytes) 2009-06-19 13:51

- Relationships
related to 0000732closedGranjow Font size of text clip changes on different PCs 

-  Notes
(0003196)
xzhayon (developer)
2009-06-15 00:08

it would be great if you could point me to the commit regarding issue 732
(0003200)
xzhayon (developer)
2009-06-15 00:54

ok, found, assigning to myself
(0003233)
xzhayon (developer)
2009-06-16 12:52

this is fixed in revision 3551. please, test

i'm not forcing the recreation of the preview file (used in the producer) because:
- if there is a preview file, it should be ok, because it was saved under the user's eyes
- since this problem happens when moving projects on different computer, images used in the title could be absent

so, this modification does something only when the preview file isn't there (because it's automatically recreated on the new xml data)
(0003317)
Granjow (developer)
2009-06-19 13:57

Some impressions after loading an old project on my laptop.
Disregarded of the fact that it is fubar (yes, really. Everything has moved around and so on.) something seems to be wrong. Will test on PC later and upload some other screenshots. Perhaps it looks wrong too there.

* I'm not being notified that font-pixel-size will be used from now on. My laptop is the machine it looks wrong on. I think kdenlive should ask me which dpi settings to use to convert to pixel-size, or at least warn me that I should open this project on the original machine first.
(0003319)
xzhayon (developer)
2009-06-19 15:01

is it correct to say that to convert a point size to a pixel size i need to know the dpi of the screen? i don't know so much about this. that would be a problem, and then i could only warn the user
(0003322)
Granjow (developer)
2009-06-19 15:35

Yes.
(0003323)
Granjow (developer)
2009-06-19 15:36

Warning would be best anyway I guess. Which user knows his dpi settings.
(0003342)
xzhayon (developer)
2009-06-20 12:57

fixed in rev. 3601

user is asked if he wants to convert when loading a project, and only warned (he will get deformed text both with points and pixels) when a title clip is opened in the title widget (as well as a .kdenlivetitle is loaded)

- Issue History
Date Modified Username Field Change
2009-04-05 11:06 Granjow New Issue
2009-04-05 11:06 Granjow Build/Install Method => Manual build from SVN
2009-04-05 11:06 Granjow Relationship added related to 0000732
2009-06-15 00:08 xzhayon Note Added: 0003196
2009-06-15 00:08 xzhayon Status new => feedback
2009-06-15 00:54 xzhayon Note Added: 0003200
2009-06-15 00:54 xzhayon Assigned To => xzhayon
2009-06-15 00:54 xzhayon Status feedback => acknowledged
2009-06-15 00:57 xzhayon Status acknowledged => assigned
2009-06-16 12:52 xzhayon Note Added: 0003233
2009-06-16 12:52 xzhayon Status assigned => feedback
2009-06-19 02:37 xzhayon Target Version => future version
2009-06-19 13:50 Granjow File Added: clips-dpi-monitor.png
2009-06-19 13:50 Granjow File Added: clips-dpi-window2.png
2009-06-19 13:51 Granjow File Added: clips-dpi-overview.png
2009-06-19 13:51 Granjow File Added: clips-dpi-window.png
2009-06-19 13:57 Granjow Note Added: 0003317
2009-06-19 15:01 xzhayon Note Added: 0003319
2009-06-19 15:35 Granjow Note Added: 0003322
2009-06-19 15:36 Granjow Note Added: 0003323
2009-06-20 12:57 xzhayon Note Added: 0003342
2009-06-26 01:51 xzhayon Status feedback => resolved
2009-06-26 01:51 xzhayon Fixed in Version => Recent git
2009-06-26 01:51 xzhayon Resolution open => fixed
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:55 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker