Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000759KdenliveBuild Systempublic2009-04-10 09:282009-06-18 01:51
Reportergrof 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.3 
Summary0000759: Rpaths errors in Fedora package
DescriptionI was getting RPaths problem in this four files when building Kdenlive on Fedora:

kdenlive.i386: E: binary-or-shlib-defines-rpath /usr/bin/kdenlive_render ['/usr/lib', '/usr/lib/kde4/devel']
kdenlive.i386: E: binary-or-shlib-defines-rpath /usr/bin/kdenlive ['/usr/lib', '/usr/lib/kde4/devel']
kdenlive.i386: E: binary-or-shlib-defines-rpath /usr/lib/kde4/libkdenlive_sampleplugin.so ['/usr/lib', '/usr/lib/kde4/devel']
kdenlive.i386: E: binary-or-shlib-defines-rpath /usr/lib/kde4/westleypreview.so ['/usr/lib', '/usr/lib/kde4/devel']


With adding
set(CMAKE_SKIP_RPATH true)
in CMakeLists.txt the problem is solved

I attached patch file...

TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filespatch file icon kdenlive-0.7.2.1-rpath.patch [^] (427 bytes) 2009-04-10 09:28 [Show Content]

- Relationships

-  Notes
(0002694)
administrator (administrator)
2009-04-10 10:50

I have absolutely no idea if this rpath option should be set to true in all cases...

You should be able to disable rpath when calling cmake at compile time. I think that doing:

cmake (...) -DCMAKE_SKIP_RPATH=true

should solve the issue without patching the CMakeList file...
Does this look an acceptable workaround?
(0002695)
grof (reporter)
2009-04-10 11:12

Yes! This is the best solution.

I just tried, and it works!

You can close this bug as solved :)

bye
Zarko

- Issue History
Date Modified Username Field Change
2009-04-10 09:28 grof New Issue
2009-04-10 09:28 grof File Added: kdenlive-0.7.2.1-rpath.patch
2009-04-10 09:28 grof Build/Install Method => Distribution package
2009-04-10 10:50 administrator Note Added: 0002694
2009-04-10 10:50 administrator Status new => feedback
2009-04-10 11:12 grof Note Added: 0002695
2009-04-10 11:19 administrator Status feedback => resolved
2009-04-10 11:19 administrator Resolution open => fixed
2009-04-10 11:19 administrator Fixed in Version => Recent git
2009-04-15 13:07 madsdyd Fixed in Version Recent git => 0.7.3
2009-06-18 01:51 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker