Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000785KdenliveUser Interfacepublic2009-04-23 10:082011-11-01 18:56
Reporterrwst 
Assigned Toxzhayon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.3 
Target VersionFixed in Version0.8.2 
Summary0000785: guides not accessible from right click in time bar
DescriptionI can add guides to the timeline by right-clicking in the time bar but I can't edit or delete them this way: I always get the popup menu with the four items Add/Edit/Delete/DAll but Edit and Delete always shows the "No guide at cursor time" message, regardless of where the click is done (also not if clicked directly on the guide). I can workaround the delete by shoving the guide off the left side, of course.
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Files

- Relationships
duplicate of 0001947acknowledged Inconsistent behaviour of clip unselection 
related to 0001945new Add «Show markers comments» to the timeline ruler's context menu 
related to 0001946acknowledged Multiple selection in the timeline should ignore guide lines 

-  Notes
(0002769)
administrator (administrator)
2009-04-27 18:53

To edit / delete a guide, the timeline cursor must be placed at the exact guide position. You can move the cursor using ALT + LEFT / RIGHT ARROW to go to that position, then right click in the ruler...
(0002775)
rwst (reporter)
2009-04-28 19:36

No, doesn't work with SVN. With Right-Click, a line is added to the
"Undo history" named "Edit guide" but nothing else happens. However,
with Doubleclick, a box named "Edit guide" opens, but I can't delete
the guide using that box.
(0002778)
administrator (administrator)
2009-04-28 23:43

Still works fine for me. Maybe you are doing something that corrupts the guides state... Can you try the following:

When starting from a blank project:
right click in the timeline ruler -> Add Guide.
You get a dialog asking for guide position and guide comment (comments are displayed if enabled in Kdenlive Settings->Display->Display clip markers comments).

Click ok to add the guide. Then right click again in timeline ruler -> Delete Guide, and the guide is deleted.

Does it work?
(0002779)
eurodrew555 (reporter)
2009-04-28 23:57

I've just been looking at a similar issue (see 0000801) relating to markers/guides.

I was trying to right click on the clip and/or guide in the timeline, but I didn't realise for guides you have to snap to the guide and then right click on the timeline ruler, not within the timeline itself (clips, or white space).

I suppose I get it now, but my natural feel was to right click somewhere near the guide itself, I thought if I was right clicking over the guide but in white space on the timeline I would get an option to edit the guide itself.
(0002783)
rwst (reporter)
2009-04-29 11:26

Ah ok, the cursor must be in that position? Please please be not so stupid and think this is sufficient for a good GUI. First, for that to work, the cursor must snap more than it does now: I need several tries every time I try it. Secondly, this is not what users expect, in two ways: they expect object-oriented behaviour and in most kdenlive cases they get it, so why not here? Right-Click on it should show the possible (or impossible) actions on it. But what do I get with right-click? In the timeline, no hint. In the ruler, Delete is always there, even if it does nothing. So, my position is clear, this is a twofold UI-related bug: right-click near the guide in the timeline should give the menuitem Delete Guide, and not near a guide a disabled menuitem. Likewise, in the ruler. As a minimal implementation, narrowing it to the ruler would be sufficient. In the edit box, a button Delete should be added, too.
(0002785)
eurodrew555 (reporter)
2009-04-29 14:23

I would have to agree, why do we need to restrict this action to the timeline ruler?

It would seem more natural to add the guide options to the right click menu within the timeline. So you right click over a clip and for example you get add marker, but also add guide. This would be intuitive and fast.

It would also seem logical to be able to right click very close to a guide and get the option to delete guide, etc. I know this might be problem with several guides close together though?
(0002789)
administrator (administrator)
2009-05-01 16:25

I improved a bit the handling of guides:
* you can edit / delete a guide by right-clicking close to it in an empty zone of timeline.
* Edit / delete actions in ruler context menu now affect the guide close to the mouse click and are enabled / disabled when they should.

Is that ok for you?
(0002802)
rwst (reporter)
2009-05-03 18:22

I can't say anymore, as I'm now using a Mac. Sorry. But maybe the other ones, eurodrew555?
(0002808)
eurodrew555 (reporter)
2009-05-04 16:01
edited on: 2009-05-04 16:02

When I enable "Show marker comments" the name of the guide appears in the time line.
I can right click very close to the guide and I get the edit/delete guide right click options.
However if I right click over the guide comment I don't get any options.

The right click edit/delete options should also be enabled anywhere over or near the comment.

(0002826)
xzhayon (developer)
2009-05-08 17:17

i don't have any problem with guides, and the new solution by jb works well
(0002845)
xzhayon (developer)
2009-05-11 17:21

oh sorry, i didn't read very well your note... i've just fixed a pair or problems with guides, now i'll try to work on clickable comments
(0002847)
xzhayon (developer)
2009-05-12 02:39

feature added in rev. 3376. please, test
(0002849)
eurodrew555 (reporter)
2009-05-12 09:48

The clickable comments are great, thanks for adding this.

The only problem I can see is if a guide is over a clip, when you right click the guide comment it actually selects the clip instead, even though the guide comment is selected (it's changed to red).

If the guide is selected then I think it makes sense that the right click options should work on the guide and not the clip.
(0002850)
xzhayon (developer)
2009-05-12 12:01

yes, i think you're right (and this is not making harder to access context menus in thin clips): added in rev. 3377

here's the logic for guides clicks (please, comment):
- if there's a guide right under the mouse ignore any other item
   - LEFT CLICK: unselect the other items (i don't like this), start moving the guide and STOP
   - RIGHT CLICK: do not unselect the other items (the same behaviour as ruler right click), pop up the context menu and STOP
- if you clicked on an empty area (no clips nor transitions) look for guides close to the mouse
   - RIGHT CLICK: if there's one, do not unselect the other items, pop up its context menu and STOP

i've done all the tests i can think of and couldn't find any new problems...
(0002861)
eurodrew555 (reporter)
2009-05-12 21:07

LEFT CLICK:

I noticed unselect doesn't allow you to undo and go back to your previous selection (which could be complex, multiple tracks, etc).

Wouldn't it be natural to have undo go back to the previous selection, rather than the previous action (such as moving a clip), as the selection itself could be quite important, and have taken quite a while to set up.

I think the LEFT CLICK behaviour could be ok as long as there was undo history to restore the selection.

RIGHT CLICK:

Works great! Very easy to use across a project with a lot of guides... nice

RIGHT CLICK (empty area):

Seems very natural, looks good.

Thanks for implementing these changes so quickly.
(0002862)
xzhayon (developer)
2009-05-12 23:57

mh, i don't believe it would be a good idea to make selections (when selected clips > N, anyway) (un|re)doable, they could throw away from the stack more destructive (is this the right word?) actions like cuts and movements

anyway, i'd like to fix the unselect issue when leftclicking on a guide
(0006210)
Granjow (developer)
2010-12-26 10:06

Resolving; Created new reports for still existing bugs.

- Issue History
Date Modified Username Field Change
2009-04-23 10:08 rwst New Issue
2009-04-23 10:08 rwst Build/Install Method => Other Method?
2009-04-27 18:53 administrator Note Added: 0002769
2009-04-28 19:36 rwst Note Added: 0002775
2009-04-28 23:43 administrator Note Added: 0002778
2009-04-28 23:43 administrator Status new => feedback
2009-04-28 23:57 eurodrew555 Note Added: 0002779
2009-04-29 11:26 rwst Note Added: 0002783
2009-04-29 13:06 administrator Status feedback => acknowledged
2009-04-29 14:23 eurodrew555 Note Added: 0002785
2009-05-01 16:25 administrator Note Added: 0002789
2009-05-03 18:22 rwst Note Added: 0002802
2009-05-04 16:01 eurodrew555 Note Added: 0002808
2009-05-04 16:01 eurodrew555 Note Edited: 0002808
2009-05-04 16:01 eurodrew555 Note Edited: 0002808
2009-05-04 16:02 eurodrew555 Note Edited: 0002808
2009-05-08 17:17 xzhayon Note Added: 0002826
2009-05-11 17:21 xzhayon Note Added: 0002845
2009-05-12 02:39 xzhayon Note Added: 0002847
2009-05-12 02:39 xzhayon Status acknowledged => feedback
2009-05-12 09:48 eurodrew555 Note Added: 0002849
2009-05-12 12:01 xzhayon Note Added: 0002850
2009-05-12 12:01 xzhayon Note Added: 0002851
2009-05-12 12:01 xzhayon Note Deleted: 0002851
2009-05-12 21:07 eurodrew555 Note Added: 0002861
2009-05-12 23:57 xzhayon Note Added: 0002862
2010-12-26 09:56 Granjow Relationship added related to 0001945
2010-12-26 10:03 Granjow Relationship added related to 0001946
2010-12-26 10:05 Granjow Relationship added duplicate of 0001947
2010-12-26 10:06 Granjow Note Added: 0006210
2010-12-26 10:06 Granjow Status feedback => resolved
2010-12-26 10:06 Granjow Fixed in Version => 0.7.4
2010-12-26 10:06 Granjow Resolution open => fixed
2010-12-26 10:06 Granjow Assigned To => xzhayon
2011-07-05 12:15 j-b-m Fixed in Version 0.7.4 => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker