Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000808KdenliveRenderingpublic2009-05-03 11:062009-05-30 12:01
Reportermichelinux 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.3 
Target VersionFixed in Version0.7.4 
Summary0000808: Bitrate parameter is ignored when exporting to H.264
DescriptionTrying to export a project to H.264 always create the same file, indipendently on what bitrate you choose.

Steps to reproduce the bug.

1. Create a project (a simple one is OK)
2. Press the Export button and choose H.264
3. Choose a bitrate (e.g. 200k), name the export file (e.g "bug_0200k") and press Render to file
4. Choose a different bitrate (e.g. 2000k), name the export file (e.g. "bug_2000k) and press Render to file
5. Choose one more different bitrate (e.g. 8000k), name the export file (e.g. "bug_8000k) and press Render to file
6. Open a terminal in the folder you saved the previous three files.
7. From the terminal run "md5sum *mp4", and see if the three files have same checksum.

Additional InformationThe software used to reproduce the bug are:

Kdenlive 0.7.3 (binary version from Ubuntu 9.04)
ffmpeg 0.5 SVN-r18508 (you can find a binary package for Ubuntu at https://launchpad.net/~michelinux/+archive/ppa [^]

This bug occurs with any kind of video size, resolution and length. It also occurs when using libmp3lame instead of libfaac as audio codec.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0002796)
Granjow (developer)
2009-05-03 11:18

Tested with 200k and 25000k.

-rw-r--r-- 1 simon simon 470782 3. Mai 11:14 high.mp4
0e23d76e846b8b9887e5528e92e38376 high.mp4
-rw-r--r-- 1 simon simon 470782 3. Mai 11:14 low.mp4
1600b5c250794c46f8bae7fc86bc6836 low.mp4


With 2 pass testing wasn't possible because rendering crashed.
[libx264 @ 0x908f930]no ratecontrol method specified
(0002895)
Granjow (developer)
2009-05-23 19:56

Is this an ffmpeg bug? When I do
ffmpeg -i something.m2ts -b 200 out.mpg
I receive the same file as with
ffmpeg -i something.m2ts -b 20000 out.mpg
(0002937)
ddennedy (developer)
2009-05-27 08:13

'-b 200' is too low for ffmpeg. This is measure in bits/sec, not kb/s. If you want kb/s, then append a 'k' to the number. More than likely, ffmpeg is ignoring the bitrate and using a hardcoded minimum. Of course, I am not commenting on the bug directly, but just the last comment.
(0002971)
Granjow (developer)
2009-05-29 19:35

Ah, indeed. Thanks for the enlightment. Now I know why the quality wasn't too good :)
(0002983)
ddennedy (developer)
2009-05-30 02:38

In addition, the 2 pass options would fail with "no ratecontrol method specified"
(0002985)
ddennedy (developer)
2009-05-30 03:26

Fixed in SVN r3454

- Issue History
Date Modified Username Field Change
2009-05-03 11:06 michelinux New Issue
2009-05-03 11:06 michelinux Build/Install Method => Distribution package
2009-05-03 11:18 Granjow Note Added: 0002796
2009-05-03 11:18 Granjow Status new => acknowledged
2009-05-23 19:56 Granjow Note Added: 0002895
2009-05-27 08:13 ddennedy Note Added: 0002937
2009-05-27 08:13 ddennedy Status acknowledged => assigned
2009-05-27 08:13 ddennedy Assigned To => ddennedy
2009-05-29 19:35 Granjow Note Added: 0002971
2009-05-30 02:38 ddennedy Note Added: 0002983
2009-05-30 03:26 ddennedy Note Added: 0002985
2009-05-30 03:26 ddennedy Status assigned => resolved
2009-05-30 03:26 ddennedy Resolution open => fixed
2009-05-30 09:03 ddennedy Product Version 0.7.3 => Recent git
2009-05-30 09:05 ddennedy Product Version Recent git => 0.7.3
2009-05-30 09:05 ddennedy Fixed in Version => Recent git
2009-05-30 11:54 administrator Fixed in Version Recent git => 0.7.4
2009-05-30 12:01 administrator Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker