Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000831KdenliveUser Interfacepublic2009-05-16 02:432010-09-14 23:29
Reportergsking1 
Assigned ToLeHomard 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.3 
Target VersionFixed in Version0.7.7.1 
Summary0000831: crash when copied the cached data to a new folder.
DescriptionSteps taken to crash:
-Start Kdenlive.
-Import DV video files
-Edit Project Settings, change project folder, change profile, click OK
-Prompted with question about copying the cached data to the new folder. Click Yes.
-then it crashed.

Also note that after I restarted and went through the same procedure the file "File Already Exists" dialogs were endless and indicate that most if not all of the copying took place. At this point I chose to kill kdenlive and delete the stuff that had already copied. Then on next run of kdenlive did the same method above and had no crash.
Additional InformationThis backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

[Thread debugging using libthread_db enabled]
[New Thread 0xb5df3700 (LWP 9825)]
[New Thread 0xae95fb90 (LWP 10871)]
[New Thread 0xae15eb90 (LWP 10870)]
[New Thread 0xad02cb90 (LWP 9842)]
0xb805d430 in __kernel_vsyscall ()
[Current thread is 0 (LWP 9825)]

Thread 4 (Thread 0xad02cb90 (LWP 9842)):
#0 0xb805d430 in __kernel_vsyscall ()
#1 0xb67197b1 in select () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb73fc380 in ?? () from /usr/lib/libQtCore.so.4
0000003 0xb732a96e in ?? () from /usr/lib/libQtCore.so.4
0000004 0xb66254ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb672149e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xae15eb90 (LWP 10870)):
#0 0xb805d430 in __kernel_vsyscall ()
#1 0xb67197b1 in select () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb5fe7ca7 in ?? () from /usr/lib/libxcb.so.1
0000003 0xb5fe9a12 in xcb_wait_for_reply () from /usr/lib/libxcb.so.1
0000004 0xb6426cae in _XReply () from /usr/lib/libX11.so.6
0000005 0xb641a507 in XSync () from /usr/lib/libX11.so.6
0000006 0xb43616c5 in ?? ()
0000007 0xb4366a36 in ?? ()
0000008 0xb435386a in ?? ()
0000009 0xb4456f6a in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xae95fb90 (LWP 10871)):
#0 0xb805d430 in __kernel_vsyscall ()
#1 0xb66dc7a6 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb66dc5be in sleep () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb7e718b2 in ?? () from /usr/lib/libkdeui.so.5
0000004 0xb7e72274 in KCrash::defaultCrashHandler () from /usr/lib/libkdeui.so.5
0000005 <signal handler called>
0000006 0xb8046c2d in mlt_properties_fetch (this=<value optimized out>, name=0xb4458c81 <Address 0xb4458c81 out of bounds>) at mlt_properties.c:363
0000007 0xb804894f in mlt_properties_set_int (this=0xa78632f8, name=0xb4458c81 <Address 0xb4458c81 out of bounds>, value=0) at mlt_properties.c:738
0000008 0xb4456419 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb5df3700 (LWP 9825)):
#0 0xb805d430 in __kernel_vsyscall ()
#1 0xb66290e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb67302ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb732b9b2 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
0000004 0xb732ab13 in QThread::wait () from /usr/lib/libQtCore.so.4
0000005 0xb73ff2fe in ?? () from /usr/lib/libQtCore.so.4
0000006 0xb73ff81a in ?? () from /usr/lib/libQtCore.so.4
0000007 0xb666bbb9 in exit () from /lib/tls/i686/cmov/libc.so.6
0000008 0xb6a8a21b in ?? () from /usr/lib/libQtGui.so.4
0000009 0xb7e012fa in KApplication::xioErrhandler () from /usr/lib/libkdeui.so.5
0000010 0xb7e01336 in ?? () from /usr/lib/libkdeui.so.5
0000011 0xb43699d7 in ?? ()
0000012 0xb641ef22 in _XIOError () from /usr/lib/libX11.so.6
0000013 0xb6426743 in ?? () from /usr/lib/libX11.so.6
0000014 0xb6426ccd in _XReply () from /usr/lib/libX11.so.6
0000015 0xb6403f83 in XGetWindowProperty () from /usr/lib/libX11.so.6
0000016 0xb7f56da2 in NETWinInfo::update () from /usr/lib/libkdeui.so.5
0000017 0xb7f5ec05 in NETWinInfo::NETWinInfo () from /usr/lib/libkdeui.so.5
0000018 0xb7f50fe3 in KWindowInfo::KWindowInfo () from /usr/lib/libkdeui.so.5
0000019 0xb7f4c6f7 in KWindowSystem::windowInfo () from /usr/lib/libkdeui.so.5
0000020 0xb7ee3397 in KMainWindow::saveWindowSize () from /usr/lib/libkdeui.so.5
0000021 0xb7ee4634 in KMainWindow::saveMainWindowSettings () from /usr/lib/libkdeui.so.5
0000022 0xb7ee46af in KMainWindow::saveAutoSaveSettings () from /usr/lib/libkdeui.so.5
0000023 0xb7ee4733 in ?? () from /usr/lib/libkdeui.so.5
0000024 0xb7ee47cc in KMainWindow::setSettingsDirty () from /usr/lib/libkdeui.so.5
0000025 0xb7ee5963 in KMainWindow::qt_metacall () from /usr/lib/libkdeui.so.5
0000026 0xb7f28f7a in KXmlGuiWindow::qt_metacall () from /usr/lib/libkdeui.so.5
0000027 0x080d2d92 in MainWindow::qt_metacall (this=0x9f8ab08, _c=QMetaObject::InvokeMetaMethod, _id=35, _a=0xbfa779bc)
    at /home/gsking/programs/src/kdenlive-0.7.3/build/src/cmake_bindir/mainwindow.moc:248
0000028 0xb7434ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000029 0xb7435932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000030 0xb6e3dd59 in QDockWidget::visibilityChanged () from /usr/lib/libQtGui.so.4
0000031 0xb6e4b649 in ?? () from /usr/lib/libQtGui.so.4
0000032 0xb6e7543a in ?? () from /usr/lib/libQtGui.so.4
0000033 0xb70df76d in ?? () from /usr/lib/libQtGui.so.4
0000034 0xb7434ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000035 0xb7435932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000036 0xb6ec9c53 in QTabBar::currentChanged () from /usr/lib/libQtGui.so.4
0000037 0xb6ed0e25 in QTabBar::setCurrentIndex () from /usr/lib/libQtGui.so.4
0000038 0xb6e443ea in ?? () from /usr/lib/libQtGui.so.4
0000039 0xb6e75294 in ?? () from /usr/lib/libQtGui.so.4
0000040 0xb6e41420 in QDockWidget::event () from /usr/lib/libQtGui.so.4
0000041 0xb6a25e9c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
0000042 0xb6a2e282 in QApplication::notify () from /usr/lib/libQtGui.so.4
0000043 0xb7e0194d in KApplication::notify () from /usr/lib/libkdeui.so.5
0000044 0xb741ea3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
0000045 0xb6a79e9d in QWidget::raise () from /usr/lib/libQtGui.so.4
0000046 0x080d35de in MainWindow::qt_metacall (this=0x9f8ab08, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfa780d0)
    at /home/gsking/programs/src/kdenlive-0.7.3/build/src/cmake_bindir/mainwindow.moc:276
0000047 0xb7434ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000048 0xb7435932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000049 0x08161d8b in MonitorManager::raiseClipMonitor (this=0xa084c70, _t1=true) at /home/gsking/programs/src/kdenlive-0.7.3/build/src/cmake_bindir/monitormanager.moc:120
0000050 0x081623cf in MonitorManager::switchMonitors (this=0xa084c70) at /home/gsking/programs/src/kdenlive-0.7.3/src/monitormanager.cpp:74
0000051 0x080ee377 in Monitor::slotSetXml (this=0xa2dd500, clip=0xa9b5538, position=-1) at /home/gsking/programs/src/kdenlive-0.7.3/src/monitor.cpp:672
0000052 0x080f602e in Monitor::qt_metacall (this=0xa2dd500, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xbfa78250) at /home/gsking/programs/src/kdenlive-0.7.3/build/src/cmake_bindir/monitor.moc:244
0000053 0xb7434ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000054 0xb7435932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000055 0x080d82e5 in ProjectList::clipSelected (this=0x9fc2c78, _t1=0xa9b5538) at /home/gsking/programs/src/kdenlive-0.7.3/build/src/cmake_bindir/projectlist.moc:197
0000056 0x080dbcd7 in ProjectList::slotClipSelected (this=0x9fc2c78) at /home/gsking/programs/src/kdenlive-0.7.3/src/projectlist.cpp:227
0000057 0x080e5e65 in ProjectList::qt_metacall (this=0x9fc2c78, _c=QMetaObject::InvokeMetaMethod, _id=29, _a=0xbfa78388)
    at /home/gsking/programs/src/kdenlive-0.7.3/build/src/cmake_bindir/projectlist.moc:174
#58 0xb7434ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000059 0xb7435932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000060 0xb7015c37 in QTreeWidget::itemSelectionChanged () from /usr/lib/libQtGui.so.4
0000061 0xb7018cc7 in ?? () from /usr/lib/libQtGui.so.4
0000062 0xb70233b1 in QTreeWidget::qt_metacall () from /usr/lib/libQtGui.so.4
0000063 0x081425bf in ProjectListView::qt_metacall (this=0xa080118, _c=QMetaObject::InvokeMetaMethod, _id=121, _a=0xbfa78558)
    at /home/gsking/programs/src/kdenlive-0.7.3/build/src/cmake_bindir/projectlistview.moc:74
0000064 0xb7434ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000065 0xb7435932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000066 0xb6ff2419 in QItemSelectionModel::selectionChanged () from /usr/lib/libQtGui.so.4
0000067 0xb6ffabd0 in QItemSelectionModel::emitSelectionChanged () from /usr/lib/libQtGui.so.4
0000068 0xb6ffaed6 in QItemSelectionModel::select () from /usr/lib/libQtGui.so.4
0000069 0xb6fe01a6 in ?? () from /usr/lib/libQtGui.so.4
0000070 0xb6fe0d16 in QTreeView::setSelection () from /usr/lib/libQtGui.so.4
0000071 0xb6fa433d in QAbstractItemView::mousePressEvent () from /usr/lib/libQtGui.so.4
0000072 0xb6fe885f in QTreeView::mousePressEvent () from /usr/lib/libQtGui.so.4
0000073 0xb6a7cc46 in QWidget::event () from /usr/lib/libQtGui.so.4
0000074 0xb6e56993 in QFrame::event () from /usr/lib/libQtGui.so.4
0000075 0xb6ef694f in QAbstractScrollArea::viewportEvent () from /usr/lib/libQtGui.so.4
0000076 0xb6fa8647 in QAbstractItemView::viewportEvent () from /usr/lib/libQtGui.so.4
0000077 0xb6fe30c4 in QTreeView::viewportEvent () from /usr/lib/libQtGui.so.4
0000078 0xb6ef8f55 in ?? () from /usr/lib/libQtGui.so.4
0000079 0xb741dc5a in QCoreApplicationPrivate::sendThroughObjectEventFilters () from /usr/lib/libQtCore.so.4
0000080 0xb6a25e7a in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
0000081 0xb6a2eb11 in QApplication::notify () from /usr/lib/libQtGui.so.4
0000082 0xb7e0194d in KApplication::notify () from /usr/lib/libkdeui.so.5
0000083 0xb741ea3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
0000084 0xb6a2db7e in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
0000085 0xb6a9d97e in ?? () from /usr/lib/libQtGui.so.4
0000086 0xb6a9cca7 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
0000087 0xb6ac7c6a in ?? () from /usr/lib/libQtGui.so.4
0000088 0xb6163b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000089 0xb61670eb in ?? () from /usr/lib/libglib-2.0.so.0
0000090 0xb6167268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000091 0xb744a438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
0000092 0xb6ac7365 in ?? () from /usr/lib/libQtGui.so.4
0000093 0xb741d06a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
0000094 0xb741d4aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
0000095 0xb741f959 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
0000096 0xb6a25d17 in QApplication::exec () from /usr/lib/libQtGui.so.4
0000097 0x080acf15 in main (argc=1, argv=0xbfa79da4) at /home/gsking/programs/src/kdenlive-0.7.3/src/main.cpp:84
#0 0xb805d430 in __kernel_vsyscall ()
TagsNo tags attached.
Build/Install MethodManual build from release
Attached Files

- Relationships

-  Notes
(0004992)
LeHomard (developer)
2010-04-10 21:53

Is the issue still present with version 0.7.7 or latest svn ? If the issue isn't confirmed I'll go ahead and close the bug report.
(0005021)
gsking1 (reporter)
2010-04-11 21:46

Just tried one example and it did not crash. So i guess since it must have fixed itself. Consider resolved from my end.

- Issue History
Date Modified Username Field Change
2009-05-16 02:43 gsking1 New Issue
2009-05-16 02:43 gsking1 Build/Install Method => Manual build from release
2010-04-10 21:53 LeHomard Note Added: 0004992
2010-04-10 21:53 LeHomard Assigned To => LeHomard
2010-04-10 21:53 LeHomard Status new => feedback
2010-04-11 21:46 gsking1 Note Added: 0005021
2010-04-11 21:46 gsking1 Status feedback => assigned
2010-04-11 23:22 j-b-m Status assigned => resolved
2010-04-11 23:22 j-b-m Fixed in Version => 0.7.7.1
2010-04-11 23:22 j-b-m Resolution open => fixed
2010-09-14 23:29 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker