Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000838KdenliveUser Interfacepublic2009-05-22 03:182010-09-25 22:29
Reportergsking1 
Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.3 
Target VersionFixed in Version0.7.8 
Summary0000838: Sometimes cannot move a clip.
DescriptionI sometimes get an error where I cannot move a clip. For example, I have several clips on a timeline and try to click and move it to a different time. It goes back to where it was and the status bar says something about cannot move clip...

Console output:
kdenlive(30292) EffectStackEdit::transferParamDesc: in
kdenlive(30292) Render::mltMoveClip: ////// LOOKING FOR CLIP TO MOVE, INDEX: 0
kdenlive(30292) Render::mltMoveClip: // ERROR MOVING CLIP TO : 261
kdenlive(30292) CustomTrackView::mousePressEvent: mousePressEvent STARTED
kdenlive(30292) EffectStackEdit::transferParamDesc: in
kdenlive(30292) Render::mltMoveClip: ////// LOOKING FOR CLIP TO MOVE, INDEX: 0
kdenlive(30292) Render::mltMoveClip: // ERROR MOVING CLIP TO : 0

This problem usually goes away after re-starting kdenlive.
TagsNo tags attached.
Build/Install MethodManual build from release
Attached Filesjpeg file icon errorremove.jpeg [^] (182,934 bytes) 2009-06-27 03:18


? file icon test2.kdenlive [^] (122,325 bytes) 2009-06-27 15:28

- Relationships

-  Notes
(0002909)
gsking1 (reporter)
2009-05-25 21:19

This seems more prevalent when using certain bad quality video clips. See my bug 0000840.
(0003472)
administrator (administrator)
2009-06-26 00:34

This issue should be fixed in latest svn
(0003495)
gsking1 (reporter)
2009-06-27 03:21

I was able to trigger this by quickly deleting a bunch of random clips. In this case it got stuck on the color clip. Maybe it only just affects color clips now?? Please see the screenshot I just uploaded.
Thanks for all your hard work.
(0003498)
j-b-m (administrator)
2009-06-27 09:12

I could not reproduce... if you can find a more or less reliable way to reproduce that would be great. Did you delete several clips at once (a group of clips) or just single clips one by one?
(0003507)
gsking1 (reporter)
2009-06-27 15:27

I was removing a group of clips at once. It just randomly select and delete groups and it eventually had the problem. Took about 10 tries. In this case today it could not remove the black clip at 35:36:28. Uploading project file also.
(0003600)
mcfrisk (reporter)
2009-07-04 15:54

I've been hitting this one for a while too, latest with svn 3726. Restarting kdenlive helps, but takes ages with my large project.


Before these "Cannot..." messages I usually have been going over the time line and fixing a number of small issues with syncing videos and audio. Some of the sync problems have been from kdenlive corrupting the timeline, some just my own mistakes. In the latest case, I found one empty frame between two clips and was trying to fix that, but the error came up and I couldn't, but a restart helped.
(0003603)
mcfrisk (reporter)
2009-07-05 15:07

By moving a group of clips around I managed to corrupt my timeline at around 15-20 minutes. There are no visible clips but previewing the area shows that some clips are played anyway and I can't move or delete any of the visible clips.

How to recover from corrupt timeline?

I guess manual editing of the .kdenlive file would be a start. I could even delete all the clips from the affected area and redo them, but I would hate losing the things before and after the corrupted area.
(0005607)
LeHomard (developer)
2010-08-12 22:41

I confirm this happened to me several times fairly recently. Unfortunately it seems difficult to reproduce...
(0005648)
mcfrisk (reporter)
2010-08-19 22:23

On kdenlive svn 4739, latest ffmpeg, mlt and frei0r.

I'm moving around big groups of clips on time line and quite often I get the warning bling sounds and some clips fail to move. After that the project time line is somehow corrupted. Clips have moved around so much that I can't move them back easily. For example there's no simple offset on one track. Actually the corruption occurred before those bling sounds (one of my backup projects was corrupt as well), but after I started moving those big clip groups around. Moving a single clip around doesn't seem to corrupt anything.

The clips on timeline have a few pan and zoom effects in them but no transitions. Previously in the session I have usually done one or more undos for one group move because I forgot to select a few clips.

I can't reproduce this with generated clips and a fresh project. I'm saving a lot of project files as backup to work around this, though opening the project takes over 10 minutes to the point where timeline is visible which slows down testing and kind of kills editing motivation.

I could enable some logging if you have patch or know which source files to instrument.
(0005649)
mcfrisk (reporter)
2010-08-19 22:27

One addition:

When the corruption occurs and a clip on time line fails to be moved to a different position, the time line looks ok. At this point I can't see any corruption. The corruptions are visible only by previewing the seeminly ok looking timeline or by saving and re-opening the project after which the actual time line shows the signs of curruption.
(0005651)
mcfrisk (reporter)
2010-08-20 05:02

Just noticed that after moving a group of clips, saving the project and reopening it, all moved clips with speed effect got removed from the time line. The group had two dnxhd clips with speed set to 133%.
(0005653)
mcfrisk (reporter)
2010-08-20 21:23

My problems come from the combination of group move and speed effects.

I removed or disabled all speed effects from my time line and now the same group moves succeed which previously caused mayhem on the timeline.
(0005815)
ttill (developer)
2010-09-12 14:26

@mcfrisk: I cannot reproduce using Kdenlive SVN. Can you maybe provide a sample project?
(0005851)
mcfrisk (reporter)
2010-09-16 22:19

till, I have not seen timeline corruptions after moving clips around time line
in the past two weeks. Though some transitions got lost in one case, but luckily I don't use many of them. But that may be another bug. Right now I can't share my project (300 Gb in size), I wish I could due to all the rendering problems I've had lately.
(0005852)
mcfrisk (reporter)
2010-09-17 06:52

Sorry, due to rendering problems I had not reviewed my timeline after group moves. It is totally messed up. Timeline line looks ok but clip in and out points have moved around and sync to a metronome and drum audio tracks in wav format has been lost.

I will have to redo the whole 20 minute timeline, again.
(0005915)
mcfrisk (reporter)
2010-09-25 08:02

My timeline corruptions after rendering were my own fault:

For some reason I used a bad melt command line like:

$ "/usr/bin/melt" consumer:/home/mcfrisk/video/verbier_2010/kooste_38.kdenlive profile=hdv_720_30p -consumer avformat:/home/mcfrisk/video/verbier_2010/testi38.mp4 progress=1 f=mp4 hq=1 acodec=aac ab=128k ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 b=1000k b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=@16/9 progressive=1 s=960x540

The consumer: part makes for some interesting results. Rendering from kdenlive works
and moving a group of clips works without problems in kdenlive. From my point of view, this bug is fixed.

Sorry for the false information.
(0005917)
ttill (developer)
2010-09-25 22:28

Okay,
closing.

- Issue History
Date Modified Username Field Change
2009-05-22 03:18 gsking1 New Issue
2009-05-22 03:18 gsking1 Build/Install Method => Manual build from release
2009-05-25 21:19 gsking1 Note Added: 0002909
2009-06-26 00:34 administrator Note Added: 0003472
2009-06-26 00:34 administrator Status new => feedback
2009-06-27 03:18 gsking1 File Added: errorremove.jpeg
2009-06-27 03:21 gsking1 Note Added: 0003495
2009-06-27 09:12 j-b-m Note Added: 0003498
2009-06-27 15:27 gsking1 Note Added: 0003507
2009-06-27 15:28 gsking1 File Added: test2.kdenlive
2009-07-04 15:54 mcfrisk Note Added: 0003600
2009-07-05 15:07 mcfrisk Note Added: 0003603
2010-08-12 22:41 LeHomard Note Added: 0005607
2010-08-19 22:23 mcfrisk Note Added: 0005648
2010-08-19 22:27 mcfrisk Note Added: 0005649
2010-08-20 05:02 mcfrisk Note Added: 0005651
2010-08-20 21:23 mcfrisk Note Added: 0005653
2010-09-12 14:26 ttill Note Added: 0005815
2010-09-16 22:19 mcfrisk Note Added: 0005851
2010-09-17 06:52 mcfrisk Note Added: 0005852
2010-09-25 08:02 mcfrisk Note Added: 0005915
2010-09-25 22:28 ttill Note Added: 0005917
2010-09-25 22:28 ttill Status feedback => resolved
2010-09-25 22:28 ttill Resolution open => fixed
2010-09-25 22:28 ttill Fixed in Version => 0.7.8
2010-09-25 22:29 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker