Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000849KdenliveUser Interfacepublic2009-05-23 16:062011-11-01 18:56
ReporterGranjow 
Assigned Toj-b-m 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.8 
Summary0000849: Add user defined title templates on the Add Clip menu
DescriptionI'm working on a video with sort of subtitles for explanations. Now the steps I have to take are the following:

* Create a good template
* Save the template as .kdenlivetitle
while (!all_subtitles_entered)
* Click on the Add button
* Select Add Title
* Click on the Open button
* Select the template
* Enter text as desired
done

Suggested workflow:

* Create a good template
* Add the template to the current project's template list (it will then be listed in the dropdown menu of the Add Clip button
while (!all_subtitles_entered)
* Click the Add Clip button
* Select the template created before
* Enter text
done

Especially when all_subtitles_entered is false for a long time this would save lots of clicks and time and nerves :)
Tagstitler
Build/Install MethodManual build from SVN
Attached Files

- Relationships
related to 0000603closed Duplicate a text clip 

-  Notes
(0003303)
administrator (administrator)
2009-06-19 03:03

This is now implemented in svn. To use it:

* Create title clip, put a text block with "%s" in it (will be replaced by real text).
* Save it as .kdenlivetitle file
* Add Template Title (from the add clip menu), select the previously saved template
* Double click in the "Description" filed from the project tree, enter your text, it will automatically be inserted
(0003308)
Granjow (developer)
2009-06-19 09:14

Wow, very nice! Some points:
* After entering the description the title preview isn't updated. I need to click another clip and then the previously modified one.
* Newlines and other special characters like Unicode characters ;) How do I enter them?
* Templates are not marked in the Project Content widget. A little hint would be useful. Don't have a good idea right now.

Thanks!
(0003311)
Granjow (developer)
2009-06-19 10:04

* Problem when X/Y axis inverted (right/bottom edge fixed)
(0003402)
Granjow (developer)
2009-06-23 20:16

I've just taken a look at the source. Looks like inverted x/y axis and unicode insertion wouldn't be that easy currently.

I like your method to simply use the description as replacement for %s, because it is simple and intuitive. However, perhaps it is better to use a simplified TtitleClip widget: All unnecessary toolbars hidden (background color, position and everything), but an additional bar/whatever where text can be entered. That way one would also see how it will look like with the entered text.
(0006219)
Granjow (developer)
2010-12-26 10:22

Closing.

- Issue History
Date Modified Username Field Change
2009-05-23 16:06 Granjow New Issue
2009-05-23 16:06 Granjow Build/Install Method => Manual build from SVN
2009-05-23 16:07 Granjow Relationship added related to 0000603
2009-05-27 00:28 administrator Status new => acknowledged
2009-06-03 06:04 ddennedy Severity minor => feature
2009-06-19 03:03 administrator Note Added: 0003303
2009-06-19 03:03 administrator Status acknowledged => feedback
2009-06-19 09:14 Granjow Note Added: 0003308
2009-06-19 09:36 xzhayon Target Version => future version
2009-06-19 10:04 Granjow Note Added: 0003311
2009-06-23 20:16 Granjow Note Added: 0003402
2009-06-26 21:13 administrator Target Version future version => 0.7.5
2010-12-26 10:21 Granjow Tag Attached: titler
2010-12-26 10:22 Granjow Note Added: 0006219
2010-12-26 10:22 Granjow Status feedback => new
2010-12-26 10:22 Granjow Status new => resolved
2010-12-26 10:22 Granjow Fixed in Version => 0.7.5
2010-12-26 10:22 Granjow Resolution open => fixed
2010-12-26 10:22 Granjow Assigned To => j-b-m
2011-07-05 12:15 j-b-m Fixed in Version 0.7.5 => 0.8.2
2011-07-05 12:19 j-b-m Fixed in Version 0.8.2 => 0.8
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker