Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000865KdenliveRenderingpublic2009-05-26 14:532010-09-22 17:53
ReporterDave M G 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel 32 duo coreOSUbuntu LinuxOS Version9.04
Product Version0.7.3 
Target Version0.7.6Fixed in Version0.7.6 
Summary0000865: Audio out of sync
DescriptionVery simple: Any and all attempts to render any kind of video comes out with the audio out of sync with the video. Audio is about 1 or 2 seconds faster than the video.

Also, sound quality is always poor. Slightly fuzzy, with occasional popping.
Steps To ReproduceRender any video with sound. Select any rendering profile. Use any input video.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships
duplicate of 0000852closedddennedy Problems with a/v synch. in rendered files 

-  Notes
(0002944)
Dave M G (reporter)
2009-05-27 12:42

I've created a small video for the purpose of demonstrating the problem.

It's just a video of me snapping my finger and turning on a blender, just to make noise.

The input video, an MPG, which comes directly off my Sony DCR-SR300, plays fine on my computer.

I loaded it into Kdenlive, and simply rendered it out again as an AVI file. No modifications at all.

In the output AVI, at least on my system, the sound is out of sync. At first it's okay, but after a few seconds it goes out of sync. In the latter half of the video, you can easily see that the sound is not matching the video.

It's not so easy to tell in this video that the sound quality it poor, but one problem at a time I guess.

The original MPG file is a bit large, so I wasn't able to upload it directly here. So I put it on my web site, and you can download it here:
http://autotelic.com/kdenlive_sound_sync_bug.tar.gz [^]

In the file is the original MPG, the output AVI, and the .kdenlive file used to do the rendering.

I hope that can help people diagnose the problem.
(0002948)
piotr (reporter)
2009-05-27 17:07

The same in my case at first its ok, than going worse.
(0002959)
ddennedy (developer)
2009-05-29 08:37

I received a 403 Forbidden error trying to download your video.
(0002961)
Dave M G (reporter)
2009-05-29 11:05

ddennedy,

Thank you for replying. I can not reproduce the 403 Forbidden error, but I logged in by FTP and set the file permissions to 777. Hopefully that will help. Please try downloading again. Thanks.
(0002966)
piotr (reporter)
2009-05-29 13:27
edited on: 2009-05-29 13:56

I tried can download your file, the downloading works fine.

(0002981)
ddennedy (developer)
2009-05-30 01:48

I got it. wget was giving this problem for some reason, but not Ark. Anyways, I hope you did not injure the tip of your finger in the making of this.

your XVid 1000k - bad
MPEG-2 8000k - good
MPEG-4 1000k - bad
Custom/MPEG-4 MP4 with AAC (instead of MP3) - bad
H.264 1000k -
DV NTSC - good
Flash 1000k - bad (shares code with ffmpeg mpeg4)
NTSC 4:3 VOB - good

It seems anything based on MPEG-4 part2 regardless of audio codec or container format is bad.

Next, I tried the following, whose output is fine, of course:

$ ffmpeg -i M2U00344.MPG -s 640x480 -acodec libmp3lame -ab 128k -ar 44100 -vcodec mpeg4 -minrate 0 -b 1000k -aspect 4:3 -mbd 2 -trellis 1 -flags +mv4 -deinterlace -ac 2 ffmpeg.mp4

Well, doesn't that suck?

Please test DV, MPEG-2, and/or H.264 output and confirm the same behaviour.

I am using FFmpeg v0.5.
(0002982)
ddennedy (developer)
2009-05-30 01:49

H.264 1000k should be *good* in the above.
(0002990)
Dave M G (reporter)
2009-05-30 05:53

ddennedy,

Thank you for replying.

I tested your suggestions, and I get the same results. DV, MPEG-2, and H.264 come back with the sound in sync.

Does this help diagnose the problem?
(0002992)
ddennedy (developer)
2009-05-30 06:19

Not really, it just reinforces that I now need face up to the bug and try to fix it, which I have a feeling is not going to be fun :-(
(0002994)
Dave M G (reporter)
2009-05-30 06:38

Well, if it's any consolation, I'm rooting for you. Kdenlive is on the brink of incredible awesomeness, and could be a huge factor in getting more people to use Linux. I know many people who would use Linux if there were an easy to use but still fully featured video editor, and I think Kdenlive is that editor.

Anyway, I know debugging is not fun at all, but I hope you work through it.

If there is anything at all I can do to help test or resolve this bug, please let me know.
(0003141)
ddennedy (developer)
2009-06-10 07:50

When I test mpeg4 output with a special a/v sync test clip that is in DV format, it works perfectly. Then, when I add the MPEG-2 blender video referenced in this bug after the DV clip, the sync-test shot is OK, but the blender shot is not. When I put the blender shot first, then both the blender shot and the sync-text shot are out of sync. All this only when rendering to MPEG-4 only. Tough one.
(0003433)
guiodic (reporter)
2009-06-24 13:19

I confirm but problem is greater: audio/video are not synconized in kdenlive playback too.
(0003438)
guiodic (reporter)
2009-06-24 19:19

I think the problem is in mlt.
I compiled kdenlive from source but with mlt 0.4.2 stable.
It works very well.
(0003451)
ddennedy (developer)
2009-06-24 23:50

guiodic, if you see the problem in the monitor, then your problem is different. This is not a catch-all bug report for every a/v synch problem. Please file a NEW bug, but provide the following information:
1) the output of 'ffmpeg -i thefile'
and
2) is a/v sync ok when played with ffplay?
(0003458)
guiodic (reporter)
2009-06-25 14:47

@ddennedy: excuse me, but I think this bugs are the same (in my case) because a/v sync does not work in playback and in rendered file.

p.s. ffmpeg works good.
(0003462)
ddennedy (developer)
2009-06-25 19:35

Well, then, guiodc, I must disregard your comments because this bug is specifically about this one file and MPEG-4 part output.
(0003463)
guiodic (reporter)
2009-06-25 19:41

ok, I'llopen a specific bug report, delete my posts here.
Thank you.
(0003550)
guiodic (reporter)
2009-06-30 01:39

Today I build kdenlive 3695 + ffmpeg 19299 + mlt 0.4.2 stable (because my ploblem: http://www.kdenlive.org/mantis/view.php?id=965 [^])

I rendered in mp4, xvid, flv. The issue is no more present.

Yestarday (with ffmpeg 1-day older) is was.

So, can be a ffmpeg issue?
(0003553)
ddennedy (developer)
2009-06-30 02:41

guidoc, is this something you noticed with the sample video provided in the first comment to this bug, or is this a change you noticed using your own video files?
(0003557)
guiodic (reporter)
2009-06-30 04:09
edited on: 2009-06-30 04:10

I used the sample video provided by reporter.

p.s. I reopened the other bug.

(0003558)
ddennedy (developer)
2009-06-30 04:17

Oh, wow, great, thanks! I will wait for confirmation from reporter.
(0003559)
Dave M G (reporter)
2009-06-30 06:08

Original reporter here.

Confirmation of what, exactly?
(0003560)
ddennedy (developer)
2009-06-30 06:42

That a new version of ffmpeg, at least SVN-r19299, fixes the problem you report. I see you are using distribution packages, so this is probably not an easy thing for you to test. I will eventually try to confirm it myself.
(0003573)
Dave M G (reporter)
2009-07-01 17:11

So if I understand correctly, there is a possibility that with the next update of ffmpeg is available, that the problem might be corrected?
(0003574)
ddennedy (developer)
2009-07-01 18:44

Yes, except that in the context of FFmpeg, "next update" is loosely defined. In their perspective, the next update is every commit to SVN even though some in the group are again preparing releases. Then, each distribution approaches their updating of ffmpeg differently. I have yet to confirm as I have been busy with other, very heavy MLT work.
(0003575)
Dave M G (reporter)
2009-07-01 19:31

Understood. Thank you for explaining the situation.

I guess I'll just have to wait for an update to come downstream into Ubuntu repositories and see if that helps. I'll report back here when that happens.
(0003819)
Dave M G (reporter)
2009-08-26 09:57

SOLVED

This issue appears to have been completely resolved in Kdenlive 0.7.5

Thanks to the developers for all their hard work!
(0003853)
piotr (reporter)
2009-09-02 15:58

In kdenlive 0.7.5 still the same problem remains.
(0004105)
piotr (reporter)
2009-10-10 15:24

In kdenlive 0.7.6!!
still the same problem remains.
(0004108)
ddennedy (developer)
2009-10-10 22:04

Original reporter says it is resolved. I just re-tested using the original reporter's clip, the release version of MLT 0.4.6, the MLT recommended version of FFmpeg (r19873), and Kdenlive 0.7.6, and it works perfectly.

piotr, unless you tested with the original reporter's M2U00344.MPG and at least FFmpeg r19299, then your feedback is invalid. Even so, I can not validate your process and neither I or the original poster reproduce this bug.

- Issue History
Date Modified Username Field Change
2009-05-26 14:53 Dave M G New Issue
2009-05-26 14:53 Dave M G Build/Install Method => Distribution package
2009-05-27 08:14 ddennedy Relationship added duplicate of 0000852
2009-05-27 12:42 Dave M G Note Added: 0002944
2009-05-27 17:07 piotr Note Added: 0002948
2009-05-29 08:37 ddennedy Note Added: 0002959
2009-05-29 08:37 ddennedy Status new => feedback
2009-05-29 11:05 Dave M G Note Added: 0002961
2009-05-29 13:27 piotr Note Added: 0002966
2009-05-29 13:56 piotr Note Edited: 0002966
2009-05-30 01:48 ddennedy Note Added: 0002981
2009-05-30 01:49 ddennedy Note Added: 0002982
2009-05-30 01:53 ddennedy Status feedback => assigned
2009-05-30 01:53 ddennedy Assigned To => ddennedy
2009-05-30 05:53 Dave M G Note Added: 0002990
2009-05-30 06:19 ddennedy Note Added: 0002992
2009-05-30 06:38 Dave M G Note Added: 0002994
2009-06-10 07:50 ddennedy Note Added: 0003141
2009-06-19 09:53 xzhayon Target Version => future version
2009-06-24 13:19 guiodic Note Added: 0003433
2009-06-24 19:19 guiodic Note Added: 0003438
2009-06-24 23:50 ddennedy Note Added: 0003451
2009-06-25 14:47 guiodic Note Added: 0003458
2009-06-25 19:35 ddennedy Note Added: 0003462
2009-06-25 19:41 guiodic Note Added: 0003463
2009-06-30 01:39 guiodic Note Added: 0003550
2009-06-30 02:41 ddennedy Note Added: 0003553
2009-06-30 04:09 guiodic Note Added: 0003557
2009-06-30 04:10 guiodic Note Edited: 0003557 View Revisions
2009-06-30 04:17 ddennedy Note Added: 0003558
2009-06-30 06:08 Dave M G Note Added: 0003559
2009-06-30 06:42 ddennedy Note Added: 0003560
2009-07-01 17:11 Dave M G Note Added: 0003573
2009-07-01 18:44 ddennedy Note Added: 0003574
2009-07-01 19:31 Dave M G Note Added: 0003575
2009-08-26 09:57 Dave M G Note Added: 0003819
2009-09-02 15:58 piotr Note Added: 0003853
2009-10-10 15:24 piotr Note Added: 0004105
2009-10-10 22:04 ddennedy Note Added: 0004108
2009-10-10 22:04 ddennedy Status assigned => resolved
2009-10-10 22:04 ddennedy Fixed in Version => 0.7.6
2009-10-10 22:04 ddennedy Resolution open => fixed
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed
2010-09-22 17:53 Granjow Target Version future version => 0.7.6


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker