Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000890KdenliveBuild Systempublic2009-06-02 23:072009-07-01 21:57
ReporterCimmo 
Assigned Tomadsdyd 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.4 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000890: Cannot compile 0.7.4 on KDE 4.1.x
DescriptionCannot compile 0.7.4 on KDE 4.1.2

[ 85%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/dvdwizardmenu.o
/home/marco/src/kdenlive/src/dvdwizardmenu.cpp: In member function 'QDomElement DvdWizardMenu::toXml() const':
/home/marco/src/kdenlive/src/dvdwizardmenu.cpp:522: error: 'class KUrlRequester' has no member named 'text'
/home/marco/src/kdenlive/src/dvdwizardmenu.cpp:525: error: 'class KUrlRequester' has no member named 'text'
make[2]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/dvdwizardmenu.o] Error 1
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0003046)
administrator (administrator)
2009-06-02 23:12

Issue fixed but there might be other problems since I have no KDE 4.1.x install here. Please report further compilation issues here and I will try to fix...
(0003049)
Cimmo (reporter)
2009-06-02 23:22

/home/marco/src/kdenlive/src/dvdwizard.cpp: In member function 'void DvdWizard::slotSave()':
/home/marco/src/kdenlive/src/dvdwizard.cpp:661: error: 'class KUrlRequester' has no member named 'text'
/home/marco/src/kdenlive/src/dvdwizard.cpp:662: error: 'class KUrlRequester' has no member named 'text'
make[2]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/dvdwizard.o] Error 1


Maybe searching into che code for '->text()' would help? :)
(0003051)
administrator (administrator)
2009-06-02 23:31

Fixed. I didn't detect any other KUrlRequester's so that error should be ok now
(0003052)
Cimmo (reporter)
2009-06-02 23:38

Thanks, now compiles. That was quick :)
(0003053)
Cimmo (reporter)
2009-06-03 00:12

http://www.marcocimmino.net/2009/06/02/kdenlive-074-for-ubuntu-804/ [^]

:)

- Issue History
Date Modified Username Field Change
2009-06-02 23:07 Cimmo New Issue
2009-06-02 23:07 Cimmo Build/Install Method => Build Wizard
2009-06-02 23:12 administrator Note Added: 0003046
2009-06-02 23:12 administrator Status new => feedback
2009-06-02 23:22 Cimmo Note Added: 0003049
2009-06-02 23:31 administrator Note Added: 0003051
2009-06-02 23:38 Cimmo Note Added: 0003052
2009-06-03 00:12 Cimmo Note Added: 0003053
2009-06-03 13:31 madsdyd Status feedback => resolved
2009-06-03 13:31 madsdyd Fixed in Version => Recent git
2009-06-03 13:31 madsdyd Resolution open => fixed
2009-06-03 13:31 madsdyd Assigned To => madsdyd
2009-06-27 02:17 j-b-m Target Version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:57 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker