Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000895KdenliveUser Interfacepublic2009-06-05 04:022009-07-01 21:57
Reportergsking1 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000895: Crash when in Missing Files Dialog and click Abort
DescriptionI opened a project file that had moved video files. The missing clips dialog came up. Instead of finding them, I chose Abort and got a crash.

QFile::remove: Empty or null file name
*** glibc detected *** kdenlive: free(): invalid pointer: 0x09ae5638 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb6584604]
/lib/tls/i686/cmov/libc.so.6(cfree+0x96)[0xb65865b6]
/usr/lib/libX11.so.6[0xb630b6ce]
/usr/lib/libX11.so.6(_XReply+0x10d)[0xb630bccd]
/usr/lib/libX11.so.6(_XGetWindowAttributes+0xc6)[0xb62e98e6]
/usr/lib/libX11.so.6(XGetWindowAttributes+0x42)[0xb62e9a62]
/usr/local/lib/mlt/libmltsdl.so[0xb58aed64]


Application: Kdenlive (kdenlive), signal SIGABRT
[Current thread is 0 (LWP 26542)]

Thread 4 (Thread 0xac760b90 (LWP 26553)):
#0 0xb7f4e424 in __kernel_vsyscall ()
#1 0xb65f17b1 in select () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb732a380 in ?? () from /usr/lib/libQtCore.so.4
0000003 0xb725896e in ?? () from /usr/lib/libQtCore.so.4
0000004 0xb64fd4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb65f949e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xaddf8b90 (LWP 27598)):
[KCrash Handler]
0000006 0xb7f4e424 in __kernel_vsyscall ()
0000007 0xb65406d0 in raise () from /lib/tls/i686/cmov/libc.so.6
0000008 0xb6542098 in abort () from /lib/tls/i686/cmov/libc.so.6
0000009 0xb657e24d in ?? () from /lib/tls/i686/cmov/libc.so.6
0000010 0xb6584604 in ?? () from /lib/tls/i686/cmov/libc.so.6
0000011 0xb65865b6 in free () from /lib/tls/i686/cmov/libc.so.6
0000012 0xb630b6ce in ?? () from /usr/lib/libX11.so.6
0000013 0xb630bccd in _XReply () from /usr/lib/libX11.so.6
0000014 0xb62e98e6 in _XGetWindowAttributes () from /usr/lib/libX11.so.6
0000015 0xb62e9a62 in XGetWindowAttributes () from /usr/lib/libX11.so.6
0000016 0xb58aed64 in consumer_get_dimensions (width=0x9f04e10, height=0xab8a0ab0) at consumer_sdl_still.c:614
0000017 0xb58aefc2 in consumer_thread (arg=0xab8a09b0) at consumer_sdl_still.c:400
0000018 0xb64fd4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000019 0xb65f949e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa3378b90 (LWP 27599)):
#0 0xb7f4e424 in __kernel_vsyscall ()
#1 0xb65010e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb66082ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb58ae4fc in consumer_thread (arg=0xab6cc148) at consumer_sdl_preview.c:381
0000004 0xb64fd4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb65f949e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5b70920 (LWP 26542)):
#0 0xb7f4e424 in __kernel_vsyscall ()
#1 0xb6608643 in ?? () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb6589f5d in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003494)
gsking1 (reporter)
2009-06-27 03:11

Just had this happen again.

I had previously moved things around on the filesystem. I opened a project it prompted me to search for the missing files. I realized this was not hte project I wanted so instead of letting is search (which works), I chose the abort button instead. It crashed.

This is with latest mlt and kdenlive (rev3675)

Backtrace (reporting assistant says probably not useful).
Application: Kdenlive (kdenlive), signal: Aborted
[Current thread is 0 (LWP 20962)]

Thread 6 (Thread 0xaeedab90 (LWP 20963)):
#0 0xb8023424 in __kernel_vsyscall ()
#1 0xb66b8643 in ?? () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb6639f5d in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 5 (Thread 0xabea1b90 (LWP 22007)):
[KCrash Handler]
0000006 0xb8023424 in __kernel_vsyscall ()
0000007 0xb65f06d0 in raise () from /lib/tls/i686/cmov/libc.so.6
0000008 0xb65f2098 in abort () from /lib/tls/i686/cmov/libc.so.6
0000009 0xb662e24d in ?? () from /lib/tls/i686/cmov/libc.so.6
0000010 0xb6634604 in ?? () from /lib/tls/i686/cmov/libc.so.6
0000011 0xb66365b6 in free () from /lib/tls/i686/cmov/libc.so.6
0000012 0xb63a86ce in ?? () from /usr/lib/libX11.so.6
0000013 0xb63a8ccd in _XReply () from /usr/lib/libX11.so.6
0000014 0xb63868e6 in _XGetWindowAttributes () from /usr/lib/libX11.so.6
0000015 0xb6386a62 in XGetWindowAttributes () from /usr/lib/libX11.so.6
0000016 0xb4266d64 in consumer_get_dimensions (width=0x9bf7390, height=0xa62dd30) at consumer_sdl_still.c:614
0000017 0xb4266fc2 in consumer_thread (arg=0xa62dc30) at consumer_sdl_still.c:400
0000018 0xb65ad4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000019 0xb66a949e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xac6a2b90 (LWP 22008)):
#0 0xb8023424 in __kernel_vsyscall ()
#1 0xb65b10e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb66b82ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb42664fc in consumer_thread (arg=0xa61f028) at consumer_sdl_preview.c:381
0000004 0xb65ad4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb66a949e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xadbd2b90 (LWP 22009)):
#0 0xb8023424 in __kernel_vsyscall ()
#1 0xb66b8643 in ?? () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb6639f5d in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0xae3d3b90 (LWP 22010)):
#0 0xb8023424 in __kernel_vsyscall ()
#1 0xb65b10e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb66b82ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb42664fc in consumer_thread (arg=0xa6436f0) at consumer_sdl_preview.c:381
0000004 0xb65ad4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb66a949e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5c09920 (LWP 20962)):
#0 0xb8023424 in __kernel_vsyscall ()
#1 0xb66b8643 in ?? () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb6639f5d in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(0003499)
j-b-m (administrator)
2009-06-27 09:21

Cannot reproduce and the backtrace is useless. Could you attach your project file or send it to me so that I can try to reproduce?
(0003509)
gsking1 (reporter)
2009-06-27 16:41

I guess it's resolved. I can no longer reproduce this either. I think the only significant change to my system since yesterday was that I deleted my old kdenliverc file yesterday and updated to rev3675 (have been updating every 2 days or so).

Is deleting the kdenliverc file necessary? I ask because I also notice the transition triangle in the corner of clips has returned. It had been missing for some time for me (few weeks). I just assumed that it had been removed since it is easy to use the right click menu.

- Issue History
Date Modified Username Field Change
2009-06-05 04:02 gsking1 New Issue
2009-06-05 04:02 gsking1 Build/Install Method => Manual build from SVN
2009-06-27 03:11 gsking1 Note Added: 0003494
2009-06-27 09:21 j-b-m Note Added: 0003499
2009-06-27 09:21 j-b-m Status new => feedback
2009-06-27 16:41 gsking1 Note Added: 0003509
2009-07-01 19:21 j-b-m Assigned To => j-b-m
2009-07-01 19:21 j-b-m Status feedback => resolved
2009-07-01 19:21 j-b-m Resolution open => fixed
2009-07-01 19:21 j-b-m Fixed in Version => Recent git
2009-07-01 19:21 j-b-m Target Version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:57 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker