Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000898KdenliveUser Interfacepublic2009-06-07 14:222009-07-01 21:56
ReporterJerem 
Assigned Toddennedy 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.4 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000898: large mem leak with NTSC slowmotion clips
Descriptionif you read a clip that does not have a speed of 100 (25 or 50 for example), the memory usage increases very quickly, about 20 MB per second.

The test :
- a new project
- add a new clip and change the speed : 100 to 25
- read the project from the begining
- keep an eye on the memory usage during the playback, it increases quicky after 6 secondes (probably from begin).

Then read a 2 minutes slowmotion uses more than 2 GB of ram (or read 20 times 10 secondes).

this does not seem to occur when rendering
Additional Informationkdenlive revision 3474
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0003112)
administrator (administrator)
2009-06-08 11:23

Cannot reproduce. Which version of MLT are you using?
(0003124)
Jerem (reporter)
2009-06-08 23:28

mlt version :
commit 6eb6dbb439b440804c63c1845cb14e20a4b61fa date: sat may 30 09:01:12 2009 -0700

I have update at 20h00 gmt today (8 june), to the newest (kdenlive, ffmpeg, mlt) with the bulder, and I have the same leak.

I try lot's of format : flv, mp4, wmv, ...
A test :
-empty project HD 720p 59,94 Hz
-use this http://para15.ovh.org/tmp/2008.06.15_15-19-13_h264.avi [^]
-add to the first track
-modify the speed : 100 to 50
-look the memory usage with "top" for exemple


I use this command to log the memory usage while a playback : top -d 1 -p 6117 -b > top.log
the file top.log is attached.

In short, the playback start at 23:09:40 and the tops have gave :

          VIRT RES SHR S %CPU %MEM
23:09:40 252m 82m 31m S 6 4.1
23:09:41 272m 88m 32m S 13 4.4
23:09:42 305m 109m 34m R 96 5.4
23:09:43 305m 109m 34m S 79 5.4
23:09:44 305m 109m 34m S 77 5.4
23:09:45 305m 109m 34m S 79 5.4
23:09:46 311m 114m 34m R 76 5.7
23:09:47 348m 147m 34m S 78 7.3
23:09:48 405m 197m 34m S 86 9.8
23:09:49 466m 250m 34m S 82 12.4
23:09:50 508m 288m 34m S 73 14.3
23:09:51 568m 341m 34m S 71 17.0
23:09:52 631m 397m 34m S 60 19.7
23:09:53 665m 427m 34m S 63 21.2
23:09:54 703m 460m 34m R 64 22.9
23:09:55 745m 497m 34m S 61 24.7
23:09:56 800m 545m 34m S 66 27.1
23:09:57 855m 593m 34m S 67 29.5
23:09:58 909m 641m 34m S 60 31.9
23:09:59 948m 675m 34m S 59 33.6
23:10:00 997m 719m 34m S 62 35.7
23:10:01 1039m 754m 34m R 63 37.5
23:10:02 1078m 789m 34m S 57 39.2
23:10:03 1099m 807m 32m S 43 40.1
23:10:04 1099m 807m 32m S 10 40.1

It's stange : it increases after 6 secondes
(0003125)
administrator (administrator)
2009-06-09 09:25

Ok, I can confirm this problem. It only seems to happen with NTSC profiles, where frame rate are non integer. Reproducable with melt:

melt -profile hdv_720_60p framebuffer:2008.06.15_15-19-13_h264.avi?.25

This is probably an issue in the framebuffer producer, will take a look unless Dan has a better idea.
(0003186)
ddennedy (developer)
2009-06-13 05:04

I will take a look, and I changed to block because I hate bugs that cause huge memory consumption rendering the system unresponsive for potentially a long time.
(0003222)
ddennedy (developer)
2009-06-16 07:52

This is fixed in MLT git commit a54ac61aa629fb76eb8394616e37608b9c327f16.

- Issue History
Date Modified Username Field Change
2009-06-07 14:22 Jerem New Issue
2009-06-07 14:22 Jerem Build/Install Method => Build Wizard
2009-06-08 11:23 administrator Note Added: 0003112
2009-06-08 11:23 administrator Status new => feedback
2009-06-08 23:28 Jerem Note Added: 0003124
2009-06-09 09:25 administrator Note Added: 0003125
2009-06-09 09:25 administrator Status feedback => acknowledged
2009-06-09 09:26 administrator Summary large lek when playback clip with speed != 100% => large mem leek with NTSC slowmotion clips
2009-06-09 12:16 administrator Summary large mem leek with NTSC slowmotion clips => large mem leak with NTSC slowmotion clips
2009-06-13 05:03 ddennedy Status acknowledged => assigned
2009-06-13 05:03 ddennedy Assigned To => ddennedy
2009-06-13 05:03 ddennedy Severity major => block
2009-06-13 05:04 ddennedy Note Added: 0003186
2009-06-16 07:52 ddennedy Note Added: 0003222
2009-06-16 07:52 ddennedy Status assigned => resolved
2009-06-16 07:52 ddennedy Fixed in Version => Recent git
2009-06-16 07:52 ddennedy Resolution open => fixed
2009-06-19 02:38 xzhayon Target Version => future version
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:56 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker