Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000899KdenliveEffectspublic2009-06-08 08:262013-02-14 16:14
Reporterrico 
Assigned ToLeHomard 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0000899: on applying the glow effect kdenlive crashes
DescriptionKdenlive SVN r3495

when i apply the glow filter kdenlive quits.
this is what i got from launching it from a terminal:

kdenlive(7806) EffectStackEdit::transferParamDesc: in
kdenlive(7806) EffectsListWidget::itemEffect: // EFFECT SELECTED: ("frei0r.glow", "frei0r.glow")
kdenlive(7806) ClipItem::initEffect: // inint eff: "Blur"
kdenlive(7806) AddEffectCommand::redo: ---- redoing action
kdenlive(7806) Render::mltAddEffect: / / INSERTING EFFECT: "frei0r.glow"
kdenlive(7806) EffectStackEdit::transferParamDesc: in
kdenlive(7806) EffectStackEdit::transferParamDesc: in form
kdenlive: symbol lookup error: /home/eric/kdenlive/lib/frei0r-1//glow.so: undefined symbol: MAX
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filesdiff file icon glow.diff [^] (1,007 bytes) 2009-06-15 21:30 [Show Content]

- Relationships

-  Notes
(0003114)
administrator (administrator)
2009-06-08 19:40

Cannot reproduce. I would say it is an issue with your frei0r install. Can you try to recompile frei0r?
(0003122)
rico (reporter)
2009-06-08 20:19

trashed all fei0r i could find and restarted the wizard.. still crashing on glow

frei0r: commit c950588f3e9188aa51e2cd3b9346bf346ad34118 Date: Thu Apr 9
ffmpeg: r19134
mlt: commit c15dfffd57afb2addd717400c53972364b9c761e Date: Sun Jun 7
kdenlive: r3498

install options:
theora support, AAC support, MP3 support, H264 support
sox support enabled


same error in the terminal

ubuntu 9.04_64
(0003127)
administrator (administrator)
2009-06-09 14:52

Wondering if this is a 64bit specific issue. Can you try the effect with melt:

melt video.mpg -attach frei0r.glow "Blur=0.5"
(0003128)
rico (reporter)
2009-06-09 15:12

..I'm afraid I don't understand what do you mean by trying the effect with melt..

is that a command line?
i tried it as a command line and i get
bash: melt: command not found
(0003129)
administrator (administrator)
2009-06-09 15:21
edited on: 2009-06-09 15:26

Yes, that is a command line... but since you installed with the wizard, you probably need to go in the wizard binary folder, like:
$HOME/kdenlive/bin

which should contain the melt executable.

then, try:

./melt video.mpg -attach frei0r.glow "Blur=0.5"

*Edit:
You might need to enter the following line before executing melt:
export MLT_FREI0R_PLUGIN_PATH=$HOME/kdenlive/lib/frei0r-1/

(0003130)
rico (reporter)
2009-06-09 15:29

a window opens playing the video and i get this in the terminal, no crash:

+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5= 0| |6= 1| |7= 2| |8= 5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
| H = back 1 minute, L = forward 1 minute |
| h = previous frame, l = next frame |
| g = start of clip, j = next clip, k = previous clip |
| 0 = restart, q = quit, space = play |
+---------------------------------------------------------------------+
Current Position: 1909
(0003131)
administrator (administrator)
2009-06-09 15:44

Can you see the glow effect in action in the playing video?
You can try to adjust the glow value by increasing the Blur value to 0.9 to be sure.
(0003132)
rico (reporter)
2009-06-09 15:49

no i can't see the glow effect, increased the value to 0.9 and compared to the original movie.. no difference
(0003133)
administrator (administrator)
2009-06-09 15:58

Did you type the export line in the same terminal before running melt:

export MLT_FREI0R_PLUGIN_PATH=$HOME/kdenlive/lib/frei0r-1/

Make sure to type it (replace $HOME with your home folder: /home/eric/)

then, try:
./melt -query filters

You should see a line stating freior.glow

then try again:
./melt video.mpg -attach frei0r.glow "Blur=0.9"
(0003134)
rico (reporter)
2009-06-09 16:05

ok.. i would say the glow worked this time.. cause.. it crashed:

~/kdenlive/bin$ ./melt /home/eric/Desktop/video.flv -attach frei0r.glow "Blur=0.9"
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5= 0| |6= 1| |7= 2| |8= 5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
| H = back 1 minute, L = forward 1 minute |
| h = previous frame, l = next frame |
| g = start of clip, j = next clip, k = previous clip |
| 0 = restart, q = quit, space = play |
+---------------------------------------------------------------------+
./melt: symbol lookup error: /home/eric/kdenlive/lib/frei0r-1//glow.so: undefined symbol: MAX
(0003135)
administrator (administrator)
2009-06-09 16:20

I think it is a 64bit issue. MAX is defined in frei0r/src/filters/glow/blur.h,
but for some reason it looks like it does not work...

Could anybody with a 64bit system confirm that issue?
If this is confirmed, should be reported to the frei0r mailing list...
(0003138)
rico (reporter)
2009-06-09 20:15

just tried on a ubuntu 9.04_32 and same issue.
(also compiled with the build wizard)
(0003212)
administrator (administrator)
2009-06-15 21:03

Ok, was able to reproduce. However it only happens when using the Builder Wizard, there may be a linkage error or something... trying to investigate.
(0003215)
administrator (administrator)
2009-06-15 21:32
edited on: 2009-06-15 21:33

Ok, I found the problem and I think it is a frei0r issue. The attached patch (glow.diff) fixes the crash. Not sure if it has side effects, so if someone else can give his opinion, we can then forward it to frei0r's mailing list.

Basically, the patch changes the frei0r file glow/blur.h and replaces:

__inline functions

with:

static inline functions

(0003601)
guiodic (reporter)
2009-07-05 07:10

I applied the patch. wen I apply glow effect kdenlive doesn't crash, but if I increase the blur then it does.
(0005292)
LeHomard (developer)
2010-06-18 12:32

Does this issue still exist ? I cannot reproduce it on a recent build.
(0005340)
LeHomard (developer)
2010-07-03 13:50

Closing bug report because of lack of response.

- Issue History
Date Modified Username Field Change
2009-06-08 08:26 rico New Issue
2009-06-08 08:26 rico Build/Install Method => Build Wizard
2009-06-08 19:40 administrator Note Added: 0003114
2009-06-08 19:40 administrator Status new => feedback
2009-06-08 20:19 rico Note Added: 0003122
2009-06-09 14:52 administrator Note Added: 0003127
2009-06-09 15:12 rico Note Added: 0003128
2009-06-09 15:21 administrator Note Added: 0003129
2009-06-09 15:26 administrator Note Edited: 0003129
2009-06-09 15:26 administrator Note Edited: 0003129
2009-06-09 15:29 rico Note Added: 0003130
2009-06-09 15:44 administrator Note Added: 0003131
2009-06-09 15:49 rico Note Added: 0003132
2009-06-09 15:58 administrator Note Added: 0003133
2009-06-09 16:05 rico Note Added: 0003134
2009-06-09 16:20 administrator Note Added: 0003135
2009-06-09 20:15 rico Note Added: 0003138
2009-06-15 21:03 administrator Note Added: 0003212
2009-06-15 21:30 administrator File Added: glow.diff
2009-06-15 21:32 administrator Note Added: 0003215
2009-06-15 21:33 administrator Note Edited: 0003215
2009-06-19 02:40 xzhayon Target Version => future version
2009-07-05 07:10 guiodic Note Added: 0003601
2010-06-18 12:32 LeHomard Note Added: 0005292
2010-07-03 13:50 LeHomard Note Added: 0005340
2010-07-03 13:50 LeHomard Status feedback => resolved
2010-07-03 13:50 LeHomard Resolution open => fixed
2010-07-03 13:50 LeHomard Assigned To => LeHomard
2010-09-14 23:23 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker