Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000911KdenliveUser Interfacepublic2009-06-11 22:502009-07-01 21:56
ReporterGranjow 
Assigned ToGranjow 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000911: Title Clip Window: When «--X» selected right border of text should be fixed when typing
Descriptionso that the text field is growing to the left.
Additional InformationUnfortunately QGraphicsTextItem doesn't have a textChanged() signal …
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships
related to 0000914closedGranjow Title Clip Window: Remember selected axis for items 
child of 0000846closedGranjow Title Clip editor: Allow positioning also relative to bottom right edge 

-  Notes
(0003173)
xzhayon (developer)
2009-06-12 01:30

at last i found some time to look at it
actually, qgraphicsitem's has almost no signals at all!

i would try these two paths:
1. http://doc.trolltech.com/4.5/qgraphicsscene.html#changed [^] -> i wouldn't be optimist about this
2. grabbing keyboard input: bad, absolutely bad, but... who knows?

write if you need help (here or on irc)
(0003176)
Granjow (developer)
2009-06-12 11:57

Fixed in r3520. Could you please test and tell me whether it looks OK? I've also inverted x/y axis so you don't have to enter negative values as long as the item is top/left of the axis.
(0003177)
Granjow (developer)
2009-06-12 11:57

Ah yeah, and thanks for your link, it really worked :)
(0003178)
xzhayon (developer)
2009-06-12 12:19

it works fine here, nice job! it's better now with positive values, and it's really useful!

just 2 notes:
1. why did you include iostream?
2. i think it's better to keep slotChanged() as a generic slot which calls textChanged(), because it could do many other things

btw: to save it look at titledocument.cpp (better to open another child issue i think)
(0003192)
Granjow (developer)
2009-06-13 19:18

Thank you!

1. I forgot to remove it :)
2. Yes, you're right. Thanks for pointing that out. I've changed it.
(0003193)
Granjow (developer)
2009-06-13 19:54

in r3529. Okay?
(0003198)
xzhayon (developer)
2009-06-15 00:45

it's okay: fixed!

- Issue History
Date Modified Username Field Change
2009-06-11 22:50 Granjow New Issue
2009-06-11 22:50 Granjow Build/Install Method => Manual build from SVN
2009-06-11 22:50 Granjow Relationship added child of 0000846
2009-06-11 22:51 Granjow Summary Text Clip Window: When «?X» selected right border of text should be fixed when typing => Text Clip Window: When «--X» selected right border of text should be fixed when typing
2009-06-12 01:30 xzhayon Note Added: 0003173
2009-06-12 01:30 xzhayon Status new => feedback
2009-06-12 10:58 Granjow Status feedback => assigned
2009-06-12 10:58 Granjow Assigned To => Granjow
2009-06-12 11:57 Granjow Note Added: 0003176
2009-06-12 11:57 Granjow Status assigned => feedback
2009-06-12 11:57 Granjow Note Added: 0003177
2009-06-12 12:19 xzhayon Note Added: 0003178
2009-06-13 19:18 Granjow Note Added: 0003192
2009-06-13 19:21 Granjow Relationship added related to 0000914
2009-06-13 19:54 Granjow Note Added: 0003193
2009-06-14 22:14 Granjow Summary Text Clip Window: When «--X» selected right border of text should be fixed when typing => Title Clip Window: When «--X» selected right border of text should be fixed when typing
2009-06-15 00:45 xzhayon Note Added: 0003198
2009-06-15 00:45 xzhayon Status feedback => resolved
2009-06-15 00:45 xzhayon Fixed in Version => Recent git
2009-06-15 00:45 xzhayon Resolution open => fixed
2009-06-19 02:42 xzhayon Target Version => future version
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:56 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker