Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000913KdenliveMLTpublic2009-06-13 09:162009-07-01 21:56
ReporterWeevil 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000913: MLT: SDL module not found'. Without frei0r this doesn't happen
DescriptionWhen building with frei0r support Kdenlive gives the error 'MLT: SDL module not found'. Without frei0r this doesn't happen.
Additional InformationDebian (Unstable/Squeeze 2.6.26-2-686)

Kdenlive Builder Wizard version: 0.9.90
ffmpeg: Revision: 19180 Last Changed Date: 2009-06-13 05:02:16 +0200 (Sat, 13 Jun 2009)
mlt: commit 5ed9541653c9da74ea99648c65e84d2b46897ad8 Date: Wed Jun 10 22:10:01 2009 -0700
kdenlive: Revision: 3526 Last Changed Date: 2009-06-13 01:22:14 +0200 (Sat, 13 Jun 2009)
Qt: 4.5.1
KDE: 4.2.2 (KDE 4.2.2)
Kdenlive: 0.7.4



Might be related to:
http://kdenlive.org/forum/kdenlive-doesnt-start-after-installation#comment-3506 [^]
https://bugs.launchpad.net/ubuntu/+source/kdenlive/+bug/363430 [^] (could not find facedetect.so though)
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filesgz file icon kbw.gbw.logs.tar.gz [^] (117,052 bytes) 2009-06-17 22:45

- Relationships
has duplicate 0000917closedddennedy Melt crashes when frei0r-plugins are installed 

-  Notes
(0003187)
ddennedy (developer)
2009-06-13 09:30

The claim about SDL vs frei0r is absurd. There is no bug here in the MLT build. Maybe something strange going on with the build wizard in your environment or distro version.
(0003204)
jmpoure (developer)
2009-06-15 16:55
edited on: 2009-06-15 16:56

I can confirm this problem on Ubuntu and Debian. All my Debian hosts have the problem. The title of bug is not correct.

When installed with frei0r, running melt from the command line results in an immediate crash.

(0003209)
Weevil (reporter)
2009-06-15 19:28

At the moment... actually since right the next day after posting this, I'm having trouble building Kdenlive. I think it's something to do with MLT (/home/marijn/src/kdenlive/thumbnailer/cmake_bindir/../westleypreview.h:45: error: 'Mlt' has not been declared) so for now I am waiting for a new MLT revision, otherwise I'll contact Mads.

If the frei0r/SDL/... bug persists after building I'll post back here or just close this bugreport and I will make an new one with less misleading title and description.
(0003210)
administrator (administrator)
2009-06-15 19:54

The compile error is due to a recent change in Kdenlive. Please try to clean the kdenlive sources and rebuild.
(0003211)
jmpoure (developer)
2009-06-15 20:59
edited on: 2009-06-15 21:01

Dear Dan,

I can confirm the bug using the live DVDs and several Debian systems. Running melt any-file.avi results in a segfault. This is not a Kdenlive problem. Removing frei0r-plugins solves the issue.

I will rename the bug to avoid any sdl confusion. There is no SDL problem.

If this problem was fixed lately, maybe we should make a release.

Kind regards,
Jean-Michel

(0003213)
ddennedy (developer)
2009-06-15 21:04

This is a bug in the build of the frei0r facedetect plugin, apparently related to opencv that plugin uses. I do not reproduce this issue on Arch Linux. Just accessing the plugin to register it without ever using it triggers the segfault. What would you have me do? Do I need to add a blacklist in MLT? If so, then do we blacklist some things even though they work fine on some systems?
(0003216)
ddennedy (developer)
2009-06-15 21:41

On my Ubuntu 9.04 box at work, I use the build wizard, and mlt with frei0r and facedetect work just fine on that build. Even applying the filter to a video works!
(0003218)
jmpoure (developer)
2009-06-15 22:26

The builder wizard provides the latest build, not the stock release. Did you use the lastest frei0r from git?
(0003219)
jmpoure (developer)
2009-06-15 22:38
edited on: 2009-06-15 22:45

Compiling the latest MLT from GIT with Frei0r Debian packages works fine.
Downloading and compiling MLT 0.4.2 by hand also works fine with Frei0r.

I don't understand what is going on.

(0003220)
ddennedy (developer)
2009-06-15 22:48

I am beginning to believe that some frei0r dependency had a API change but did not update the lib versions forcing dependent packages to be rebuilt. Therefore, when you build the package, it picks up the change, and all is resolved.

My frei0r build is based on a git clone whose last log message is Apr 9, 2009. Nothing changed in mlt for frei0r since the last release.
(0003231)
jmpoure (developer)
2009-06-16 12:18
edited on: 2009-06-16 12:27

apt-get build-dep frei0r-plugins
apt-get source -b frei0r-plugins
to rebuild freiOr-plugins

Then:
dpkg --install --reinstall frei0r-plugins to test.

Rebuilding Frei0r-plugins makes no difference.

(0003232)
jmpoure (developer)
2009-06-16 12:28

Okay, I am now looking at MLT packages. It seems like the Debian maintainer added up to 6 patches. Wooo! We were not aware of these ***nice*** addition. Let me check.
(0003234)
jmpoure (developer)
2009-06-16 12:55
edited on: 2009-06-16 16:19

I rebuilt and installed MLT Debian packages without any patch and it still segfaults. I also rebuild it without-mmx, still the same problem.

(0003266)
Weevil (reporter)
2009-06-17 22:46

The building issue is solved now, the frei0r/MLT/SDL/... error has returned.

Here's what I did to confirm and reproduce:

1. Delete every configfile I could find (/home/user/.kde4/etcetera) or make sure that they're non-existent

2. Delete source directories for kdenlive, ffmpeg, mlt and frei0r

3. Delete previous install dir kdenlive (if existent)

4. Run build wizard


...with the same result.
 Build with frei0r support = 'MLT: SDL module not found' error at startup
 Build without frei0r support = working Kdenlive

Opening an avi with melt gives sound and video. This is not claims or fantasy just what I did and the result. KBW build logs and GDB output are attached.
(0003295)
ddennedy (developer)
2009-06-18 21:14

I think jmpoure may have incorrectly changed the subject and hijacked this bug report for a separate issue. I do not know what is going on with the build wizard to cause this. Hopefully, Mads who wrote the wizard can look at your log and give it some thought.
(0003296)
jmpoure (developer)
2009-06-18 21:26

I reverted the sorry, sorry for the inconvenience. JB could reproduce the problem and sent an email to MLT mailing list. I could also reproduce on USB key live.
(0003297)
Weevil (reporter)
2009-06-18 21:32

Strange things... today it works again. Build a clean install, it starts and frei0r effects work. I'll try some build combinations to see if I can pinpoint the issue some more.

At least we have some logs.
(0003298)
Weevil (reporter)
2009-06-18 23:14

I'm going crazy here :| I've double checked my update logs (/var/log/apt/term.log) and nothing on my system is updated after my post yesterday. Also I haven't installed anything else, should be the same computer with the same operating system and the same programs/programversions.

Yet today building & running kdenlive with the exact same frei0r/mlt/ffmpeg/kdenlive versions (also double checked) that gave me problems yesterday does work. I don't understand this.
(0003299)
ddennedy (developer)
2009-06-18 23:21

I just finished a test of the build wizard on Ubuntu 9.04, and it worked fine here.

jmpoure, Re: "JB could reproduce the problem and sent an email to MLT mailing list."

Which problem? And I do not see or understand the email to which you refer - subject?
(0003300)
administrator (administrator)
2009-06-18 23:31

No idea what jmpoure meant. Maybe he was referring to issue 0000899 which caused a crash when using the frei0r glow effect (problem appeared only with the Build Wizard) and for which I attached a patch for frei0r... But that's another issue.
(0003305)
ddennedy (developer)
2009-06-19 07:01

Weevil, I now recall that you get this error when melt can not be found in your path. When using the build wizard, it is important to run the kdenlive_start script instead of just kdenlive to fully setup the environment.
(0003313)
jmpoure (developer)
2009-06-19 10:33

I was refering to JB mail:

From: jb <j-b-m@users.sourceforge.net>
To: mlt-devel@lists.sourceforge.net
Cc: Dan Dennedy <dan@dennedy.org>
Subject: [Mlt-devel] Framebuffer producer crashes with sdl_preview consumer
Date: Thu, 18 Jun 2009 01:10:58 +0200

Anyway, I see the SDL issue was fixed in GIT. Thanks.
(0003337)
Weevil (reporter)
2009-06-20 01:12

So enlightenment has come :) Thanks ddennedy & everyone!
(0003344)
Weevil (reporter)
2009-06-20 14:18

Just got hit by a brainwave... in order to get the gdb error output which I included I had to run kdenlive_start. That means the environment should have been setup, right?
(0003363)
Weevil (reporter)
2009-06-21 19:55

Update of the current situation over here:

1. Install with frei0r support

 - melt gives Segmentation Fault (tested with mpeg2 video)
 - Kdenlive SVN starts, plays video files, plays audio files
 - going to 'Setting' > 'Config Wizard' gives back the "MLT: SDL module not found'" message

2. Install without frei0r support
 - melt plays mpeg2 video
 - Kdenlive SVN starts, plays video files, plays audio files
 - going to 'Setting' > 'Config Wizard' gives back no error messages
(0003365)
ddennedy (developer)
2009-06-22 01:49

So this is actually the same bug as the frei0r bug jmpoure claimed. We should keep the subject line because that is how some people are experiencing this problem. When the wizard runs, it launches melt, which crashes on frei0r facedetect.so, and reports this error because the 'melt -query consumer' output does not contain 'sdl'. This bug is such a nuisance, I think I'm just gonna add a black list to mlt.
(0003374)
jmpoure (developer)
2009-06-22 16:19

I agree with these statements. This is the same here.
(0003381)
ddennedy (developer)
2009-06-22 22:14

Please test MLT Git. I added blacklist to the frei0r module. See if blacklisting facedetect solves the problem.
(0003403)
Weevil (reporter)
2009-06-23 21:20

Just installed everything with KBW, with frei0r support. Melt plays video files, Kdenlive plays video & audio files, Config Wizard gives no errors all the way.
(0003404)
ddennedy (developer)
2009-06-23 21:23

thank you for your feedback

- Issue History
Date Modified Username Field Change
2009-06-13 09:16 Weevil New Issue
2009-06-13 09:16 Weevil Build/Install Method => Build Wizard
2009-06-13 09:30 ddennedy Note Added: 0003187
2009-06-15 16:55 jmpoure Note Added: 0003204
2009-06-15 16:56 jmpoure Note Edited: 0003204
2009-06-15 19:28 Weevil Note Added: 0003209
2009-06-15 19:54 administrator Note Added: 0003210
2009-06-15 20:59 jmpoure Note Added: 0003211
2009-06-15 21:00 jmpoure Category Build System => MLT
2009-06-15 21:00 jmpoure Summary MLT: SDL module not found. => MLT: melt segfaults when frei0r is installed
2009-06-15 21:01 jmpoure Note Edited: 0003211
2009-06-15 21:04 ddennedy Note Added: 0003213
2009-06-15 21:41 ddennedy Note Added: 0003216
2009-06-15 22:26 jmpoure Note Added: 0003218
2009-06-15 22:38 jmpoure Note Added: 0003219
2009-06-15 22:38 jmpoure Note Edited: 0003219
2009-06-15 22:45 jmpoure Note Edited: 0003219
2009-06-15 22:48 ddennedy Note Added: 0003220
2009-06-16 12:18 jmpoure Note Added: 0003231
2009-06-16 12:18 jmpoure Note Edited: 0003231
2009-06-16 12:27 jmpoure Note Edited: 0003231
2009-06-16 12:28 jmpoure Note Added: 0003232
2009-06-16 12:55 jmpoure Note Added: 0003234
2009-06-16 16:19 jmpoure Note Edited: 0003234
2009-06-17 22:45 Weevil File Added: kbw.gbw.logs.tar.gz
2009-06-17 22:46 Weevil Note Added: 0003266
2009-06-18 21:14 ddennedy Note Added: 0003295
2009-06-18 21:25 jmpoure Summary MLT: melt segfaults when frei0r is installed => MLT: SDL module not found'. Without frei0r this doesn't happen
2009-06-18 21:26 jmpoure Note Added: 0003296
2009-06-18 21:32 Weevil Note Added: 0003297
2009-06-18 23:14 Weevil Note Added: 0003298
2009-06-18 23:21 ddennedy Note Added: 0003299
2009-06-18 23:31 administrator Note Added: 0003300
2009-06-19 07:01 ddennedy Note Added: 0003305
2009-06-19 10:33 jmpoure Note Added: 0003313
2009-06-20 01:12 Weevil Note Added: 0003337
2009-06-20 14:18 Weevil Note Added: 0003344
2009-06-21 19:55 Weevil Note Added: 0003363
2009-06-22 01:49 ddennedy Note Added: 0003365
2009-06-22 01:49 ddennedy Relationship added has duplicate 0000917
2009-06-22 16:19 jmpoure Note Added: 0003374
2009-06-22 22:14 ddennedy Note Added: 0003381
2009-06-22 22:14 ddennedy Status new => feedback
2009-06-23 21:20 Weevil Note Added: 0003403
2009-06-23 21:23 ddennedy Note Added: 0003404
2009-06-23 21:23 ddennedy Status feedback => resolved
2009-06-23 21:23 ddennedy Fixed in Version => Recent git
2009-06-23 21:23 ddennedy Resolution open => fixed
2009-06-23 21:23 ddennedy Assigned To => ddennedy
2009-06-23 21:23 ddennedy Target Version => future version
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:56 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker