Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000919KdenliveUser Interfacepublic2009-06-15 18:162009-07-01 21:56
ReporterGranjow 
Assigned Toxzhayon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000919: Title Clip Window: Edges for resizing rects don't change when it is transformed
DescriptionThis is sort of nasty. When I've got a rect from (0|0) to (100|100) and set a zoom factor of 200 %, it is visible from (0|0) to (200|200). However I still have to point my mouse to (100|100) to get the resize cursor.

Same with rotate.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003235)
xzhayon (developer)
2009-06-16 12:57

i'll take it
(0003237)
xzhayon (developer)
2009-06-16 13:23

add: same with (h|v)center positioning
(0003253)
xzhayon (developer)
2009-06-17 20:54

fixed in rev. 3559, please test

resizing from the top left vertex results in a strange behaviour when the rectangle is rotated, i don't know why (it required a hack to work), but it's fine
if someone knows a better way to do this, please tell me!
(0003262)
xzhayon (developer)
2009-06-17 22:30

oh, kill me! there IS a faster way to do all those calcs! i'm going to change it later tonight
anyway, the behaviour won't change, so please have a test :)
(0003276)
xzhayon (developer)
2009-06-18 00:31

it seems i can't make it with the QTransform::map() functions (which are designed to do those calcs)
i'll keep it as is since it's working, and review it in the future
(0003310)
Granjow (developer)
2009-06-19 09:48

Working here!

* When rotated, the cursor doesn't suit anymore.
* There are very few pixels at the edges where I get the cursor to change both width and height.
* When dragging the left edge of a rect over the right edge and farther the width remains at 1 px or so. Would be nice to see it expanding in the other direction. But just an unimportant feature :)
(0003312)
xzhayon (developer)
2009-06-19 10:07

- there is no way to rotate a cursor :(... i could create 2PI different cursors! :P
- you mean: it's difficult to get to the corner resize? ok, i'll improve this
- this is done not to get negative widths/heights. i'll test how they work but i don't like a negative number displayed in the width field (even if it would eliminate all those calcs), so maybe i could improve it to make it keep a positive width (easy i guess)
(0003314)
Granjow (developer)
2009-06-19 10:46

* Just use another cursor :) If the rect is rotated by 45°, change to the horizontal resize cursor and so on.
* Exactly.
* -> Use a new rect. User is then dragging the right edge of the rect without knowing it.
(0003315)
xzhayon (developer)
2009-06-19 10:48

resizing over borders implemented in rev. 3590, please test

it can happen that you lose handle to the border and stop resizing when the rectangle is thin: i think i know why, i'll try to fix it later. anyway it's not related to this issue

i've not changed the corner resizing because it's working fine here, and i want to know if i have understood correctly
(0003316)
xzhayon (developer)
2009-06-19 10:51

- yes, that's an idea
- ok, fixing
- already done, in a simpler way :)
(0003325)
xzhayon (developer)
2009-06-19 17:05

both fixed in rev. 3594
i've enlarged the mouse selection area, enlarging it further would be too much i think
(0003330)
Granjow (developer)
2009-06-19 19:36

Yes, looks nice!

- Issue History
Date Modified Username Field Change
2009-06-15 18:16 Granjow New Issue
2009-06-15 18:16 Granjow Build/Install Method => Manual build from SVN
2009-06-16 12:57 xzhayon Status new => assigned
2009-06-16 12:57 xzhayon Assigned To => xzhayon
2009-06-16 12:57 xzhayon Note Added: 0003235
2009-06-16 13:23 xzhayon Note Added: 0003237
2009-06-17 20:54 xzhayon Note Added: 0003253
2009-06-17 20:54 xzhayon Status assigned => feedback
2009-06-17 22:30 xzhayon Note Added: 0003262
2009-06-18 00:31 xzhayon Note Added: 0003276
2009-06-19 02:15 xzhayon Target Version => future version
2009-06-19 09:48 Granjow Note Added: 0003310
2009-06-19 10:07 xzhayon Note Added: 0003312
2009-06-19 10:46 Granjow Note Added: 0003314
2009-06-19 10:48 xzhayon Note Added: 0003315
2009-06-19 10:51 xzhayon Note Added: 0003316
2009-06-19 17:05 xzhayon Note Added: 0003325
2009-06-19 19:36 Granjow Note Added: 0003330
2009-06-19 21:53 xzhayon Status feedback => resolved
2009-06-19 21:53 xzhayon Fixed in Version => Recent git
2009-06-19 21:53 xzhayon Resolution open => fixed
2009-06-26 21:01 administrator Fixed in Version Recent git => 0.7.5
2009-06-26 21:07 administrator Fixed in Version 0.7.5 => Recent git
2009-06-26 21:07 administrator Target Version future version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:56 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker