Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000927KdenliveBuild Systempublic2009-06-17 23:192010-11-14 22:35
Reportercatscanner 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version0.7.3 
Target VersionFixed in Version0.7.4 
Summary0000927: crash during editing .mod files
DescriptionKDElive cashes while editing .mod files. The files open and previews can be played. I also can work normally with the timeline and other features. But after a short time(between 30 seconds and 5 minutes) the program give the crash notification you can see in the atached file.
The .mod files are created bij a JVC Everio Camcorder.
My OS is Ubuntu 9.04 with Gnome version 2.26.0 and Linux version 2.6.29
Additional InformationCashlog:
This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5e54700 (LWP 8743)]
[New Thread 0xae30fb90 (LWP 8803)]
[New Thread 0xab3beb90 (LWP 8802)]
[New Thread 0xac5c2b90 (LWP 8759)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xb80ac430 in __kernel_vsyscall ()
[Current thread is 0 (LWP 8743)]
Thread 4 (Thread 0xac5c2b90 (LWP 8759)):
#0 0xb80ac430 in __kernel_vsyscall ()
#1 0xb677a7b1 in select () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb743d380 in ?? () from /usr/lib/libQtCore.so.4
0000003 0xb736b96e in ?? () from /usr/lib/libQtCore.so.4
0000004 0xb66864ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb678249e in clone () from /lib/tls/i686/cmov/libc.so.6
Thread 3 (Thread 0xab3beb90 (LWP 8802)):
#0 0xb80ac430 in __kernel_vsyscall ()
#1 0xb673d7a6 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb673d5be in sleep () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb7eb28b2 in ?? () from /usr/lib/libkdeui.so.5
0000004 0xb7eb3274 in KCrash::defaultCrashHandler () from /usr/lib/libkdeui.so.5
0000005 <signal handler called>
0000006 0xb3500334 in ?? ()
0000007 0xb3502083 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Thread 2 (Thread 0xae30fb90 (LWP 8803)):
#0 0xb80ac430 in __kernel_vsyscall ()
#1 0xb668a0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb67912ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb3f64d2c in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Thread 1 (Thread 0xb5e54700 (LWP 8743)):
#0 0xb80ac430 in __kernel_vsyscall ()
#1 0xb668a0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb67912ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb736c9b2 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
0000004 0xb736bb13 in QThread::wait () from /usr/lib/libQtCore.so.4
0000005 0xb74402fe in ?? () from /usr/lib/libQtCore.so.4
0000006 0xb744081a in ?? () from /usr/lib/libQtCore.so.4
0000007 0xb66ccbb9 in exit () from /lib/tls/i686/cmov/libc.so.6
0000008 0xb577a165 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
0000009 0xb7e422fa in KApplication::xioErrhandler () from /usr/lib/libkdeui.so.5
0000010 0xb7e42336 in ?? () from /usr/lib/libkdeui.so.5
0000011 0xb3d1f257 in ?? ()
0000012 0xb6475f22 in _XIOError () from /usr/lib/libX11.so.6
0000013 0xb647d743 in ?? () from /usr/lib/libX11.so.6
0000014 0xb647dccd in _XReply () from /usr/lib/libX11.so.6
0000015 0xb645af83 in XGetWindowProperty () from /usr/lib/libX11.so.6
0000016 0xb7f97da2 in NETWinInfo::update () from /usr/lib/libkdeui.so.5
0000017 0xb7f9fc05 in NETWinInfo::NETWinInfo () from /usr/lib/libkdeui.so.5
0000018 0xb7f91fe3 in KWindowInfo::KWindowInfo () from /usr/lib/libkdeui.so.5
0000019 0xb7f8d6f7 in KWindowSystem::windowInfo () from /usr/lib/libkdeui.so.5
0000020 0xb7f24397 in KMainWindow::saveWindowSize () from /usr/lib/libkdeui.so.5
0000021 0xb7f25634 in KMainWindow::saveMainWindowSettings () from /usr/lib/libkdeui.so.5
0000022 0xb7f256af in KMainWindow::saveAutoSaveSettings () from /usr/lib/libkdeui.so.5
0000023 0xb7f26933 in KMainWindow::qt_metacall () from /usr/lib/libkdeui.so.5
0000024 0xb7f69f7a in KXmlGuiWindow::qt_metacall () from /usr/lib/libkdeui.so.5
0000025 0x080e94ec in MainWindow::qt_metacall ()
0000026 0xb7475ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000027 0xb7476932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000028 0xb74b1717 in QTimer::timeout () from /usr/lib/libQtCore.so.4
0000029 0xb747b6fe in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
0000030 0xb747015f in QObject::event () from /usr/lib/libQtCore.so.4
0000031 0xb6a66e9c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
0000032 0xb6a6f19e in QApplication::notify () from /usr/lib/libQtGui.so.4
0000033 0xb7e4294d in KApplication::notify () from /usr/lib/libkdeui.so.5
0000034 0xb745fa3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
0000035 0xb748ed71 in ?? () from /usr/lib/libQtCore.so.4
0000036 0xb748b4e0 in ?? () from /usr/lib/libQtCore.so.4
0000037 0xb61bab88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000038 0xb61be0eb in ?? () from /usr/lib/libglib-2.0.so.0
0000039 0xb61be268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000040 0xb748b438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
0000041 0xb6b08365 in ?? () from /usr/lib/libQtGui.so.4
0000042 0xb745e06a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
0000043 0xb745e4aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
0000044 0xb6aef310 in QDragManager::drag () from /usr/lib/libQtGui.so.4
0000045 0xb6a7a53a in QDrag::exec () from /usr/lib/libQtGui.so.4
0000046 0xb6a7a5e4 in QDrag::exec () from /usr/lib/libQtGui.so.4
0000047 0x081673ae in ProjectListView::mouseMoveEvent ()
0000048 0xb6abd9ad in QWidget::event () from /usr/lib/libQtGui.so.4
0000049 0xb6e97993 in QFrame::event () from /usr/lib/libQtGui.so.4
0000050 0xb6f3794f in QAbstractScrollArea::viewportEvent () from /usr/lib/libQtGui.so.4
0000051 0xb6fe9647 in QAbstractItemView::viewportEvent () from /usr/lib/libQtGui.so.4
0000052 0xb70240c4 in QTreeView::viewportEvent () from /usr/lib/libQtGui.so.4
0000053 0xb6f39f55 in ?? () from /usr/lib/libQtGui.so.4
0000054 0xb745ec5a in QCoreApplicationPrivate::sendThroughObjectEventFilters () from /usr/lib/libQtCore.so.4
0000055 0xb6a66e7a in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
0000056 0xb6a6fb11 in QApplication::notify () from /usr/lib/libQtGui.so.4
0000057 0xb7e4294d in KApplication::notify () from /usr/lib/libkdeui.so.5
#58 0xb745fa3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
0000059 0xb6a6eb7e in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
0000060 0xb6ade97e in ?? () from /usr/lib/libQtGui.so.4
0000061 0xb6addca7 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
0000062 0xb6b08c6a in ?? () from /usr/lib/libQtGui.so.4
0000063 0xb61bab88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000064 0xb61be0eb in ?? () from /usr/lib/libglib-2.0.so.0
0000065 0xb61be268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000066 0xb748b438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
0000067 0xb6b08365 in ?? () from /usr/lib/libQtGui.so.4
0000068 0xb745e06a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
0000069 0xb745e4aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
0000070 0xb7460959 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
0000071 0xb6a66d17 in QApplication::exec () from /usr/lib/libQtGui.so.4
0000072 0x080ca8cc in main ()
#0 0xb80ac430 in __kernel_vsyscall ()
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filespng file icon Schermafdruk-Kdenlive - The KDE Crash Handler.png [^] (37,348 bytes) 2009-06-17 23:19

- Relationships

-  Notes
(0003331)
catscanner (reporter)
2009-06-19 20:16

Steps to reproduce:
Start to import .mod files and place them in the timeline. Mostly the crash notification appears after playing a preview of the full timeline.
(0003333)
administrator (administrator)
2009-06-19 20:24

The backtrace doesn't give useful info. Can you make a small video sample available so that we can try to reproduce?
(0003372)
jmpoure (developer)
2009-06-22 15:57

Could you upgrade to Kdenlive 0.7.4, MLT 0.4.2 and a recent FFmpeg snapshot.

Also, publish an entry in the camcorder database:
http://www.kdenlive.org/video-editor [^]
(0006059)
ttill (developer)
2010-11-14 22:35

Closing, lack of response.

- Issue History
Date Modified Username Field Change
2009-06-17 23:19 catscanner New Issue
2009-06-17 23:19 catscanner File Added: Schermafdruk-Kdenlive - The KDE Crash Handler.png
2009-06-17 23:19 catscanner Build/Install Method => Distribution package
2009-06-19 20:16 catscanner Note Added: 0003331
2009-06-19 20:24 administrator Note Added: 0003333
2009-06-19 20:24 administrator Status new => feedback
2009-06-22 15:57 jmpoure Note Added: 0003372
2010-11-14 22:35 ttill Status feedback => resolved
2010-11-14 22:35 ttill Resolution open => unable to reproduce
2010-11-14 22:35 ttill Fixed in Version => 0.7.4
2010-11-14 22:35 ttill Note Added: 0006059
2010-11-14 22:35 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker