Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000953KdenliveUser Interfacepublic2009-06-23 03:472011-03-11 22:29
Reportergsking1 
Assigned To 
PrioritynormalSeveritycrashReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.6 
Summary0000953: Crash after
DescriptionSorry but I don't have much info on this one. I think I had just moved and deleted a bunch of clips, both in timeline and file selector. moving pretty fast so I don't have many more details. This after a good 45 minutes of editing. Hope it's useful.

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 0 (LWP 22707)]

Thread 3 (Thread 0xa6dfdb90 (LWP 22480)):
#0 0xb8023424 in __kernel_vsyscall ()
#1 0xb65b1412 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb66b8344 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb8016e29 in mlt_consumer_get_frame (this=0x9e895b0) at mlt_consumer.c:498
0000004 0xb80170b0 in mlt_consumer_rt_frame (this=0x9e895b0) at mlt_consumer.c:896
0000005 0xb4266e6a in consumer_thread (arg=0x9e895b0) at consumer_sdl_still.c:562
0000006 0xb65ad4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000007 0xb66a949e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xade8fb90 (LWP 22481)):
#0 0xb8023424 in __kernel_vsyscall ()
#1 0xb65b10e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb66b82ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb42664fc in consumer_thread (arg=0x91cdf08) at consumer_sdl_preview.c:381
0000004 0xb65ad4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb66a949e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5c09920 (LWP 22707)):
[KCrash Handler]
0000006 0xb734d769 in QString::operator< () from /usr/lib/libQtCore.so.4
0000007 0x080f7a8d in DocClipBase::getClipHash (this=0xdb96f00) at /usr/include/qt4/QtCore/qmap.h:104
0000008 0x0810aa15 in CustomTrackView::saveThumbnails (this=0x9fdfb10) at /home/gsking/programs/src/svn/kdenlive/kdenlive/src/customtrackview.cpp:4158
0000009 0x08080fde in MainWindow::saveFileAs (this=0x92d7900, outputFileName=@0xbfcd9ac8) at /home/gsking/programs/src/svn/kdenlive/kdenlive/src/mainwindow.cpp:1331
0000010 0x08090f6b in MainWindow::saveFile (this=0x92d7900) at /home/gsking/programs/src/svn/kdenlive/kdenlive/src/mainwindow.cpp:1365
0000011 0x0809c310 in MainWindow::qt_metacall (this=0x92d7900, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbfcd9c3c)
    at /home/gsking/programs/src/svn/kdenlive/kdenlive/build/src/cmake_bindir/mainwindow.moc:275
0000012 0xb7413ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000013 0xb74140e0 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
0000014 0xb69a9891 in QAction::triggered () from /usr/lib/libQtGui.so.4
0000015 0xb69aae0f in QAction::activate () from /usr/lib/libQtGui.so.4
0000016 0xb6e7a322 in QToolButton::nextCheckState () from /usr/lib/libQtGui.so.4
0000017 0xb6d92cd3 in ?? () from /usr/lib/libQtGui.so.4
0000018 0xb6d92fa6 in QAbstractButton::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
0000019 0xb6e7a81c in QToolButton::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
0000020 0xb6a06b43 in QWidget::event () from /usr/lib/libQtGui.so.4
0000021 0xb6d90f5e in QAbstractButton::event () from /usr/lib/libQtGui.so.4
0000022 0xb6e7d24a in QToolButton::event () from /usr/lib/libQtGui.so.4
0000023 0xb69afe9c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
0000024 0xb69b8b11 in QApplication::notify () from /usr/lib/libQtGui.so.4
0000025 0xb7dbde8d in KApplication::notify () from /usr/lib/libkdeui.so.5
0000026 0xb73fda3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
0000027 0xb69b7b7e in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
0000028 0xb6a2797e in ?? () from /usr/lib/libQtGui.so.4
0000029 0xb6a26ca7 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
0000030 0xb6a51c6a in ?? () from /usr/lib/libQtGui.so.4
0000031 0xb5f6fb88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000032 0xb5f730eb in ?? () from /usr/lib/libglib-2.0.so.0
0000033 0xb5f73268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000034 0xb7429438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
0000035 0xb6a51365 in ?? () from /usr/lib/libQtGui.so.4
0000036 0xb73fc06a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
0000037 0xb73fc4aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
0000038 0xb73fe959 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
0000039 0xb69afd17 in QApplication::exec () from /usr/lib/libQtGui.so.4
0000040 0x0807cd25 in main (argc=1, argv=0xbfcdad24) at /home/gsking/programs/src/svn/kdenlive/kdenlive/src/main.cpp:89
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003387)
gsking1 (reporter)
2009-06-23 03:57

When trying to open the file I was working on during this crash I get a popup that says "Broken clip producer 52". Then when clicking OK it crashed the first time. The second time after opening again it opens and I was able to re-save the file after some minor re-editing
(0006561)
ttill (developer)
2011-03-11 22:29

Closing because of age and no way given to reproduce.

- Issue History
Date Modified Username Field Change
2009-06-23 03:47 gsking1 New Issue
2009-06-23 03:47 gsking1 Build/Install Method => Manual build from SVN
2009-06-23 03:57 gsking1 Note Added: 0003387
2011-03-11 22:29 ttill Status new => resolved
2011-03-11 22:29 ttill Resolution open => fixed
2011-03-11 22:29 ttill Fixed in Version => 0.7.6
2011-03-11 22:29 ttill Note Added: 0006561
2011-03-11 22:29 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker