Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000960KdenliveRenderingpublic2009-06-24 15:302009-07-01 21:57
ReporterGoups 
Assigned Toadministrator 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000960: DVD wizard fails to create DVD structure
DescriptionWhen creating DVD from a previously rendered vob file (PAL 4/3 VOB 2 pass), with a simple menu (single button), the DVD wizard stops before the creation of the iso file (see attached snapshot).

Some messages appear in the progress part of the dialog ... but get immediately cleared when the error occurs.
Additional InformationThe only clue for the moment is the console output:

libpng warning: Can't write tRNS with an alpha channel
libpng warning: Can't write tRNS with an alpha channel
libpng warning: Can't write tRNS with an alpha channel
QFile::at: Cannot set file position 0
QFile::at: Cannot set file position 0
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filespng file icon DVD-Wizard.png [^] (41,368 bytes) 2009-06-24 15:30


png file icon DVD-Wizard-with-log.png [^] (51,275 bytes) 2009-06-24 23:12

- Relationships
related to 0000832closedGranjow error when creating dvd image menu 

-  Notes
(0003437)
administrator (administrator)
2009-06-24 19:04

I can't reproduce. Can you please give us more infos:

Which text was in the button, which font style and size did you use in the menu, did you set a background image or color, and which version of Qt do you have on your system?
(0003442)
Goups (reporter)
2009-06-24 21:58

Well, I did the simplest way as possible:
- added my vob file
- no chapter
- activated the check button to create a simple menu
- did not change anything in the menu settings:
  + kept the button text as is (i.e. "Lecture")
  + no background image

Qt: 4.5.0

In fact, it is not a UI thing. I followed the execution using a debugger and it is clearly dvdauthor invocation that resulted in an error.
Unfortunately, though the output of dvdauthor is captured in the error box of the wizard, this error box is immediately cleared at the end of the process and I cannot see the raised issue(s) ...
With the current behaviour, as the error box do not keep track of encountered errors, it is of little use.

I keep on investigating ...
(0003445)
administrator (administrator)
2009-06-24 22:59

I just committed a change in svn so that now the full log is visible in the DVD Wizard dialog, so please update if you can so we can get a better debug info
(0003446)
Goups (reporter)
2009-06-24 23:00

I manage to keep the files prepared by kdenlive prior to invoke dvdauthor, and then invoke dvdauthor in the console with these files: dvdauthor is crashing after tons of warnings

DVDAuthor::dvdauthor, version 0.6.14.
Build options: gnugetopt magick iconv freetype

...
WARN: Skipping sector, waiting for first VOBU...
WARN: Skipping sector, waiting for first VOBU...
WARN: System header found, but PCI/DSI information is not where expected
        (make sure your system header is 18 bytes!)
WARN: Skipping sector, waiting for first VOBU...
WARN: Skipping sector, waiting for first VOBU...
...
WARN: Skipping sector, waiting for first VOBU...
WARN: Skipping sector, waiting for first VOBU...
STAT: VOBU 0 at 0MB, 1 PGCS

Program received signal SIGSEGV, Segmentation fault.
(0003447)
administrator (administrator)
2009-06-24 23:05

Does it work if you try to create the dvd without menu? I am wondering if the problem might be with your source vob file...

Was it created with Kdenlive?
(0003448)
Goups (reporter)
2009-06-24 23:15

Same punishment without menu. By the way, I can confirm that I now benefit from error feedback I expected (DVD-Wizard-with-log.png). Thanks a lot !

The source vob file was created with Kdenlive.
(0003450)
administrator (administrator)
2009-06-24 23:22

Ok, then the problem is that the rendered file is not accepted. If you are using Kdenlive from svn, there were several fixes in the last days in MLT and Kdenlive, so I would recommend that you try to update and regenerate the vob file if possible.
(0003457)
Goups (reporter)
2009-06-25 10:13

The generated vob file was the source of the issue. Once re-generated with a fresh rebuild, everything goes right ...

As the wizard now displays what it is going on, the case can be closed :-)

- Issue History
Date Modified Username Field Change
2009-06-24 15:30 Goups New Issue
2009-06-24 15:30 Goups File Added: DVD-Wizard.png
2009-06-24 15:30 Goups Build/Install Method => Build Wizard
2009-06-24 18:33 administrator Relationship added related to 0000832
2009-06-24 19:04 administrator Note Added: 0003437
2009-06-24 19:04 administrator Status new => feedback
2009-06-24 21:58 Goups Note Added: 0003442
2009-06-24 22:59 administrator Note Added: 0003445
2009-06-24 23:00 Goups Note Added: 0003446
2009-06-24 23:05 administrator Note Added: 0003447
2009-06-24 23:12 Goups File Added: DVD-Wizard-with-log.png
2009-06-24 23:15 Goups Note Added: 0003448
2009-06-24 23:22 administrator Note Added: 0003450
2009-06-25 10:13 Goups Note Added: 0003457
2009-06-25 12:43 administrator Status feedback => resolved
2009-06-25 12:43 administrator Fixed in Version => Recent git
2009-06-25 12:43 administrator Resolution open => fixed
2009-06-25 12:43 administrator Assigned To => administrator
2009-06-27 02:17 j-b-m Target Version => 0.7.5
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:57 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker