Installing the required libraries

First step is to install the required libraries. These libraries are rather stable and part of every GNU/Linux distribution. They will be needed in the compilation process of FFmpeg, MLT and Kdenlive.

Build Script

As an alternative to this manual procedure, there is a build script that gets the latest version of Kdenlive and many of its multimedia dependencies including x264, libvpx, FFmpeg, frei0r, MLT. Then, it builds them into an isolated folder in your home directory and does not require installation. Rather, when you run it with the provided launch script, it uses the more recent libraries and plugins instead of those from packages.

Packages and Version Numbers

Version numbers of the libraries may change. If you cannot find the exact name of a library, e.g. libpango1.0-dev, try searching for a different package starting with libpango and ending with -dev. Also sometimes a version number is necessary although it is not written here (e.g. the list below says libpango-dev, but the package is called libpango1.0-dev) — or also the other way round.

When installing packages in the terminal, e.g. with
apt-get install package1 package2 …
, the Tabulator key will be a great help: Type libpango and press Tab twice to see all possible packages.

One-liner

For easier installing, this is the list of the required libraries. They are explained below.

subversion git cmake build-essential yasm libqt4-dev kdelibs5-dev libsdl1.2-dev libsdl-image1.2-dev libxml2-dev libx264-dev libtheora-dev libxvidcore-dev libogg-dev libvorbis-dev libschroedinger-dev libmp3lame-dev libfaac-dev libfaad-dev libgsm1-dev libopencore-amrnb-dev libopencore-amrwb-dev libsamplerate0-dev libjack-dev libsox-dev ladspa-sdk swh-plugins libmad0-dev libpango1.0-dev

General tools

To download the source code you will need to install Subversion and git.

  • subversion
  • git
  • cmake

Additionally required for compiling stuff:

  • build-essential
  • yasm modular assembler (for H.264 decoding)

General libraries

  • Qt 4 and KDE 4 development files (libqt4-dev and kdelibs5-dev)
  • SDL (libsdl1.2-dev, libsdl-image1.2-dev)
  • libXML2 (libxml2, libxml2-dev)

Screen capture

  • recordmydesktop

Firewire and DV capture

  • dvgrab
  • libdv (libdv4-dev)
  • libdc1394 (libdc1394-22-dev)

Audio and video codecs

  • x264 codecs (x264, libx264-dev)
  • Theora codecs (libtheora-dev)
  • Xvid codecs (libxvidcore-dev)
  • OGG (libogg-dev)
  • Vorbis (libvorbis-dev)
  • Dirac lossless codec (libschroedinger-dev)
  • Lame audio codec (libmp3lame-dev)
  • Libquicktime (libquicktime-dev)
  • faac codecs (libfaac-dev)
  • faad codecs (libfaad-dev)
  • GSM (libgsm, libgsm1-dev)
  • speech codecs (libopencore-amrnb-dev libopencore-amrwb-dev)

Sound processing and effects

  • libsamplerate (libsamplerate0-dev)
  • libJack (libjack-dev)
  • SOX (sox, libsox-dev)
  • ladspa (ladspa-sdk)
  • ladspa plugins (swh-plugins)
  • libmad (libmad0-dev)

Video effects and image processing

  • frei0r effects (frei0r-plugins, frei0r-plugins-dev) only if you do not intend to compile frei0r yourself!
  • gdk-pixbuf-dev
  • libpango1.0-dev

Warning

MLT relies on FFmpeg compilation parameters. If your distribution ships with an outdated FFmpeg version, it may not be able to use the audio and video codecs like H.264 or AVCHD. In this case, recompile FFmpeg with all needed options or ask FFmpeg packager to upgrade.

Please inform us of additional dependencies that we may have forgotten.

Comments

for OpenSuse11.0 see:

http://forums.opensuse.org/how-faq-read-only/unreviewed-how-faq/400196-k...


for Mandriva
:
install with urpmi the following packages:

subversion cmake task-c-devel task-c++-devel qt4-devel libSDL-devel
kdelibs4-devel gettext sox-devel libdv-dev jack-devel ladspa-devel

You also need to install and use the Kommander for KDE 3 version when
running this script.
 

for Kubuntu 8.10:

1) sudo apt-get update ; sudo apt-get upgrade

2) on a single line:

 

sudo apt-get install gettext kommander gawk x11proto-core-dev libxau-dev libxdmcp-dev x11proto-xext-dev libxext-dev libxi-dev x11proto-input-dev x11proto-kb-dev xtrans-dev libpthread-stubs0 libpthread-stubs0-dev libxcb1-dev libxcb-xlib0-dev libx11-dev mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev libice-dev libsm-dev x11proto-render-dev libxfixes-dev libxcursor-dev libexpat1-dev zlib1g-dev libfreetype6-dev pkg-config libfontconfig1-dev libxft-dev x11proto-xinerama-dev libxinerama-dev libxmu-headers x11proto-randr-dev libxrandr-dev libxt-dev x11proto-record-dev libxtst-dev cmake cvs libstdc++6-4.3-dev g++-4.3 g++ libxmu-dev liblcms1-dev libjpeg62-dev libmng-dev libpng12-dev xlibmesa-gl-dev libglu1-xorg-dev libaudio-dev libssl-dev libkadm55 comerr-dev libkrb5-dev libpq-dev libglib2.0-dev libsqlite0 libsqlite0-dev libqt4-dev libsoprano-dev automoc libphonon-dev libasound2-dev libgpg-error-dev libgcrypt11-dev libtasn1-3-dev libgnutls-dev libcups2-dev libdbus-1-dev libkeyutils-dev libstreams-dev libstreamanalyzer-dev libxml2-dev libxml2-utils libxslt1-dev libgif-dev libavahi-common-dev libbz2-dev libenchant-dev libattr1-dev libacl1-dev libjasper-dev libilmbase-dev libopenexr-dev libpcrecpp0 libpcre3-dev libtiffxx0c2 libtiff4-dev hspell xsltproc kdesdk-scripts kdelibs5-dev libslang2-dev libncurses5-dev libaa1-dev libapr1 libaprutil1 libartsc0-dev libaudiofile-dev libcucul-dev libcaca-dev libdirectfb-extra libsysfs-dev libdirectfb-dev libesd0-dev libneon27-gnutls libqt4-opengl-dev libsdl1.2-dev libsvn1 subversion libglib1.2ldbl libgtk1.2-common libgtk1.2 libavc1394-0 libiec61883-0 libfreebob0 libjack0 libsndfile1 jackd ladspa-sdk libavutil49 libgsm1 libavcodec51 libdv4 libfaad0 libjack-dev libmad0 libmad0-dev libogg-dev libpopt-dev libqt4-gui libswscale0 libquicktime1 libsamplerate0-dev libvorbis-dev qjackctl dvgrab libdv-bin libdv4-dev libfaac0 libfaac-dev libfaad-dev libmp3lame0 libmp3lame-dev libtheora-dev

taken from:

http://kde-apps.org/content/show.php/Kdenlive+Builder+Wizard?content=85826

Kubuntu is a Debian system. So you only need to run:

apt-get build-dep ffmpeg to build FFmpeg dependant libraries. Then you can compile FFmpeg by hand.

Same applies for MLT and Kdenlive, after using our repositories:

apt-get build-dep mlt

apt-get build-dep kdenlive

thx jmpoure,

i didn't know abut apt-get build-dep and had been whiling away the hours individually gathering and compiling every dependency. when i could have let apt-get do it for me. you saved me a bunch of time and frustration thx. jayson

Based on the configure command line you specified -dev libraries are also needed for:

libopencore-amrwb
libopencore-amrnb
libxvid
libdc1394

and FWIW it builds nicely on a Kubuntu 10.4 system ...

Pages