0.75 on ubuntu intrepid sound delay bug

I have installed kdenlive 0.75 for ubuntu intrepid following your instructions.
after install i found that the sound of the video clip I dragged into the timeline is in delay.

It can start fine and with sync and then when I move the cursor to forward the clip the sync is gone and the sound delayed.

In the previous version it was fine.


can you explain how, please?

Never mind, I found it. settings, right?

It doesn't work. same problem.
b.t.w, I experiance it also in avidemux.
Maybe a kernel issue?

Well, I installed mint 7 gloria which is ubuntu jaunty,
and still I have the Same bug.
The video and the sound are not in sync.

I tried Erasing PulseAudio like the link you gave me suggested,
All went well exept that I couldn't find the asound.conf file in the location specified.

I continued anyway, and installed Esound package as well as changing the driver in kdenlive settings to alsa.
Still sound delay and not syncing with video.

I am really clueless.

I'm starting to think it's not a big in kdenlive.
I tried Kino and there seem to be the same problem there.

avidemux is fine.

What could be the reason that both kdenlive and kino are having sound out of sync?

I am also having this problem - I tried the link above and it did not work for me. Uninstalling PulseAudio did nothing to help my sync problems.

I am running kdenlive 0.7.5 on Ubuntu Jaunty Jackalope (AMD64).

Like others, the project playback works fine the first time I start from the beginning, but once I move the timeline around it gets out of sync, and is out of sync after rendering.

This link seems to indicate something that might help, about .WMV having variable frame rates?


Ok, so I found a workaround - transcode the .wmvs to .mp4, h264 video codec, aac audio codec, using ffmpeg. This sucks because the result is lossy, but at least I was able to get the clips working (somewhat) in kdenlive, enough that I could do some desktop recording of them for my tutorial video.

Another problem I am having is rendering - no matter what I do, when I render the video the video is sped up to twice the audio speed - the audio plays as I want it, the video has me looking like a chipmunk :(

Finally, none of the h.264, xvid, or other options are available to me upon rendering, only things like Theora and AVI. I'll start another thread on how to enable the others, so as not to hijack this one.

mp4 did not help.

What did help was encoding the video files in the .dv format using avidemux.

Now kdenlive is up and running with no delay.

I came back here after I was having sync issues with Kdenlive 0.7.3 and then 0.7.5. Was totaly frustrated as I didn't want to keep going back to windows to edit! Today I installed kernel update for Kubuntu Jaunty (15).
It has solved both my audio sync and crashing!

I have problems with this sound delay bug in Ubuntu 9.04 and Arch Linux (Kdenlive 0.7.5 and SVN (from today, so nearly 0.7.6?)) with my ogg-files.

The first half-second isn't there (the file in Kdenlive starts half a second later), the sound stops about 1 second before it should (although the project-manager/thumbnail says: everything okay here) and after a second/third "loop", it stops about 2 seconds before it should. So if I place my ogg-file 3 times in a row, there is a "sound gap" between the ogg-files (and getting bigger, the longer the project is). And sometimes, my 1 min long ogg-file is only 52 seconds long. Don't know why.

Also pausing the project and resuming it also inflicts a sound delay (it starts about half a second before I paused it, although I already heard the part).

This doesn't happen, if I convert the ogg-files into wav-files. So with wav-files, everything is okay. No delay, no problem with pause and resume. No trouble at all. I had a poor quality mp3 (and only mono), where I didn't experienced the problem too. So maybe some audio-formats don't work that well in Kdenlive?

Interesting. Might be related to FFmpeg version/build-configuration or whatever created them and the versions of libs it used. I have used successfully use Ogg Vorbis with Kdenlive many times.