60i DVD from 60i AVCHD (or MPEG4)

Hello,

I've been trying to create 60i DVD's (720x480) from 60i 1440x1080 AVCHD files, with no success.

The result always comes out as 30 fps, in which each frame is composed of both fields, filtered and superimposed (not interlaced), as if a deinterlace method was used. It can clearly be seen if the camera does a horizontal pan.

I tried all of the DVD formats, and tried "force interlaced", and the result is the same.

I also converted my AVCHD source material to MPEG4 at 60i 1440x1080 (which looks good) and then tried to render to 60i DVD. No success either.

Has anyone had success in creating a 60i DVD and watched it on TV with a smooth 60Hz motion?

I have Kdenlive 0.7.5 and MLT 0.4.4.

Thanks
Eduardo

Bumper?

Nobody uses DVDs anymore???

The scaler is not field-aware. Therefore, when MLT detects that you are resizing the vertical dimension it forces a deinterlace. Sorry, I will add field-based scaling to the MLT ToDo list.

Thanks! That would be really great, allowing us to create nice full-framerate DVDs that we can give to our moms and dads to watch on their TVs.

It would also allow for the professional production of DVDs. 30fps DVDs would be unacceptable in the professional realm.

Strangely, it seems to be impossible for ffmpeg or mencoder to reduce resolution without deinterlacing... Is MLT a library that uses libavcodec?

Do you know of a command-line way to do field-aware scaling? I could reduce my source material to 720x480x60i before editing. I assume Kdenlive would export it correctly if it's not scaling...

Thanks
Eduardo

do you have a blue rayplayer and hd-tv cus if you don't it will not work even if you do make the DVD. DVD are 29.97, 720x480, that's in the professional realm. Blue-ray players open up those options but only on a HD TV. normal TV only scan at 29.97 but your DVD play should slow it automatically for you. although i find that NTSC plays tend to suck, so make it 29.97 if you can to begin with.

Alabandit:

DVDs are 29.97 interlaced (60 fields per second), or 60i. For scenes with movement, the two fields are different and separate in time, producing smooth motion. The resulting frame rate is 60 Hz.

A DVD that was created from 30 Hz material has an actual frame rate of 30 Hz. Movement will be less fluid than 60 Hz. This is not professional. Especially if the original material was in 60i and something got lost in the process.

The problem is that Kdenlive only generates 30 Hz material.

What is getting lost is field information during the resize. The library used by Kdenlive apparently is unable to resize field-by-field, only frame-by-frame.

Eduardo

PS: I'm having a hard time with this issue in iMovie as well. It seems that only Final Cut and similar tools can do it. I hope Kdenlive wins the race with iMovie to have this fixed! :)